Jump to content

Subquake's Undead Legacy


Subquake

Recommended Posts

33 minutes ago, Labaffe69 said:

Is there a way to upgrade steel block to stainless steel block?

No and there won't be. A20 vanilla will change block tiers, shapes and things anyway (if you have been paying attention to what TFP talk about a20 and their dev streams about it) :)

I'll fiddle around with adding more block tiers once A20 Experimental is available for us to play around with :)

Edited by Subquake (see edit history)
  • Like 1
Link to comment
Share on other sites

1 hour ago, Zyamaia said:

Hi SQ, great mod as usual but I found kind of an discrepancy.  The repairable 4x4 trucks need a car repair kit not a truck repair kit.  LOL saved up the resources to repair one and it said I needed the car one.   

It's a known oversight on my part, where I live trucks are big vehicles (semi-trucks etc), with more than 4 wheels, to me the vanilla 4x4 Truck is a car, since it doesn't have a v12 engine, which the truck repair kit is based off of. The names of the repair kits will be renamed to make it less confusing in the future :)

Link to comment
Share on other sites

5 minutes ago, DMon87 said:

Is it Okay that traders doesn't show distance to quest place?

It's a bug for russian localization, the guy who was doing the translation made a typo. You can get the fixed localization file from his github:
https://github.com/Kelthuzer/7D2D_UL_Localization/tree/main

The fix will be applied with next big update, but it's not going to be ready for about a month.

Link to comment
Share on other sites

I found a minor bug, or at least inconsistency. The tier 2 furnace will burn you if you're standing on it, even if it is off. Even if you newly placed it and haven't added wood yet. The tier 1 furnace doesn't do this. I was concerned it might be affecting activity level but as far as I can tell it doesn't. Now, there's not much reason to stand on a furnace but I'm thinking T1 and T2 should behave the same.

Link to comment
Share on other sites

Can Horde Night Be Disabled ?

 

I started a game and set Blood moon Frequency to 'Disabled', believing that this would eliminate horde night. However, on the 9th night the standard blood moon sequence (6:00pm thunder/red sky/horde) occurred.  Is the blood moon a mandatory occurrence  or can it be disabled ?

 

Thanks

 

Link to comment
Share on other sites

20 hours ago, newbie said:

Can Horde Night Be Disabled ?

 

I started a game and set Blood moon Frequency to 'Disabled', believing that this would eliminate horde night. However, on the 9th night the standard blood moon sequence (6:00pm thunder/red sky/horde) occurred.  Is the blood moon a mandatory occurrence  or can it be disabled ?

 

Thanks

 

 

I'm on day 68 of a game I started with bloodmoon disabled. Haven't had a bloodmoon. I am on the a19.5 version though.

Link to comment
Share on other sites

On 10/21/2021 at 9:13 AM, newbie said:

Can Horde Night Be Disabled ?

I started a game and set Blood moon Frequency to 'Disabled', believing that this would eliminate horde night. However, on the 9th night the standard blood moon sequence (6:00pm thunder/red sky/horde) occurred.  Is the blood moon a mandatory occurrence  or can it be disabled ?

25 minutes ago, newbie said:

(..) will wait for the dev to respond (..)

Mod doesn't change how those settings work. If you disabled blood moons, but they are still happening, there's something else going on, but the issue isn't mod related.

Link to comment
Share on other sites

 

It appears that the 'Persistent User Profile' option is involved:   

 

1. Game 1 with this mod:  'Persistent Profile' = true, Blood Moon Frequency = 9 using 6K map gen'd by King Gen tool:               Blood Moon occurred on day 9

2. Game 2:  Same 6K map as 1st game, Persistent Profile = true but Blood Moon Frequency set to Disabled:                                Blood Moon occurred on day 9 again

3. Game 3: Gen'd new 4K map using King Gen tool, Persistent Profile = true and Blood Moon Frequency set to disabled:            Blood Moon occurred on day 9 again

4. Game 4: Re-used 6K map from Game 1&2, Persistent User Profiles set to 'off' and  Blood Moon Frequency set to 'Disabled':   No Blood Moon on day 9 

 

I don't really understand what that option does, why it would cause this and I couldn't find any detailed information about it online. 

 

Thanks for such an amazing mod 

 

  • Have a Cookie 1
Link to comment
Share on other sites

Is there a way to stop, or at least minimize, vehicles from jumping around and teleporting? Some examples. The other day I moved a military truck to a different parking spot to get it out of the way. A bit later I noticed it was back in the original spot. Then later, it was in the new spot again. This back and forth happened several times. If I wasn't in SP I'd swear I was being trolled. Today I moved a number of vehicles into an underground garage I've been building. I took a trip to the trader and as I returned, one of my military trucks flipped up in the air and landed on its back. I had moved it and another one before I left and they were now back in the original spots. And, 5 of the vehicles I had put in the garage were now on the surface again, back in their original parking spots. I've had vehicles move a little in vanilla, but nothing like this.

 

Edit: Just realized, one of the vehicles that was in the garage was also duplicated.

Edited by seven (see edit history)
Link to comment
Share on other sites

2 hours ago, seven said:

Is there a way to stop, or at least minimize, vehicles from jumping around and teleporting? Some examples. The other day I moved a military truck to a different parking spot to get it out of the way. A bit later I noticed it was back in the original spot. Then later, it was in the new spot again. This back and forth happened several times. If I wasn't in SP I'd swear I was being trolled. Today I moved a number of vehicles into an underground garage I've been building. I took a trip to the trader and as I returned, one of my military trucks flipped up in the air and landed on its back. I had moved it and another one before I left and they were now back in the original spots. And, 5 of the vehicles I had put in the garage were now on the surface again, back in their original parking spots. I've had vehicles move a little in vanilla, but nothing like this.

 

Edit: Just realized, one of the vehicles that was in the garage was also duplicated.

Those are all vanilla issues. They are aware of the duping but I haven't heard much about it being worked on/fixed. The bouncing I assume is possibly due to the vehicle either loading in before the terrain, or loading in after it but down in it just enough to cause them to spring out. Or it could be the game doing it unstick thing like it does with players.

Link to comment
Share on other sites

No, it's more  than just the duping in vanilla, and a little bouncing around. I had 3 of the humvee vehicles. I now have 6. I thought maybe the game wasn't saving the position of the vehicles, so I exited the game and entered, and repeated this a few times. The vehicles keep moving now every time I log in. A couple screen shots to illustrate. And I may have solved the duplication issue, I think they are mating.

 

 

A19.5_2021-10-30_19-20-20.jpg

A19.5_2021-10-30_19-21-18.jpg

A19.5_2021-10-30_19-11-11.jpg

Edited by seven (see edit history)
Link to comment
Share on other sites

Any idea what may be causing it? The duplication isn't a bother, I can just throw away the extras. For now, I'm storing my vehicles in a box, but the idea was to collect vehicles and fill my garage. Now my multi-level garage seems rather pointless. Or, more pointless than it was ;)

Link to comment
Share on other sites

Hello, tell me what the problem may be: we are playing in the 2nd with a friend through a dedicated server (launched from the game client on a laptop). My PC configuration is AMD Phenom II X4 925 2.3 Ghz, 8 Gb DDR2 RAM, RX 450 2 GB, the game is installed on SATA I HDD 5200. I don't experience any problems except firs when opening inventory. My friend's configuration is AMD Ryzen 3 3100 3.1 Ghz, 16 Gb RAM 3200 Mhz, RX 3060 12GB, the game is installed on a PCI-E 4.0 SSD. When playing, a friend also experiences the friezes of opening inventory, the game works on any quality settings. But when the RAM is filled with 12 GB after a while, the game crashes. Fatal error. What can be done? As far as I know, a friend does not use a swap file, since he does not want to waste the SSD's service life, I use a 7990 Mb swap file. What can be done?

 

Earlier I searched the forum for a similar problem, but no solution was found.☹️

Link to comment
Share on other sites

18 hours ago, seven said:

Any idea what may be causing it? The duplication isn't a bother, I can just throw away the extras. For now, I'm storing my vehicles in a box, but the idea was to collect vehicles and fill my garage. Now my multi-level garage seems rather pointless. Or, more pointless than it was ;)

What I have been told and observed so far is that the vehicle manager saves every 5 minutes, what helps is if you don't move your vehicles or don't interact with them for at least 5 minutes before shutting down a server, logging off or quitting the save. I have my own dedicated server where I played and I ran it 24/7, never had issues with vehicles duping and while working on making the mod (single player) it happened to me only once like a month ago, but that's when I do a lot of ALT+F4, force quits and don't care about the 5 minut rule.

5 hours ago, Statsz said:

Hello, tell me what the problem may be: we are playing in the 2nd with a friend through a dedicated server (launched from the game client on a laptop). My PC configuration is AMD Phenom II X4 925 2.3 Ghz, 8 Gb DDR2 RAM, RX 450 2 GB, the game is installed on SATA I HDD 5200. I don't experience any problems except firs when opening inventory. My friend's configuration is AMD Ryzen 3 3100 3.1 Ghz, 16 Gb RAM 3200 Mhz, RX 3060 12GB, the game is installed on a PCI-E 4.0 SSD. When playing, a friend also experiences the friezes of opening inventory, the game works on any quality settings. But when the RAM is filled with 12 GB after a while, the game crashes. Fatal error. What can be done? As far as I know, a friend does not use a swap file, since he does not want to waste the SSD's service life, I use a 7990 Mb swap file. What can be done?

 

Earlier I searched the forum for a similar problem, but no solution was found.☹️

Memory leaks unfortunately happen, the longer you play. You can try mitigating it somewhat by executing a console command in the game: memcl, it clears up some of the junk in memory. That's all you can really do for now, but as for the future, TFP said they have done a lot of optimization in A20 and on top of that, next update of Undead Legacy will feature optimizations of it's own and completely reworked User Interface, there's much less lag of what you speak of, BUT there's no plans to release next update for the mod before a20 and it will be at least a few weeks until I update everything to work with a20 changes.

Link to comment
Share on other sites

2 hours ago, Izuku Midoriya said:

Hi ! Where can i find car engine because i looked everywhere, used the wrench on every cars that i passed but didn't found one. I've looked on the research station but no blueprint too for craft it, it is a bug or something ? Plz help me ! =(

Keep wrenching cars, that are lootable or repairable, the husks, that you cannot interact with have 0% chance to give you one.

  • Thanks 1
Link to comment
Share on other sites

On 10/31/2021 at 7:44 AM, seven said:

Any idea what may be causing it? The duplication isn't a bother, I can just throw away the extras. For now, I'm storing my vehicles in a box, but the idea was to collect vehicles and fill my garage. Now my multi-level garage seems rather pointless. Or, more pointless than it was ;)

Most likely, this is due to the use of the creative menu and debag menu options, there was no duplication during normal play, when the creative and debag menu was activated, the car was doubling when lifting and bifurcating it, the car was both at the place where it arrived and at the place where the game started when loading.

Link to comment
Share on other sites

hey Subquake! really glad to know that you are still active and (I hope) in good health, after quite long time without new patch notes I was afraid you either dropped project or having rl issues.

 

after a half-yeah or smth pause I've started another SP run with UL on a krunchland and must say that balance wise UL made a huge step forward. better economy, reworked research and tiers systems and rebalanced skills growth give a feeling of much more polished game. there is space for more balancing ofc, but imho difference between up-to-date UL and one from half-year back is immense.

 

when I finish this playthrough I will leave detailed report on what can be improved imho like last time. hope you don't mind.

 

also shoutout to captainkrunch. krunchland is awesome, the more I'm playing on it the clearer its getting how much love invested in it. its impossible to get back to nave or rng map after that handmade beauty. the only issue I'm having so far is real lack of some kind of boat. mb there is one from mod fully compatible with UL?

Edited by Caites (see edit history)
  • Like 1
Link to comment
Share on other sites

@Caites I am very much active and have been actively working on Undead Legacy with a healthy and steadily growing community over discord. Things however do take time, because I'm still developing it pretty much on my own with a bit of help from community members with translations for other languages (German, Spanish and Polish translations are supposedly being worked on right now, but I don't keep tabs on that, when they will be ready, they will be ready).

 

There might be a while till next big update for Undead Legacy, because I'm in the process of reworking and optimizing some of the backend code, the user interface has been immensely improved with more options and will be less laggy as a result. A handful of other features are being tweaked and changed as well, that would require a complete restart and not compatible with old saves and because of that and how close supposedly A20 release is, I don't want to disturb any current players of Undead Legacy with an update so close to A20 release, that would require a new game.

There is a roadmap available for the mod on my website, if you are interested in what's planned for the future:

https://ul.subquake.com/roadmap (P.S. Host is having some technical issues right now so uptime for the site might be chaotic for the upcoming few days)

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

7 hours ago, Shezarr said:

Most likely, this is due to the use of the creative menu and debag menu options, there was no duplication during normal play, when the creative and debag menu was activated, the car was doubling when lifting and bifurcating it, the car was both at the place where it arrived and at the place where the game started when loading.

 

I haven't been using creative or debug options but I've had about 14 vehicle duplications now. In nearly 3k hours in the game I've only had 3 or 4 duplications prior to this. And again, it's not the dupes that bother me so much, it's the vehicles moving back and forth between locations where I've left them. In the screenshots I posted earlier you can see vehicles parked in one spot have moved to another after logging in again. What I didn't show (because they were dark and harder to see) were following screenshots as I logged in multiple times where the vehicles moved back and forth between positions. It's like there are two (or more) positions saved for the same vehicle. I do wonder if there is bad data in my save, not enough to stop loading, but enough to cause problems.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...