Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

Doesn't work for me

 

The Mod Launcher generates a small serverconfig.xml, and passes the --configfile=SaveConfig.xml parameter to it, when you click on Save All Games Local To Mod. Inside this SaveCOnfig.xml is just this:

 

It doesn't work for me. I found the SaveConfig.xml File (copied it from a Mod that i installed through 7d2dModLauncher) and changed the patch for the Saves accordingly. How do i have to use the --configfile=SaveConfig.xml.

 

I tried with the 7DaysToDie.exe (Shortcut on Desktop to C:\PathTo7d2d\7DaysToDie.exe --configfile=SaveConfig.xml) but it didn't work. Still my default Saves in %appdata%

 

Kind regards

Share this post


Link to post
Share on other sites
It doesn't work for me. I found the SaveConfig.xml File (copied it from a Mod that i installed through 7d2dModLauncher) and changed the patch for the Saves accordingly. How do i have to use the --configfile=SaveConfig.xml.

 

I tried with the 7DaysToDie.exe (Shortcut on Desktop to C:\PathTo7d2d\7DaysToDie.exe --configfile=SaveConfig.xml) but it didn't work. Still my default Saves in %appdata%

 

Kind regards

 

try C:\PathTo7d2d\7Daystodie.exe -configfile=C:\Pathto7d2d\SaveConfig.xml

Share this post


Link to post
Share on other sites

Launcher Not Working

 

I installed the Launcher 2 days ago with no issues, all the mods showed in the left pane and I selected one followed instruction and all was good. I tried to log in the next day and all the mods in the left pain are missing along with the mod I downloaded. I tried to uninstall and reinstall to no avail. There is a piece of the program that does not allow full uninstall and I am not sure were to look. Also, when I uninstalled, I deleted the 7d2d folder, after the reinstall attempt the folder is still missing. There is an error that shows in the log, maybe this will help diagnose the issue.

 

INFO 1 _7D2DLauncher.frmMain - New Start - 1/10/2018 4:41:26 PM

INFO 1 _7D2DLauncher.frmMain - ==================================================

INFO 1 _7D2DLauncher.frmMain - Udating Remote Server list

INFO 1 _7D2DLauncher.frmMain - Done reading remote server list.

INFO 1 _7D2DLauncher.frmMain - Checking Steam Path: d:\\steam\steamapps\common\7 Days To Die\

INFO 1 _7D2DLauncher.frmMain - Reading d:/steam\Config\config.vdf file for alternate Steam files

INFO 1 _7D2DLauncher.frmMain - GroupName or Server Name does not exist yet.

INFO 1 _7D2DLauncher.frmMain - GroupName or Server Name does not exist yet.

INFO 1 _7D2DLauncher.frmMain - Setting up Default View

INFO 1 _7D2DLauncher.frmMain - Could not process RSS feed: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 66.6.33.21:80

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.HttpWebRequest.GetResponse()

at System.Xml.XmlDownloadManager.GetNonFileStream(Uri uri, ICredentials credentials, IWebProxy proxy, RequestCachePolicy cachePolicy)

at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn)

at System.Xml.XmlTextReaderImpl.FinishInitUriString()

at System.Xml.XmlReaderSettings.CreateReader(String inputUri, XmlParserContext inputContext)

at _7D2DLauncher.frmMain.UpdateRSSFeed(String strRSSFeed)

INFO 1 _7D2DLauncher.frmMain - Error reading from Default List: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 151.101.20.133:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.OpenRead(Uri address)

at _7D2DLauncher.frmMain.loadExamplesToolStripMenuItem_Click(Object sender, EventArgs e)

INFO 1 _7D2DLauncher.frmMain - Error reading from Default List: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 151.101.20.133:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.OpenRead(Uri address)

at _7D2DLauncher.frmMain.GetRecentChanges()

INFO 1 _7D2DLauncher.frmMain - Updating TreeView Mods

INFO 1 _7D2DLauncher.frmMain - Reading Logo: System.Drawing.Bitmap

INFO 1 _7D2DLauncher.frmMain - Updated TreeView Mods

 

 

Thanks

Share this post


Link to post
Share on other sites
try C:\PathTo7d2d\7Daystodie.exe -configfile=C:\Pathto7d2d\SaveConfig.xml

 

it works now. thank you so much for the help! :)

Share this post


Link to post
Share on other sites
I installed the Launcher 2 days ago with no issues, all the mods showed in the left pane and I selected one followed instruction and all was good. I tried to log in the next day and all the mods in the left pain are missing along with the mod I downloaded. I tried to uninstall and reinstall to no avail. There is a piece of the program that does not allow full uninstall and I am not sure were to look. Also, when I uninstalled, I deleted the 7d2d folder, after the reinstall attempt the folder is still missing. There is an error that shows in the log, maybe this will help diagnose the issue.

 

INFO 1 _7D2DLauncher.frmMain - New Start - 1/10/2018 4:41:26 PM

INFO 1 _7D2DLauncher.frmMain - ==================================================

INFO 1 _7D2DLauncher.frmMain - Udating Remote Server list

INFO 1 _7D2DLauncher.frmMain - Done reading remote server list.

INFO 1 _7D2DLauncher.frmMain - Checking Steam Path: d:\\steam\steamapps\common\7 Days To Die\

INFO 1 _7D2DLauncher.frmMain - Reading d:/steam\Config\config.vdf file for alternate Steam files

INFO 1 _7D2DLauncher.frmMain - GroupName or Server Name does not exist yet.

INFO 1 _7D2DLauncher.frmMain - GroupName or Server Name does not exist yet.

INFO 1 _7D2DLauncher.frmMain - Setting up Default View

INFO 1 _7D2DLauncher.frmMain - Could not process RSS feed: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 66.6.33.21:80

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.HttpWebRequest.GetResponse()

at System.Xml.XmlDownloadManager.GetNonFileStream(Uri uri, ICredentials credentials, IWebProxy proxy, RequestCachePolicy cachePolicy)

at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn)

at System.Xml.XmlTextReaderImpl.FinishInitUriString()

at System.Xml.XmlReaderSettings.CreateReader(String inputUri, XmlParserContext inputContext)

at _7D2DLauncher.frmMain.UpdateRSSFeed(String strRSSFeed)

INFO 1 _7D2DLauncher.frmMain - Error reading from Default List: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 151.101.20.133:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.OpenRead(Uri address)

at _7D2DLauncher.frmMain.loadExamplesToolStripMenuItem_Click(Object sender, EventArgs e)

INFO 1 _7D2DLauncher.frmMain - Error reading from Default List: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 151.101.20.133:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.OpenRead(Uri address)

at _7D2DLauncher.frmMain.GetRecentChanges()

INFO 1 _7D2DLauncher.frmMain - Updating TreeView Mods

INFO 1 _7D2DLauncher.frmMain - Reading Logo: System.Drawing.Bitmap

INFO 1 _7D2DLauncher.frmMain - Updated TreeView Mods

 

 

Thanks

 

Seems like some filtering is going on. Can you click on Disable SSL, and restart the launcher to see if the list is restored?

Share this post


Link to post
Share on other sites

trying to play some of the mods and when i click play game it launches the game then before the game even pops up it says 7 days to die has stopped working. the mods that ive tried so far are GNAMOD and True Survival. none of them worked so far but when i first got the mod launcher i played Valmod and it worked fine but also isnt working.

Edited by bbisd12 (see edit history)

Share this post


Link to post
Share on other sites
trying to play some of the mods and when i click play game it launches the game then before the game even pops up it says 7 days to die has stopped working. the mods that ive tried so far are GNAMOD and True Survival. none of them worked so far but when i first got the mod launcher i played Valmod and it worked fine but also isnt working.

 

Sorry for the trouble. Let's see if we can get you sorted out.

 

Sorry for the trouble.

 

Let's figure out what the issue is. After the game fails, can you click on the View Menu, then log files?

 

PIck the output_log.txt, and click on Upload Log file. It'll give you a pastebin.com link that you can give to me.

Share this post


Link to post
Share on other sites
I installed the Launcher 2 days ago with no issues, all the mods showed in the left pane and I selected one followed instruction and all was good. I tried to log in the next day and all the mods in the left pain are missing along with the mod I downloaded. I tried to uninstall and reinstall to no avail. There is a piece of the program that does not allow full uninstall and I am not sure were to look. Also, when I uninstalled, I deleted the 7d2d folder, after the reinstall attempt the folder is still missing. There is an error that shows in the log, maybe this will help diagnose the issue.

 

INFO 1 _7D2DLauncher.frmMain - New Start - 1/10/2018 4:41:26 PM

INFO 1 _7D2DLauncher.frmMain - ==================================================

INFO 1 _7D2DLauncher.frmMain - Udating Remote Server list

INFO 1 _7D2DLauncher.frmMain - Done reading remote server list.

INFO 1 _7D2DLauncher.frmMain - Checking Steam Path: d:\\steam\steamapps\common\7 Days To Die\

INFO 1 _7D2DLauncher.frmMain - Reading d:/steam\Config\config.vdf file for alternate Steam files

INFO 1 _7D2DLauncher.frmMain - GroupName or Server Name does not exist yet.

INFO 1 _7D2DLauncher.frmMain - GroupName or Server Name does not exist yet.

INFO 1 _7D2DLauncher.frmMain - Setting up Default View

INFO 1 _7D2DLauncher.frmMain - Could not process RSS feed: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 66.6.33.21:80

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.HttpWebRequest.GetResponse()

at System.Xml.XmlDownloadManager.GetNonFileStream(Uri uri, ICredentials credentials, IWebProxy proxy, RequestCachePolicy cachePolicy)

at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn)

at System.Xml.XmlTextReaderImpl.FinishInitUriString()

at System.Xml.XmlReaderSettings.CreateReader(String inputUri, XmlParserContext inputContext)

at _7D2DLauncher.frmMain.UpdateRSSFeed(String strRSSFeed)

INFO 1 _7D2DLauncher.frmMain - Error reading from Default List: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 151.101.20.133:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.OpenRead(Uri address)

at _7D2DLauncher.frmMain.loadExamplesToolStripMenuItem_Click(Object sender, EventArgs e)

INFO 1 _7D2DLauncher.frmMain - Error reading from Default List: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions 151.101.20.133:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.OpenRead(Uri address)

at _7D2DLauncher.frmMain.GetRecentChanges()

INFO 1 _7D2DLauncher.frmMain - Updating TreeView Mods

INFO 1 _7D2DLauncher.frmMain - Reading Logo: System.Drawing.Bitmap

INFO 1 _7D2DLauncher.frmMain - Updated TreeView Mods

 

 

Thanks

 

I have the same problem.The launcher worked for 3 weeks and now its blank.I have uninstalled and reinstalled many times,I have marked the disable SSL.I cant get anything to work any help would be great Thanks

Share this post


Link to post
Share on other sites
I have the same problem.The launcher worked for 3 weeks and now its blank.I have uninstalled and reinstalled many times,I have marked the disable SSL.I cant get anything to work any help would be great Thanks

 

Sorry for the trouble. If the Disable SSL doesn't work, you can try to go into File -> Clear - Clear Mod History, then restart the mod launcher and see if the list is restored.

 

I'm not sure where the IP for 151.101.20.133:443 is coming from. Looks like some kind of proxy / redirection. If the above doesn't work, please try running Malware Bytes anti-spyware, or check your proxy settings.

Share this post


Link to post
Share on other sites
Sorry for the trouble. If the Disable SSL doesn't work, you can try to go into File -> Clear - Clear Mod History, then restart the mod launcher and see if the list is restored.

 

I'm not sure where the IP for 151.101.20.133:443 is coming from. Looks like some kind of proxy / redirection. If the above doesn't work, please try running Malware Bytes anti-spyware, or check your proxy settings.

 

I went into the file and there was one folder the BB Mod I deleted it and restarted and it works.I dont know why that worked but it did thanks

Share this post


Link to post
Share on other sites

Reinstalling launcher with old data/saves? Help?

 

Hey Sphereii or any other PC genus...

 

I have reinstalled Windoze as well as my Steam library and would LOVE to play my old saves of Starvation and other mods via the launcher. However, when I d/load the launcher and go to install it, it forces me into a new save folder and any attempt to merge my game data does not work i.e. dragging folders etc

 

Can anyone advise?

Share this post


Link to post
Share on other sites
Hey Sphereii or any other PC genus...

 

I have reinstalled Windoze as well as my Steam library and would LOVE to play my old saves of Starvation and other mods via the launcher. However, when I d/load the launcher and go to install it, it forces me into a new save folder and any attempt to merge my game data does not work i.e. dragging folders etc

 

Can anyone advise?

 

When you say your saves of starvation, is that for older installs of the mod, or your actual save games?

Share this post


Link to post
Share on other sites

My actual saves. Like from last Friday when we played the current version. I managed to backup my data via the backup feature in steam and have installed from the backup but it's the launcher I can't get to install in the same spot....

Share this post


Link to post
Share on other sites
My actual saves. Like from last Friday when we played the current version. I managed to backup my data via the backup feature in steam and have installed from the backup but it's the launcher I can't get to install in the same spot....

 

I think your saves will be stored under your %APPDATA% folder. I'm not familiar with Steam Back up or restore. Do you know for certain it actually backs up your local saves as well as your game files?

Share this post


Link to post
Share on other sites
I think your saves will be stored under your %APPDATA% folder. I'm not familiar with Steam Back up or restore. Do you know for certain it actually backs up your local saves as well as your game files?

 

Unless they have completely rewritten the backup feature on Steam it doesn't touch your game saves. At least it didn't the last time I messed around with it.

Share this post


Link to post
Share on other sites
I think your saves will be stored under your %APPDATA% folder. I'm not familiar with Steam Back up or restore. Do you know for certain it actually backs up your local saves as well as your game files?

 

No, I don't think so. Would be amazing if it did. Unfortunately every game is different. 7D2D puts your saves in C drive even if your steam and your game files are in your D drive for example. I was just hoping I could merge data. I'm still getting used to working with the back end of the games rather than just game play. Thanks anyway Sphereii.

Share this post


Link to post
Share on other sites

Good Morning Sphereii

 

Has anyone else report a very slow start for WOW 5.2. with latest update. From the time I hit "Play mod" it took about 5 min just to get into the 7d2d launch window and another 3 minutes to get into game.

Slower than it was by a lot.

 

Just wondering and Have a Great weekend .. give a thanks now .. in-case I miss you

Share this post


Link to post
Share on other sites
Good Morning Sphereii

 

Has anyone else report a very slow start for WOW 5.2. with latest update. From the time I hit "Play mod" it took about 5 min just to get into the 7d2d launch window and another 3 minutes to get into game.

Slower than it was by a lot.

 

Just wondering and Have a Great weekend .. give a thanks now .. in-case I miss you

 

Hey gpcstargate. Happy new year! :)

 

5.2 isn't that much bigger than the older release, however, github could have been experiencing an issue, or the ISP may have had a slow down. Let me know if the problem persists, or if anyone else is seeing the same issue.

Share this post


Link to post
Share on other sites

I am having trouble getting the launcher to launch. It worked fine until one day it didn't. I thought it may have become corrupted so I removed it and downloaded it from the Link- Option1. It tried to start just as the previous file but it failed. I tried Option2, but it never opened as well. I did download the zipfile - Option3 and it allowed me to play the mods that were previously downloaded and played. So that is all good. Unfortunately it wont download new mods. It doesn't seem to want to copy the game from my drive as well. I am currently trying to download it from Steam. Not sure what issue I am having as I have searched the thread for similar issues. Running Windows10. Thanks for help in advance.

Share this post


Link to post
Share on other sites
I am having trouble getting the launcher to launch. It worked fine until one day it didn't. I thought it may have become corrupted so I removed it and downloaded it from the Link- Option1. It tried to start just as the previous file but it failed. I tried Option2, but it never opened as well. I did download the zipfile - Option3 and it allowed me to play the mods that were previously downloaded and played. So that is all good. Unfortunately it wont download new mods. It doesn't seem to want to copy the game from my drive as well. I am currently trying to download it from Steam. Not sure what issue I am having as I have searched the thread for similar issues. Running Windows10. Thanks for help in advance.

 

Sorry for the trouble. Let's see if we can get you sorted with the first problem, then we can move unto the next problem.

 

What kind of Anti-virus software are you running? Sometimes that interferes with the launcher as it falsely flags it.

 

The Mod Launcher is distributed through a One-Click packaging system. This is a microsoft-based solution, but sometimes it misbehaves.

 

Let's try to fix that by doing Option A, and if that doesnt work, try option B.

 

A) Go into Program Files and Remove the 7D2D Mod Launcher, and then re-install it

 

B) Copy and paste this in an Explorer window: %APPDATA%\..\Local\Apps\2.0 And delete everything in there. This is the OneClick cache that windows maintains for these types of apps. The information will be re-generated when you use a program listed in here

 

Here's the reference I'm using for the Options: https://support.microsoft.com/en-us/help/2713442/clickonce-application-fails-to-update

Share this post


Link to post
Share on other sites
Sorry for the trouble. Let's see if we can get you sorted with the first problem, then we can move unto the next problem.

 

What kind of Anti-virus software are you running? Sometimes that interferes with the launcher as it falsely flags it.

 

The Mod Launcher is distributed through a One-Click packaging system. This is a microsoft-based solution, but sometimes it misbehaves.

 

Let's try to fix that by doing Option A, and if that doesnt work, try option B.

 

A) Go into Program Files and Remove the 7D2D Mod Launcher, and then re-install it

 

B) Copy and paste this in an Explorer window: %APPDATA%\..\Local\Apps\2.0 And delete everything in there. This is the OneClick cache that windows maintains for these types of apps. The information will be re-generated when you use a program listed in here

 

Here's the reference I'm using for the Options: https://support.microsoft.com/en-us/help/2713442/clickonce-application-fails-to-update

 

Thanks Sphereii. You are the greatest. Worked like a charm. I did not find the other 7dtd launcher in Program Files, so I did the Option B and that seems to have worked. Downloaded the launcher and now its works perfect.

Share this post


Link to post
Share on other sites
Thanks Sphereii. You are the greatest. Worked like a charm. I did not find the other 7dtd launcher in Program Files, so I did the Option B and that seems to have worked. Downloaded the launcher and now its works perfect.

 

That's great news. It'd be really nice if Microsoft would have fixed things with that OneClick installer, but alas. Good luck, and enjoy the mods!

Share this post


Link to post
Share on other sites
Afraid not. The launcher uses the internet to download and install the mods.

 

You can't launch already downloaded mods? I didn't realise that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...