Jump to content

Radeon RX 6800 XT Graphical Issues


Recommended Posts

My mom recently bought a computer with an Radeon RX 6800 XT in it and it runs all games perfectly fine, except 7D2D. The performance is fine, but in specific locations on the map, she gets this odd graphical bug. I wouldn't call it artifacts, it's more or less a texture fading in and out. The only way I can reproduce the issue is to fly around to a location that it starts happening in. We know it happens at her base in the back yard near the pool and a few other locations, but it is rather random.
I run an IT Department and have for 20+ years so I've done all the typical stuff such as updating BIOS, running DDU to uninstall/reinstall the driver, change all types of video settings, swapped monitors, changes video cables (HDMI and DisplayPort), turned off AMD FreeSync Premium, etc.
The other games she plays such as Subnautica, Red Dead Redemption 2, Cyberpunk 2077, 3D Mark, Heaven Benchmark, and others have no graphical issues whatsoever.
I've tried searching online for 7D2D graphical issues and it seems there was a known issue back when the Radeon 5700 & 5800/Alpha 18 were released, but it was more of a "snow" effect at roads.
Anyway, anyone have any suggestions as to what might be causing this? Thanks in advance. Video Link Below:
Link to comment
Share on other sites

The video looks like a water reflections issue. You could maybe tweak that setting a bit to see if you can bypass the issue for now. If nothing changes, it might also be a bloom effect issue or something along those lines. You could also try different GPU driver versions including older ones to see if that changes anything.


But issues like this is the reason why I prefer to pay the extra money to go with Nvidia. When it comes to gaming, market share dominance for GPUs matter a lot, not so much for CPUs though, thankfully.

Edited by Fox (see edit history)
Link to comment
Share on other sites

12 hours ago, mjimlay said:
Video Link Below:

That's weird. What are the gpu temps while that's happening?

You could go through the graphics settings to narrow down which option is related to the glitch you're seeing.

Also, I'd try underclocking the vram and gpu clocks separately to see if that reveals any info. If none of that reveals anything,

I'd try undervolting the gpu.

Link to comment
Share on other sites

I used to be an AMD graphics card user by myself half a year ago. I don`t recall having this particular problem with Vega56 and its drivers. Actually, I never ever had any problem while playing 7DTD with AMD. Freesync felt really great in a single-player, super smooth framerate but the mouse was slightly less responsive, not by much. If You have really tried playing at low details, try lower resolution and field of view also, then medium and ultra, idk then. Make sure to disable or enable all possible settings in the Adrenaline panel and see then. I had more problems with AMD graphics card in older titles running in DX9, that's what forced me to switch back to nVidia. AMD is somewhat inferior, but only in certain titles, or DX9 unfortunately.


To me, this looks like some sort of reflection, texture refreshing related problem as Fox stated in his post. Perhaps unpolished drivers, this usually happens with the release of new AMD graphics cards. Try posting this issue on AMD's website. I had posted issues that I was having with brief explanations when certain problems occurred. If it's near water, then try explaining this somehow here: https://community.amd.com/t5/support-forums/ct-p/supprtforums. Try creating a ticket through Adrenaline software and post a short explanation with a video. May I know what particular settings You have played on? I will try to make an artificial pool of the same size, place a wall opposite to it and see if this happens to me with nVidia - that`s the only thing I may do even if it seems ridiculous 🙃.


I recommend nVidia users disabling SSAO in 7DTD which is handled better by AMD.

Link to comment
Share on other sites

  • 1 month later...

A friend I play Ark with has an AMD card. He played fine for YEARS, but recently got a driver update forced on him via Windows Update. It updated his Radeon drivers and software, and now when he loads the game it looks like an acid-trip. We removed the new driver, installed the original, but it still happens. Shy of a wipe of the entire system, he is now unable to play. I would bet the newer AMD drivers are your problem. AMD is doing the same thing ATI did: Releasing bad drivers.

Link to comment
Share on other sites

I did have AMD driver issues with a recent Win update. In fact, I lost over a range of 50 - 100 FPS in some games.


I rerolled to March's driver and that helped out a lot, try that (didn't roll back Win updates).


Also play with your Radeon Software, such as turning on/off various overrides

Link to comment
Share on other sites

  • 5 months later...

Same issue.  It doesn't seem to be just water reflections but any highly reflective texture.  This is outside a NEPA base.




I was so excited to get my new 6900 XT.  And then so frustrated that my favorite game is the only one showing issues.


For those interested I run a 3860 x 1080 monitor and average 80 -120fps on ultra settings with this setup.


Ryzen 7 5800x

Link to comment
Share on other sites

  • 1 year later...

Yes it still is. I was just commenting on it with my group last night. Verified the latest drivers as well.  It's not extreme as when this thread was started, and IMHO, it is most likely a Unity issue as I have noticed it occurring in other Unity games around water, or when it is raining.


I will also note that I have reflections turned off. Here are my current video options.  I'm on a 6800XT Gaming Z at 1440p


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...