Jump to content

Darkness Falls: They mostly come out at night...


KhaineGB

Recommended Posts

23 hours ago, Chivalric said:

This could just be my odd luck, but using the ratchet, impact driver, and laser tool, I get next to no batteries and engines ever, but with the most basic wrench, I get 1 to 2 on nearly every vehicle. Not sure if that's a setting that's bugged or what, just figured I'd point it out.

 

Fixed in the B34 dev build. Basic wrenches work though, as you mentioned.

 

2 hours ago, TheGreatGawain said:

Just a quick note, I haven't been able to get sap from any trees, no matter the size, whether I'm doing right or left click, no matter the distance from the tree.  Not game breaking, but damn if I don't miss my steady supply of Megacrush.  

 

Using the clay bowl?

  • Like 1
Link to comment
Share on other sites

Hi, not sure if this is just with the new build for A20 but when I copy and replace the mod folder, I run the game and start up a new world and it just gets with the console open and the text saying "NullReferenceException: Object reference not set to an instance of an object". It's been going for about 15 minutes.

 

Any tips?

 

 

EDIT: Fixed issue thanks to a helpful player, thank you! excited for the stable build!!

Edited by NasTea (see edit history)
Link to comment
Share on other sites

On 1/16/2022 at 10:49 AM, BarryTGash said:

 

Funny you should say that - I've been experiencing the similar (but didn't know about the basic wrench). I thought the drop rates were nerfed - I ended up using the silver I'd found to make engines eventually as I'd had just 1 engine out of 40 or so vehicles. Just tried the standard wrench and 4 batteries / 1 engine out of 6 vehicles.

I had started using silver as well, but the save in which I was doing that bugged out and I had to start over.. on the next, I didn't find a rachet til like day 5 and had ran out of room for the engines and batteries, which is when I noticed the difference.

On 1/16/2022 at 5:31 PM, SurvivorStu said:

 

for god´s sake, and i thought im fkn stupid not getting any engines anymore... 
just tested this, 4 cars, 3 batteries and 1 engine

Glad I could be of help. :D

  • Like 1
Link to comment
Share on other sites

20 minutes ago, BarryTGash said:

 

Cool. Can you share the solution? Others may find it helpful in future.

 

Was it similar to the issue of not having Steam running?

 

I had this, because I forgot to disable EAC in the game launcher. 
Could also be because the test build of DF can only run on the premade DF maps supplied with the mod.

Edited by Marinxar (see edit history)
  • Like 1
Link to comment
Share on other sites

3 hours ago, Falaffel said:

Honey does not seem to cure infection (on B30).

I found this also, but taking 2 consecutively does still work....  I thought maybe it was intentional and just needed a localization edit.

Link to comment
Share on other sites

Hi KhaineGB,

 

I haven't found a tool and die set yet and I'm on day 38 at level 126, I am pretty sure this isn't normal.  Getting tons of lathes, welding torches, calipers, tanning racks and from the loot table, they should be as frequent as lathes..

 

I fixed the issue with the creative menu but haven't looted one yet.

 

Currently using B30 no other mods installed.

Link to comment
Share on other sites

5 hours ago, Marinxar said:

 

I had this, because I forgot to disable EAC in the game launcher. 
Could also be because the test build of DF can only run on the premade DF maps supplied with the mod.

It was either one, or both of these. I disabled EAC and then used the test map, and it ran smooth.

Link to comment
Share on other sites

7 hours ago, TribalDragon said:

I haven't found a tool and die set yet and I'm on day 38 at level 126, I am pretty sure this isn't normal.  Getting tons of lathes, welding torches, calipers, tanning racks and from the loot table, they should be as frequent as lathes..

 

I fixed the issue with the creative menu but haven't looted one yet.

 

Currently using B30 no other mods installed.

They always were a tough drop.  I usually end up buying mine from traders 😕

Oddly, in A20... I found a cooking grill and two beakers long before a cooking pot dropped for me - go figure

Link to comment
Share on other sites

8 hours ago, TribalDragon said:

Hi KhaineGB,

 

I haven't found a tool and die set yet and I'm on day 38 at level 126, I am pretty sure this isn't normal.  Getting tons of lathes, welding torches, calipers, tanning racks and from the loot table, they should be as frequent as lathes..

 

I fixed the issue with the creative menu but haven't looted one yet.

 

Currently using B30 no other mods installed.

The drop % on pretty much everything is currently botched, I think he said it's fixed in the builds that aren't public yet. I've gotten both the chassis and parts for the gyrocoptor 20 times over before I got a single tool & die set.

Link to comment
Share on other sites

So, I've been trying now for about 3 hours to get this mod working, and nothing I do seems to work.

 

I've tried the new mod launcher, it just crashes the moment I press play.

 

I've tried the old mod launcher, same thing.

 

I've tried manually downloading the zip file on the first page and it still crashes the moment it starts, all I see is the crash handler pop up for a second and that's it.

 

All three times I have told the mod launcher to download A19.6 from steam.

 

I've played quite a few other mods with the old launcher and the new launcher, currently playing Undead Legacy, and have no issues with any other mod but this one.

 

So obviously I has the dumb and am doing something wrong, lol.

 

Anyone able to suggest some ways of getting this to work?

 

Thank you.

 

 

Edit -

 

Ok I managed to get it working, I am not sure why, but anytime I told the mod launcher to download A19.6, it was still downloading A20. I am not sure how I fixed it, but I now have downloaded a copy of A19.6 and it's working fine now.

Edited by AstrayAluveaux
Solution/Resolved (see edit history)
  • Like 1
Link to comment
Share on other sites

Looking forward to the mod coming out, was the most fun I had last time played a good amount of 7DTD, but wanted to ask something oddball someone might know; I play with someone who's an arachnophobe, and I'm generally not a big fan of giant insects either. Last time, I think A19's DF, i just commented out the two enemies from the game, both so the mob didn't exist and it never got called for spawning. At the same time, and I'm fairly sure unrelated, I could never get the scientist class because of a null error, i think? (would never be able to use the class book) I always wondered if that was because of removing the monsters, so figured I would check if anyone knows: is there anything that those two need to be in the game to allow? Is there a better way to make absolutely 100% sure they never show up?

 

My computer was also only about two steps above a potato for this game so there could be plenty of other reasons why; just not going to get them to play this unless I can get rid of those two enemies.

  • Like 1
Link to comment
Share on other sites

I don't know if anyone else had problems with Bio boost and tech boost, but I could not get transhuman over level 1. Had all the requirements met.

 

Starting digging in the xml files and found that in the progression.xml and buff.xml file 2 perks/buff were blocking them-self's.

 

Transhuman was checking if $bioboosts was at 0 but it can't because transhuman is a bioboost and Gottagofast was checking if $techboosts was at 0.

 

Edited my xml files on my server and it's now working as intended (I hope), here is what I have modified if anyone wants to make those changes while waiting for stable.

 

I hope KhaineGB will approve of this, or I can remove the code snipet from my post!

 

Buff.xml

<buff name="buffOxygenOptimizationLvlUp" hidden="true" remove_on_death="false">
    <stack_type value="ignore"/>
    <duration value="1"/>
    <effect_group>
        <requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifyCVar" cvar="$bioboosts" operation="set" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifySkillSDX, SCore" tag="perkTranshuman" operation="add" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ShowToolbeltMessage" message="Your Skill In Transhuman Has Increased!"/>
            <triggered_effect trigger="onSelfBuffStart" action="PlaySound" sound="levelup" play_in_head="true"/>
    </effect_group>
</buff>

<buff name="buffGottaGoFastLvlUp" hidden="true" remove_on_death="false">
    <stack_type value="ignore"/>
    <duration value="1"/>
    <effect_group>
        <requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifyCVar" cvar="$techboosts" operation="set" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifySkillSDX, SCore" tag="perkGottaGoFast" operation="add" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ShowToolbeltMessage" message="Your Skill In Gotta Go Fast Has Increased!"/>
            <triggered_effect trigger="onSelfBuffStart" action="PlaySound" sound="levelup" play_in_head="true"/>
    </effect_group>
</buff>

progression.xml


<perk name="perkTranshuman" parent="skillBioBoosts" name_key="perkTranshumanName" desc_key="perkTranshumanDesc" base_skill_point_cost="0" min_level="0" max_level="5" icon="ui_game_symbol_run">
    <level_requirements level="1"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="2"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="3"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="4"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="5"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>

<perk name="perkGottaGoFast" parent="skillTechBoosts" name_key="perkGottaGoFastName" desc_key="perkGottaGoFastDesc" base_skill_point_cost="0" min_level="0" max_level="5" icon="ui_game_symbol_run">
    <level_requirements level="1"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="2"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="3"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="4"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="5"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>

 

  • Like 1
Link to comment
Share on other sites

1 hour ago, TribalDragon said:

I don't know if anyone else had problems with Bio boost and tech boost, but I could not get transhuman over level 1. Had all the requirements met.

 

Starting digging in the xml files and found that in the progression.xml and buff.xml file 2 perks/buff were blocking them-self's.

 

Transhuman was checking if $bioboosts was at 0 but it can't because transhuman is a bioboost and Gottagofast was checking if $techboosts was at 0.

 

Edited my xml files on my server and it's now working as intended (I hope), here is what I have modified if anyone wants to make those changes while waiting for stable.

Not sure why I didn't think to do this, kind of kicking myself now. But yeah, I went 5/5 Acc. healing, then tried to put points into the other one that wasn't greyed out (forgot which one) and lost ALL perks in both groups. I ended up having to make a new save, since using a recent backup character and putting it in the save did nothing somehow. It just ended up as a lvl 1 new character, even though I deleted all the old files and copy pasted those into the save.

Link to comment
Share on other sites

On 1/18/2022 at 11:27 AM, Falaffel said:

Honey does not seem to cure infection (on B30).

 

Honey only has a 50% chance to start curing infection.

 

On 1/18/2022 at 3:22 PM, TribalDragon said:

Hi KhaineGB,

 

I haven't found a tool and die set yet and I'm on day 38 at level 126, I am pretty sure this isn't normal.  Getting tons of lathes, welding torches, calipers, tanning racks and from the loot table, they should be as frequent as lathes..

 

I fixed the issue with the creative menu but haven't looted one yet.

 

Currently using B30 no other mods installed.


Sounds like you got very unlucky.

On 1/19/2022 at 8:06 PM, Magnus17 said:

Looking forward to the mod coming out, was the most fun I had last time played a good amount of 7DTD, but wanted to ask something oddball someone might know; I play with someone who's an arachnophobe, and I'm generally not a big fan of giant insects either. Last time, I think A19's DF, i just commented out the two enemies from the game, both so the mob didn't exist and it never got called for spawning. At the same time, and I'm fairly sure unrelated, I could never get the scientist class because of a null error, i think? (would never be able to use the class book) I always wondered if that was because of removing the monsters, so figured I would check if anyone knows: is there anything that those two need to be in the game to allow? Is there a better way to make absolutely 100% sure they never show up?

 

My computer was also only about two steps above a potato for this game so there could be plenty of other reasons why; just not going to get them to play this unless I can get rid of those two enemies.

 

I'm scared of heights but you don't see me removing skyscrapers. 😛

 

20 hours ago, TribalDragon said:

I don't know if anyone else had problems with Bio boost and tech boost, but I could not get transhuman over level 1. Had all the requirements met.

 

Starting digging in the xml files and found that in the progression.xml and buff.xml file 2 perks/buff were blocking them-self's.

 

Transhuman was checking if $bioboosts was at 0 but it can't because transhuman is a bioboost and Gottagofast was checking if $techboosts was at 0.

 

Edited my xml files on my server and it's now working as intended (I hope), here is what I have modified if anyone wants to make those changes while waiting for stable.

 

I hope KhaineGB will approve of this, or I can remove the code snipet from my post!

 

Buff.xml

<buff name="buffOxygenOptimizationLvlUp" hidden="true" remove_on_death="false">
    <stack_type value="ignore"/>
    <duration value="1"/>
    <effect_group>
        <requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifyCVar" cvar="$bioboosts" operation="set" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifySkillSDX, SCore" tag="perkTranshuman" operation="add" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ShowToolbeltMessage" message="Your Skill In Transhuman Has Increased!"/>
            <triggered_effect trigger="onSelfBuffStart" action="PlaySound" sound="levelup" play_in_head="true"/>
    </effect_group>
</buff>

<buff name="buffGottaGoFastLvlUp" hidden="true" remove_on_death="false">
    <stack_type value="ignore"/>
    <duration value="1"/>
    <effect_group>
        <requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifyCVar" cvar="$techboosts" operation="set" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ModifySkillSDX, SCore" tag="perkGottaGoFast" operation="add" value="1"/>
            <triggered_effect trigger="onSelfBuffStart" action="ShowToolbeltMessage" message="Your Skill In Gotta Go Fast Has Increased!"/>
            <triggered_effect trigger="onSelfBuffStart" action="PlaySound" sound="levelup" play_in_head="true"/>
    </effect_group>
</buff>

progression.xml


<perk name="perkTranshuman" parent="skillBioBoosts" name_key="perkTranshumanName" desc_key="perkTranshumanDesc" base_skill_point_cost="0" min_level="0" max_level="5" icon="ui_game_symbol_run">
    <level_requirements level="1"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="2"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="3"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="4"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>
    <level_requirements level="5"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$techboosts" operation="Equals" value="0" desc_key="reqNoTechBoost"/></level_requirements>

<perk name="perkGottaGoFast" parent="skillTechBoosts" name_key="perkGottaGoFastName" desc_key="perkGottaGoFastDesc" base_skill_point_cost="0" min_level="0" max_level="5" icon="ui_game_symbol_run">
    <level_requirements level="1"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="2"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="3"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="4"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>
    <level_requirements level="5"><requirement name="PlayerLevel" target="self" operation="GTE" value="125" desc_key="reqPlayerLevel125"/><requirement name="ProgressionLevel" progression_name="attTechnology" operation="Equals" value="1" desc_key="reqattTechnology"/><requirement name="CVarCompare" cvar="$bioboosts" operation="Equals" value="0" desc_key="reqNoBioBoost"/></level_requirements>

 


Fixed locally and tested already.

Link to comment
Share on other sites

27 minutes ago, MisFitT said:

Sorry If I missed it but has the stable A20 version of DF been released yet or is it still workin??

I assume that as soon as a stable/full build of DF for A20 is ready, the 1st page of this thread will be updated to say as such. I believe i read somewhere earlier here that it'll be the 4.0 release, but i could be wrong on the release#. In any case it'll def change from 3.6 to something higher when it's released. A cple of pages back khaine released a beta version of the updated mod, obviously a work in progress, you'll experience bugs, ect. 

 

If you can't wait on the stable vers to get back into df, try that out.

Link to comment
Share on other sites

16 hours ago, MisFitT said:

Sorry If I missed it but has the stable A20 version of DF been released yet or is it still workin??

 

15 hours ago, wolfarus said:

I assume that as soon as a stable/full build of DF for A20 is ready, the 1st page of this thread will be updated to say as such. I believe i read somewhere earlier here that it'll be the 4.0 release, but i could be wrong on the release#. In any case it'll def change from 3.6 to something higher when it's released. A cple of pages back khaine released a beta version of the updated mod, obviously a work in progress, you'll experience bugs, ect. 

 

If you can't wait on the stable vers to get back into df, try that out.


^ this is correct. It's not out yet. First page will be updated when it is.

Also I tested positive with COVID yesterday, so that's fun. :D

Link to comment
Share on other sites

9 minutes ago, KhaineGB said:

Also I tested positive with COVID yesterday, so that's fun. :D

 

You can concentrate on the mod whilst self-isolating... :D

 

Seriously though, look after yourself and family first and foremost. Best of luck - hope it doesn't turn nasty.

  • Like 2
Link to comment
Share on other sites

1 hour ago, KhaineGB said:

 


^ this is correct. It's not out yet. First page will be updated when it is.

Also I tested positive with COVID yesterday, so that's fun. :D

All the postive energy/good vibes/ prayers and well wishes for you and yours. Get well soon.

Link to comment
Share on other sites

Having an issue with game launch.  Null Reference Exception : object not set to an instance of an object  right after loading player.XML   Creating player on the screen. I have deleted player profile , all saves, pulled fresh 7days build and reloaded DF into it and still same error at the same spot every time.  Trying to load B30 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...