Jump to content
Sign in to follow this  
Guppycur

A16 - Medieval Mod (SDX)

Recommended Posts

No town makes for a very difficult multiplayer; so make sure you equip your character well, because if I wipe, I'll xfer over the character files.

Share this post


Link to post
Share on other sites

Huge storm, server just took a hit. Downtime could range from quickly until "new power supply comes in."

Share this post


Link to post
Share on other sites

k, that machine survived. Hopefully the switches leading to it did as well.

 

*Update*

 

Seems to, but we'll see how long the connection holds. Vicious storm.

Edited by Guppycur (see edit history)

Share this post


Link to post
Share on other sites

Same black screen

 

Strange. i downloaded the mod via the launcher, but i only get a black screen at the start of 7d2d, nothing more....

 

I too am having the black screen issue. I have re-installed twice now. I an not running EAC. I can get the normal game to load up fine but the mod will be black at the start screen with only my cursor appearing. Help!?

Share this post


Link to post
Share on other sites
I too am having the black screen issue. I have re-installed twice now. I an not running EAC. I can get the normal game to load up fine but the mod will be black at the start screen with only my cursor appearing. Help!?

 

Are you using the Vanilla game to install the mod? if you have changes on your main 7d2d archives it can conflit with the mod

Share this post


Link to post
Share on other sites

Quick question if anybody can help: are any of the barrels in the POIs filled with anything useful, and if so, how to extract? I'm on latest build, and find many barrels (placed on horizontal axis) and try to fill with empty waterskin. Makes the noise and animation that something is happening, but the waterskin remains empty. I've tried breaking it down with an axe, and it will change to the same item but with a 1/1 hit point indicator. Try there too, I think same animation and sound, but nothing. This is not the ones you can pick up that sit on vertical axis. Am I doing something wrong, is this RNG (not all have mead), bug?

 

No big deal, still loving this mod!! Got my first ever wandering horde of zombies (burning guys and 3 or 4 custom pale guys). Holy moley, they were packing some gold!! Yikes, gonna go on a shopping spree once the daylight hits.

Share this post


Link to post
Share on other sites

The waterskin in toolbelt remains empty, but you're adding beer skins to your inventory...

 

...there's not a nice way to remove the held item AND convert the barrel block, so we removed getting the skin back after drinking beer to prevent the dupe. Point is though, check you inventory. =)

Share this post


Link to post
Share on other sites

Ugh, maybe I had my inventory already full, or maybe I'm just dumb as a rock and did not notice. Anyway, thanks Gup for the info, I'll give it a shot.

Share this post


Link to post
Share on other sites

I have put Medieval Mod as a dedicated on one of our servers and i kinda see a issue with the Horse. "unless I'm doing something wrong" When you kill the horse or find a dead horse and you hit it, it will show that is has 0/0 health which is fine, But it does not degrade like the other animals and if you hit it with let's say a Axe or a knife it will continue to upgrade your blade skill very quickly after 2 or 3 hits with a axe or knife it increases. The Horse stays there for a very long time. I am trying to figure out how to make the horse go straight to the gore block when it gets killed to eliminate this issue. But I do see there are 3 types of horse blocks in the file and I have no idea why that is. I dont even see in the Entities.xml that the horse goes to any of those blocks when killed. I see the max hit points it has but that is about it. Nothing about harvesting it in the entities.xml either only the horse blocks in the blocks.xml. Can this be fixed? Because players will no doubt use this glitch to increase their blade skills very quickly just on this horse. I have commented it out for now to prevent this unless i find a way to make it vanish when it dies. I sure hope there is a way riding it is awesome.... I do love this MOD.

 

Also since I'm thinking of it I made the Map larger for our server made it to 20,000 out. Ive noticed the crystal biome is out past this distance thought it was kinda strange does this biome and the other one that says to go North or South to get another item i forgot the biome that it is but are these suppose to be this far out or is it that we just haven't uncovered the map enough to see more of these biomes?

 

Thanks For The Help :)

Share this post


Link to post
Share on other sites

Biome placement is done via code, so you may want to try different options in the rwgmixer to accommodate your changed world size.

 

I'll check with TormentedEmu about the horse issue.

Share this post


Link to post
Share on other sites
Biome placement is done via code, so you may want to try different options in the rwgmixer to accommodate your changed world size.

 

I'll check with TormentedEmu about the horse issue.

 

Thank You for the help

Share this post


Link to post
Share on other sites

First off great mod, toss up between this and Raevnherst as to which I like more. I am looking forward to the A17 version.

 

I do have to mention the overly aggressive towns folk. I have had them come out of there building to attack me.

 

Playing on an Our Secrets server and asked to have my player data wiped because I thought I had screwed up by looting (AKA Oblivion style).

However even on the restart, with out killing a single NPC. A large % of the town want to attack me on sight. All I have to do is walk by there home and I can see them aggro and head to the door. If I open it they attack. If they glitch through it they attack.

 

If your supposed to kill a large number of the town folk you are trying to save then I guess its working. But it just seems a bit to much to me.

 

Thanks for everyone hard work.

Share this post


Link to post
Share on other sites

Definitely have to play it differently... The peasants can't open doors or break blocks, and are understandably unhappy with you for breaking into their homes, so my recommendation is to either sneak thief into the houses, by breaking a window and hopping in (1 block crouch works with this mod) or leading them out and just closing the door on them. =)

Share this post


Link to post
Share on other sites

Hello once again,

 

I am trying to help another player to get on Medieval Mod. We used the Mod Launcher, Installed the Mod, Synced the Mod, then clicked on Play button on the Mod Launcher.

 

For me for example it takes me about 3 to 5 minutes to get to the Medieval Picture that shows just before the Menu pops up. On her computer the picture comes up in like 30 seconds or so and go through the loading of blocks and such when it gets to loading items it stops there and we waited about 5 minutes and it still stayed there? It took just seconds to go through the other things until it got to the Items.

 

Anyone know what we can try to fix this? She should be able to play this mod easily. I even tried to download the master core and copy the files into a copy of the original game in a seprate directory and still the same thing happens. I feel so sorry for her she really wants to try out this mod.

 

Please Help, Thank You.

Share this post


Link to post
Share on other sites

If she gets a medieval pic that quick, the mods folder itself isn't copied correctly.

Share this post


Link to post
Share on other sites
Hello once again,

 

I am trying to help another player to get on Medieval Mod. We used the Mod Launcher, Installed the Mod, Synced the Mod, then clicked on Play button on the Mod Launcher.

 

For me for example it takes me about 3 to 5 minutes to get to the Medieval Picture that shows just before the Menu pops up. On her computer the picture comes up in like 30 seconds or so and go through the loading of blocks and such when it gets to loading items it stops there and we waited about 5 minutes and it still stayed there? It took just seconds to go through the other things until it got to the Items.

 

Anyone know what we can try to fix this? She should be able to play this mod easily. I even tried to download the master core and copy the files into a copy of the original game in a seprate directory and still the same thing happens. I feel so sorry for her she really wants to try out this mod.

 

Please Help, Thank You.

 

check the console, you probably have some errors there. The mod uses Emu's no NRE hijack so it wont pop the console down by itself. If it loads that quick I would guess that the Mods/SDX folder isn't in the right place, as it is the unpacking of the unity3d files that causes the long load times.

Share this post


Link to post
Share on other sites
I do have to mention the overly aggressive towns folk. I have had them come out of there building to attack me.

 

The hostile peasants are essentially a placeholder until I can get to the code that will make them aggro when you wreck their house or loot their stuff. They may even summon guards :)

 

They are however quite weak and can be killed with a torch after a few hits, or oneshot with just about any proper weapon.

 

Consider them a bit broken in the head from being blight tainted if it helps :)

Share this post


Link to post
Share on other sites
Thank You I'll look here in awhile to see if there is something I can do about the Horse.

 

The horse is currently coded to not fade quickly so that you can recover your saddle and items from the dead horse if needed, but we can look at making the corpse take damage to avoid the exploit. The other option is to have a corpse block that the items transfer to. It's a gradual process but its getting there more and more each day :)

Share this post


Link to post
Share on other sites
Also since I'm thinking of it I made the Map larger for our server made it to 20,000 out. Ive noticed the crystal biome is out past this distance thought it was kinda strange does this biome and the other one that says to go North or South to get another item i forgot the biome that it is but are these suppose to be this far out or is it that we just haven't uncovered the map enough to see more of these biomes?

 

Thanks For The Help :)

 

In the mixer you will find this cell rule:

 

       <!-- This cellrule contains the adjustable settings for Medieval Mod, prob is a float, but will be cast to int if required -->
       <cell_rule name="MedievalConfig">
         <!-- mode 0 is spawnPoint, mode 1 is spawnArea random -->
         <hub_rule name="spawnMode" prob="1"/>
         <!-- X + is east, Z + is north -->
         <hub_rule name="spawnPointX" prob="0"/>
         <hub_rule name="spawnPointZ" prob="10"/>
         <hub_rule name="spawnAreaMinX" prob="-350"/>
         <hub_rule name="spawnAreaMinZ" prob="-350"/>
         <hub_rule name="spawnAreaMaxX" prob="350"/>
         <hub_rule name="spawnAreaMaxZ" prob="350"/>
         <!-- value between 0.1 and 1.0 -->
         <hub_rule name="southBiome" prob="0.7"/>
         <hub_rule name="eastWestBiome" prob="0.8"/>
         <hub_rule name="northBiome" prob="0.3"/>
       </cell_rule>

 

the 0.7 for south means it will be 70% of the world radius to the south, so 7k for a 10k world, 14k for a 20k world etc.

 

you will also need to move the world border biome that spawns constant necros and other nasties.

 

       <!-- BLIGHTED LANDS BORDER -->
       <biome_spawn_rule name="wasteland">
         <distance_from_center range="9500,10000"/>
       </biome_spawn_rule>

 

This provides a 500 block blighted border (non spreading, but not for long with all the necros that spawn there) before you hit the rad zone

 

The radiation zone (aka deadly cursed blight) will be at whatever the world radius is, so you don't have to set that in the biome gen

Share this post


Link to post
Share on other sites

Currently looking at probably two or three more days before the final bits are ready for b15. Main holdup is the quests I want to re-work to flow better and guide you though the early stages and reward you with some unlocks etc. That will require a new save so I want to get it pretty much in place before we do the last save breaking update. b15 will essentially be the stable build for 1.0

Share this post


Link to post
Share on other sites

Well this mod has claimed top spot for me. Great work by everyone and the POIs are just amazing.

 

One thing I have noticed. Has the timer on farming (plants) been lengthened or is it currently not working? I have had corn and aloe, in fertilized soil for over a week in game and still only get one item back. I have used both hands and a hoe to harvest them with the same results.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...