Jump to content

Editing Height Maps


Recommended Posts

The prefabs.xml decides where the poi's go, so the EASIEST (but time consuming) is to go into the game, find a coordinate you want a poi to spawn from (F3), and edit the prefabs.xml to match.

 

...facing north, prefabs will/should spawn to the NORTHEAST from that point, meaning that if you stand on 0,0,0, the prefab will spawn starting from the lower left corner to the upper right corner from 0,0,0. I haven't actually tried it yet, but that's how it worked in previous versions.

 

Stand at the yellow X, and the prefab will spawn as such:

 

tmpcorners.png

Link to post
Share on other sites

I guess there's no way for me to set it up so the game randomly generates the world, I edit the height map and have all the prefabs conform to the new height throughout the map huh? lol

 

that's basically what I did. I just lightened the entire tga file and loaded the game. it's pretty funny how all the structures are still there...just in large pits or under the earth, hahaha

Link to post
Share on other sites

I have a question for you Gup. Maybe you can tell me if you think this will be doable. I want to package a custom biome map to go with my mod that players could use in RWG. So every time they made a new rwg map they would get different roads, terrain height and poi's but my set layout for biomes. Do you think we will be able to do something like that this alpha?

Link to post
Share on other sites

That should be doable, once the biomes.png issue is 100% sorted. 4sheetz has done it, I've accidentally done it, but I need to tinker more.

 

But Yeh... Just ship the biomes.png with your mod, make sure they install it, and call it a day.

Link to post
Share on other sites

Would be awesome if someone could figure out a way to make a 7 days map editor where you could generate a map in 7 days open it with the editor that overlays the pngs and the height map and you could just edit everything. And when you change the height it would automatically recalculate the heights for the poi's.

 

Making a biome editor shouldn't be to hard since your only working with a set format and 5 colors currently. Then you have the few colors for the road splat.

 

I have been trying to find an image editor that will show the height map in 3d. That would be cool.

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Thx, very helpful vid. Was wondering what role the RAW file played in this, but seems I can just ignore and delete it and the game is going to create a new one for me. Makes things a lot easier for me, as I could not get a single GIMP plugin for RAW files to work properly and can't afford the Adobe products at the time :D

Link to post
Share on other sites

 

Nice, never seen this before, but then again I've been out of the loop with media design stuff for a while now.

Looks good, might even hook up the old tablet for this.

 

Yeah, because you're also going to find that paint.net and gimp both will screw over your PNG file. Krita seems to work nicely though.

True, it appears they can't maintain exact RGB values on both import and export.. Never noticed that before with GIMP.

Link to post
Share on other sites

Don't know if this helps, but I've noticed with the biomes PNG if I save it as 32 bit in paint.net it throws a null reference error with chunk generation. If I do the auto detect setting, it then saves it as 8 bit and I run into the issue that Guppy did in his video, that only snow biomes work.

 

I also noticed that after saving in paint.net the file size is notably smaller, even saving as 32 bit. It seems to me paint.net borks something in the way it saves files that is important for 7 Days to Die. Perhaps something to do with file compression? Probably what Kam was saying.

 

Anyone get the Biome editing to work yet? I can get it to load using the edited biomes.PNG but the areas of burnt forest I replaced with normal forest appear as holes in the map.

 

Edit* Got it working

 

Edit : This isn't relevant anymore.

 

Might I ask how? Did you use another program, or is there a setting somewhere I missed?

 

Edit : I tried Krita, but am still having issues. The stuff I don't change works fine and I can get into the game, but when I ran into an edit it created a hole and threw the null reference error, which ended chunk generation as well.

 

A brush setting maybe? I sampled the color, so I don't know why it didn't paint the exact color it needed.

 

 

I sorted out what I was doing wrong, it was the brush doing blending and anti-aliasing. The pixel art brush works fine.

 

However, I've ran into a problem with the splat3 png, I can't seem to erase roads. The game still generates roads even if they aren't drawn in the file. The ones I do draw show up, but the ones I delete remain.

 

I am editing a random gen file though, so maybe it has something to do with that? Anyone else having this issue?

Edited by Gipothegip (see edit history)
Link to post
Share on other sites

@Gipothegip If you are deleting roads and the road is returning then, you need to check the setting in the app you are using, you are not deleting the layers. Easiest way to verify is , create a png same size as the splat 3 with "transparency background" save and put it in your folder. no roads, but your edited one has them. means you didnt edit the correct layer. second way, save your png as a tga, edit te 3 rgb layers save open that file then save it as png.

Link to post
Share on other sites

@brycie if you get holes in your map, 1 use solid brush, better to use solid pencil, 2 use only exact color, any other coloreven if off by 1 is considered invisible to game. After edit zoom to 500+% and look for any off colors. Most of the issues happen at borders between two biomes. If you zoom in you see a blended color, but eyedropper will say 0 65 0 instead of 0 64 0. that 1 dot is a 3 meterblock in game or equal to bad chunk load

Link to post
Share on other sites

 

However, I've ran into a problem with the splat3 png, I can't seem to erase roads. The game still generates roads even if they aren't drawn in the file. The ones I do draw show up, but the ones I delete remain.

 

I am editing a random gen file though, so maybe it has something to do with that? Anyone else having this issue?

 

I've been doing all of my world edits in paint.net and had a similar issue with the splat3.png

 

I had added a whole bunch of roads and paths without issue, my problem came when I wanted to delete some and using the eraser in paint.net. Basically after loading up the world I found i had some huge roads where I had deleted small ones and it was not until I seen the in-game height map (world editor) and actually noticed i had what appeared to be white gaps mirroring exactly where I had deleted stuff from the splat3.png

 

I was able to revert the changes and get rid of the issue by merging an old backup with the edited one full of holes and have tried sampling an empty area on the image and painting over the stuff I want rid off (same problem). Deleting from the layer just seems to punch a hole through it and leaves asphalt where ever these holes are.

 

I'm sure this is fixable and it's just me doing something wrong, if anyone knows how to remove/erase from a layer without totally sabotaging the image, that information might just get you a Christmas card!.

Link to post
Share on other sites

Hi guys for some reason, im not generating the dtm.tga file in my worlds folder, just the raw file. Im running single player local install, same directory as the video, even searched the whole directory and couldnt find it. Any ideas?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...