Jump to content

Prefab Editor (Alpha)


Pille
 Share

Recommended Posts

Sometimes I'm getting the message, sometimes not. It's quite annoying.^^

 

 

I always get either the console message 'triggered empty sleeper volume' or the sleepers, testing everything in either nav or rwg (when i feel like waiting). The only time I entered somewhere that didn't give either, the volume was wrong (before your beautiful addition). Since we've been able to add the volumes via the editor, I honestly think the areas they cover at least are pretty spot on. No message at all and no sleepers means something is wrong with the prefab when it's being inserted via the bbb commands I would guess, defo try loading them up naturally.

 

After guppy's little experimental prefab I tried, I was pretty stumped at why the empty volume was showing, but yours and stompys' recent posts gives a bit more to go off so there's still stuff i wanna try myself. This is really the only kink in the whole system so far and I feel your pain when the volumes are frustratingly simple that break and I've had more success with more complicated placements.

Link to comment
Share on other sites

New suggestions:

 

1) recently, for a gun range i made...i had to type "giveself item" a lot and throw them in a box. if i ever have to reload the prefab that'll suck ass. Is it possible to have containers come preloaded with level 600 items, and ammo?

 

2) Also, possible to have Signs have pre-defined text before placement of the prefab?

Link to comment
Share on other sites

Update Time!

 

I was quite busy last week, so it's only a very small update and probably the last one before v0.4 (if everything goes well):

 

Changelog v0.3n (July 25, 2017):

- added link to the official thread to the main menu (help -> show official thread)

- added dialog on quit to save unsaved changes (implementation is not complete yet (changes on sleeper volumes will be ignored))

- improved sleeper volume placing

- made read-only text fields gray

 

 

 

 

 

 

@Slaan

No message at all and no sleepers means something is wrong with the prefab when it's being inserted via the bbb commands I would guess, defo try loading them up naturally.

Actually, I tried to spawn the prefabs naturally. That didn't really work. Now I am using Hal's command and everything works fine.^^

Btw. I am used to frustraction. :)

 

 

@layarion

New suggestions:

 

1) recently, for a gun range i made...i had to type "giveself item" a lot and throw them in a box. if i ever have to reload the prefab that'll suck ass. Is it possible to have containers come preloaded with level 600 items, and ammo?

 

2) Also, possible to have Signs have pre-defined text before placement of the prefab?

 

I can't do that since those data are stored in the region files. So that stuff is tied to map, not to the prefab. No way atm. :(

 

ah, that sounds...like it would be hard as hell to find.

The file is located at

C:\Program Files (x86)\Steam\steamapps\common\7 Days To Die\Data\Worlds\Navezgane

(assuming you didn't change your steam directory)

 

 

 

@Spectral Force

Is the A16 version downloadable?

 

Yes, the current version is completely* compatible to A16. So you can use the links in the opening post.

 

*The Static entity spawn is not implemented yet. Afaik no one has requested it so far and I am not sure whether this feature works in A16....

Edited by Pille (see edit history)
Link to comment
Share on other sites

Update Time!

 

I was quite busy last week, so it's only a very small update and probably the last one before v0.4 (if everything goes well):

 

Changelog v0.3n (July 25, 2017):

- added link to the official thread to the main menu (help -> show official thread)

- added dialog on quit to save unsaved changes (implementation is not complete yet (changes on sleeper volumes will be ignored))

- improved sleeper volume placing

- made read-only text fields gray

 

 

 

 

 

 

@Slaan

 

Actually, I tried to spawn the prefabs naturally. That didn't really work. Now I am using Hal's command and everything works fine.^^

Btw. I am used to frustraction. :)

 

 

@layarion

 

 

I can't do that since those data are stored in the region files. So that stuff is tied to map, not to the prefab. No way atm. :(

 

 

The file is located at

C:\Program Files (x86)\Steam\steamapps\common\7 Days To Die\Data\Worlds\Navezgane

(assuming you didn't change your steam directory)

 

 

 

@Spectral Force

 

 

Yes, the current version is completely* compatible to A16. So you can use the links in the opening post.

 

*The Static entity spawn is not implemented yet. Afaik no one has requested it so far and I am not sure whether this feature works in A16....

"The Static entity spawn" this sounds like something useful for creating target practice at shooting ranges, or am i reading that wrong?

Link to comment
Share on other sites

1) ok that was stupid of me. i finally realized wtf was wrong with my sleeper volumes.

 

Here is the stupid of the hour mistake: http://i.imgur.com/s2NkQq9.png be sure that is set to ON.

 

2) could you have manual saves be auto-backed up to some place like My Documents? i uninstalled steam because of some stupid, super slow bug...didn't think it would delete my f game directories...and took my prefab with it.

 

sigh.

 

3) at least now i think i can get the sleeper spawns working.

Edited by layarion (see edit history)
Link to comment
Share on other sites

the new look for the click n drag rectangle in the editor makes it much easier to look at. thanks.

 

you didn't mention that change in your patch notes though

 

Uhm I did not change anything.^^ I tried to implement ctrl + mouse button for the rectangle tool and a few other things but it wasn't as easy as I thought it would be (due to bad code :D ). So I've decide to concentrate on releasing the next major update before implementing more "quality of life" stuff.

 

2) could you have manual saves be auto-backed up to some place like My Documents? i uninstalled steam because of some stupid, super slow bug...didn't think it would delete my f game directories...and took my prefab with it.

Ok, noted. Probably I have some time to implement a backup system after finishing the 0.4 update.

 

 

yet another suggestion. modifier key when held, right-clicking and dragging to place lots of a block places then in air only. just a minor thing though

 

I don't understand this suggestion. Please rephrase it.

 

 

"The Static entity spawn" this sounds like something useful for creating target practice at shooting ranges, or am i reading that wrong?

 

I don't think so. The spawned entities wouldn't respawn (there was a similar feature in Hal's editor btw.).

Edited by Pille (see edit history)
Link to comment
Share on other sites

suggestion like i don't know #20) Often times, when i'm on the edit tool, i only need the "Select" tool for just a moment, or vice versa, and basically the Edit tool needs a hotkey so that i can switch between select and edit without having to take my mouse from it's position.

Link to comment
Share on other sites

Hey gang, so I was able to get my custom sleeper spawns made through pille's editor to work on my first trial. Huzzah!!! However, for some reason after making adjustments to the SleeperVolumneGroup and GameStageAdjust settings for each volume has caused all sleeper spawns to stop working. I even tried undoing the changes and they still won't spawn. No errors in console either. I visited other POIs on the map and confirm sleeper spawns were working so the problem is only isolated to my custom prefab.

 

Deleting the region files resets any damage I caused to the POI however the sleeper spawns remain borked. Any of you run into this problem before?

 

The following is my prefab XML file:

 

<?xml version="1.0" encoding="UTF-8"?>
<prefab>
   <property name="CopyAirBlocks" value="True"/>
   <property name="AllowTopSoilDecorations" value="False"/>
   <property name="TraderArea" value="False"/>
   <property name="ExcludeDistantPOIMesh" value="False"/>
   <property name="DistantPOIYOffset" value="0"/>
   <property name="SleeperVolumeStart" value="22,7,10#23,2,18#23,2,12#29,2,12#34,2,12#45,2,13#22,6,10"/>
   <property name="SleeperVolumeSize" value="34,5,18#12,3,6#5,3,7#4,3,7#10,3,9#10,5,11#34,3,18"/>
   <property name="SleeperVolumeGroup" value="S_LootRoom_XS,S_LootRoom_XS,S_LootRoom_XS,S_LootRoom_XS,S_LootRoom_XS,S_LootRoom_XS,S_LootRoom_XS"/>
   <property name="SleeperVolumeGameStageAdjust" value="easy,easy,easy,easy,easy,easy,easy"/>
   <property name="SleeperIsLootVolume" value="False,False,False,False,False,False,False"/>
</prefab>

 

EDIT:

 

Pille, is there a way to specify where columns and rows can be inserted? From the top view it looks like new rows are only added to the top. As a side note, inserted rows are not the same when comparing the top view and the side view.

 

For example, using the insert column feature while in side view inserts a column to the right side of the grid.

 

E42ARgr.png

 

Toggling to the top view, displays the inserted columns as inserted rows at the top of the grid when it should be at the bottom of the grid.

 

5eCLfus.png

 

Let me know if this makes sense or not. Thanks :)

Edited by Laz Man (see edit history)
Link to comment
Share on other sites

# 21) the numpad + and - work for going from level to level, but the + sign next to the backspace doesn't.

 

# 22) the + and - don't work on the side view.

 

# 21) You have to press shift and + to use the plus sign next to the backspace because the sign is written on the upper half of the key (in contrast to the minus sign).

 

# 22) You have to click somewhere on the view.

Link to comment
Share on other sites

Let me know if this makes sense or not. Thanks :)

Mhh I am not sure if that's consistent behavior or not.^^ Imo the more important issue you've mentioned is that you cannot specify the position of your new layer/column/row. I needed this function for myself a couple of hours ago. So it's very likely that this feature will be implemented in the next release.^^

 

There is at least one (really ugly) workaround you can use. Either you wait for the next update or you try this:

 

Lets say you intend to insert 5 new layers / rows at the position of the red arrow (it's the front view. the arrow is between layer 40 and 41. The name of the prefab is skyscraper_01.tts).

 

2OEb6U0.png

 

 

 

Apply remove rows on the selected (red blocks) to remove the layer 0 - 40 and you will get this:

 

VcozqeD.png

 

 

 

Save this cropped prefab using a different prefab name, e.g. "temp_prefab.tts". Now reload your original prefab, click on front view and insert 5 rows.

 

I1bt69v.png

 

 

 

Click on tools -> insert prefab and select your previously saved prefab "temp_prefab.tts". Click on top view and go to the layer 46 (41 + 5). Click on the lower left corner. You should see the blue box representing your inserted prefab.

 

6yHSQ3C.png

 

 

 

Click on fix position. After that go the layers 41 - 45 and replace everything with air blocks.

 

Result: 5 new layers above of layer 40:

 

fzm6oMA.png

 

 

 

 

 

 

 

Hey gang, so I was able to get my custom sleeper spawns made through pille's editor to work on my first trial. Huzzah!!! However, for some reason after making adjustments to the SleeperVolumneGroup and GameStageAdjust settings for each volume has caused all sleeper spawns to stop working. I even tried undoing the changes and they still won't spawn. No errors in console either. I visited other POIs on the map and confirm sleeper spawns were working so the problem is only isolated to my custom prefab.

 

Deleting the region files resets any damage I caused to the POI however the sleeper spawns remain borked. Any of you run into this problem before?

 

Yes. I am not sure but I assume the sleeper volumes aren't stored in the region files. I made a test spawning a prefab with ~3000 sleeper volumes in it.

 

Observation:

The size of the main.ttw file was 8 kb before generating the prefab. After spawning the building the size changed to 1220 kb.

 

So I think the volumes are include in main.ttw. Perhaps you have to reset this file...

Edited by Pille (see edit history)
Link to comment
Share on other sites

ok, so i learned something. i don't know if it's common knowledge, but it helps me a lot.

 

Sleepers do not spawn if you are in line-of-sight of the spawn.

 

i tested this with 4 sleeper volumes. 1 was covered in two walls of glass (the game thinks glass isn't line of sight, nor can zombies see through it...nor can night vision goggles for that matter [the googles can't tell there is light]), the second was the same thing but just with 1 layer of glass, the third was an iron bar cage, and the fourth was special. The other 3 only had 1 spawn block for each volume, the 4th one had 2 spawn blocks for just 1 volume. One of those blocks was completely cut-off from my line of sight in a 2 layer glass box, and the other spawn was in a ironbar cage.

 

upon testing "S_Lootroom_XL" for each of them, i found that all the "hidden behind glass" spawners worked instantly and without issue. The cage spawners with see-through ironbars however did not spawn until i expanded the volume and put a wall between me and the ironbars. When i did that, both of volume 4's spawners worked immediately.

 

My hope with volume 4 was to keep 1 alive and out of the way, so the other zombie spawner in the cage would respawn fast and allow for easy target practice without constant F6 menu spawning; however, i must be missing something because that spawner only spawns them once and thats it. the XL room should have at least like 5 right?

 

maybe if i really expand the volume so that i can keep it active from almost any corner.

 

settime 1000 7 0 and a volume with 11 spawns, each hidden from each other, results in a spawn rate that i have a hard time keeping up with.

 

this might be for a good "shooting arena" in a training environment for noobs. which is what i'm trying to make.

 

update:

watching them it seems that once you leave the volume area they despawn very fast. They also seem to respawn fast too, at least on the extreme day of 1000.

 

update:

plans are to remove the sleepers from my training arena, but maybe i should just leave them in with a glass maze?, not even in cages. could be fun.

 

it'll either have to be a small maze or a new prefab made to order.

Edited by layarion (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...