Jump to content

Snufkin's Custom Server Side Zombies - PLUS (A20)


arramus

Recommended Posts

Hi and thx for this great Mod :)

 

I am,lets say a hobby coder,but very new to customizing 7d2d stuff.

So i wonder, how can i deactivate some of the Zombies?

I  deleted all entrys of the shark in the /Mods/SnufkinCustomZombiesPLUS_A20_2021Dec07/Config/entitygroups.xml

but there still shows up sometimes ?!?

do i have to delete something in the entityclasses.xml too ?

 

Link to comment
Share on other sites

1 hour ago, mr_renderson said:

Hi and thx for this great Mod :)

 

I am,lets say a hobby coder,but very new to customizing 7d2d stuff.

So i wonder, how can i deactivate some of the Zombies?

I  deleted all entrys of the shark in the /Mods/SnufkinCustomZombiesPLUS_A20_2021Dec07/Config/entitygroups.xml

but there still shows up sometimes ?!?

do i have to delete something in the entityclasses.xml too ?

 

In the default entitygroups.xml there are 330 instances of the SharkWFLB.

 

Only 8 of them are in the entity groups for Biomes and areas:

ZombiesNight

ZombiesAll

ZombiesBurntForest

SnowZombies

ZombiesWastelandNightHard

ZombiesForestDowntown

ZombiesForestDowntownNight

ZombiesDesertNight

 

If you've deleted all instances of SharkWFLB then that will purge them all.

 

The remaining 322 instances are in the area below that, but they are for Horde Night on the Blood Moon.

 

I wonder if you have also installed the enZombies Snufkin Add On and the shark has been duplicated in there.

  • Like 1
Link to comment
Share on other sites

16 minutes ago, mr_renderson said:

thanks for the Answers :)

 

Ok i get it now...

And i guess the last Sharks my Player saw,was already spawned ones ^^

 

Nope,just installed the SnufkinServerSide Mod

 

so i think its cleared now :)

That could well have done it. There was a small update with a new character added at the beginning of February, and that will be linked to in the first post, but here it is for convenience. It adds 'Hammer Spammer' and it is a Thor type character who carries an electrified Sledgehammer.

 

https://github.com/arramus/Snufkin-Custom-Zombies-Plus-A20-2022Feb02

Link to comment
Share on other sites

Ok well i have a problem. We are on day 284 and we decided to spice up the server by adding this mof BUT we don't see these zombies spawning.

Well personally i found only 1 after playing like 3 or 4 hours but my friends still didn't found any.

Not sure why this is and how i can fix this.

I know i can change the values from 0.075 to 0.75 or something like that but is it normal i need to change all those values?

I even tried to use godmode and fly all over the map and no success in finding a second new zombie.

Please help 

 

Btw i have the feeling that even the normal zombies are spawning a lot less now. It used to be ok but now we can walk throught village and houses sometime without seeing 1 zombie.

 

Edit: That i found at least 1 tells me the mod was installed successfully otherwise i would have started doubting it. 

Edited by MysticFist (see edit history)
Link to comment
Share on other sites

32 minutes ago, MysticFist said:

Ok well i have a problem. We are on day 284 and we decided to spice up the server by adding this mof BUT we don't see these zombies spawning.

Well personally i found only 1 after playing like 3 or 4 hours but my friends still didn't found any.

Not sure why this is and how i can fix this.

I know i can change the values from 0.075 to 0.75 or something like that but is it normal i need to change all those values?

I even tried to use godmode and fly all over the map and no success in finding a second new zombie.

Please help 

 

Btw i have the feeling that even the normal zombies are spawning a lot less now. It used to be ok but now we can walk throught village and houses sometime without seeing 1 zombie.

 

Edit: That i found at least 1 tells me the mod was installed successfully otherwise i would have started doubting it. 

1. Can you first confirm you installed this version?

https://github.com/arramus/Snufkin-Custom-Zombies-Plus-A20-2022Feb02

 

2. If yes, can you next confirm this folder has been added to your Mods folder?

SnufkinCustomZombiesPLUS_A20_2022Feb02 and not Snufkin-Custom-Zombies-Plus-A20-2022Feb02 which is a holding folder that contains the only one you need SnufkinCustomZombiesPLUS_A20_2022Feb02

 

3. Can you also confirm that you haven't installed the enZombies Mod and its Snufkin Addon?

 

4. Can you confirm that when you are in God Mode and press the F6 key, you can type 'Slasher' and the name Navezgane Slasher will appear?

 

5. Can you finally confirm that clicking on the Navezgane Slasher spawns it into the World?

Link to comment
Share on other sites

1 Yes

2 Yes i noticed and took the right folder

3 I did not install enZombies and the Sufkin Addon

4 Yes he did appear

5 Yes i can spawn the zombies in the world

 

As said i have the feeling it is installed correctly but they simple don't seems to appear.

At least once in 4 hour for me and not at all for my friends yet.

Pretty weird.

 

 

 

Link to comment
Share on other sites

14 minutes ago, MysticFist said:

1 Yes

2 Yes i noticed and took the right folder

3 I did not install enZombies and the Sufkin Addon

4 Yes he did appear

5 Yes i can spawn the zombies in the world

 

As said i have the feeling it is installed correctly but they simple don't seems to appear.

At least once in 4 hour for me and not at all for my friends yet.

Pretty weird.

 

 

 

It's very low. Very low. In fact, they are added to the new Down town night spawning feature 'ZombiesForestDowntownNight' which I was concerned about at first as it has a pretty high spawn rate. I do see them a lot in these areas.

 

If you send your server IP, and possibly let me have temporary Admin control if we are in there at the same time, I can visit a few areas and get a feel for what's happening in the server. I am also interested to hear if there are any other mods which add entities that might be overriding or conflicting. You mentioned that even the normal zombies may be spawning a lot less now, and this is symptomatic of possibly something else at play.

Link to comment
Share on other sites

5 hours ago, Shebuk said:

Good evening, I installed this mod but when I start the game I'm getting EXC Null References errors, they won't stop spamming what could it be?
 

It could be:

Using an A19 version in A20 or vice-versa.

A mismatch with another Overhaul or mod.

Corrupt files.

An incomplete install.

 

More information would be useful to assist with diagnostics.

Link to comment
Share on other sites

  • 2 weeks later...

There is not a compatible non PLUS variety available.

 

It is easy to make changes to what can appear and how often they appear by editing the entitygroups.xml.

This file governs where they spawn, how often they spawn, and what can spawn.

Removing the line connected to the entities you do not want to spawn will remove their spawn capability.

Link to comment
Share on other sites

36 minutes ago, arramus said:

There is not a compatible non PLUS variety available.

 

It is easy to make changes to what can appear and how often they appear by editing the entitygroups.xml.

This file governs where they spawn, how often they spawn, and what can spawn.

Removing the line connected to the entities you do not want to spawn will remove their spawn capability.

 

Gotcha, another question do I need to remove all of the entries inside this (zombie entities all in one-line) as well? these are all in oneline.

I think about 300+ of each zombies are in here. If yes, just need to format it, then remove each line right?

 

feralHordeStageGS1-4084

 

 

<append xpath="/entitygroups/entitygroup[@name='feralHordeStageGS1']"><entity name="ZombieArchon" prob="0.05"/><entity name="ZombieUndertaker" prob="0.1"/>...</append>
Edited by zorxgg (see edit history)
Link to comment
Share on other sites

18 minutes ago, zorxgg said:

 

Gotcha, another question do I need to remove all of the entries inside this (zombie entities all in one-line) as well? these are all in oneline.

I think about 300+ of each zombies are in here. If yes, just need to format it, then remove each line right?

 

feralHordeStageGS1-4084

 

 

<append xpath="/entitygroups/entitygroup[@name='feralHordeStageGS1']"><entity name="ZombieArchon" prob="0.05"/><entity name="ZombieUndertaker" prob="0.1"/>...</append>

This section governs the Horde Night and there will be very many entries for the Shark and Mittens in there.

Each individual entry connected to only those entities needs to be removed such as <entity name="Mittens" prob="0.15"/>

 

The <  /> areas 'open and close' each individual entities code. Nothing else needs to be removed beyond their own individual entries.

Link to comment
Share on other sites

Hey hello, I've been using this mod on my server and it's great! thank you for making this. I have ran into an occurring problem:

 

Infections are incurable...They go down to 0.0% and once antibiotics are warn out, it slowly goes back up again. I am not sure what is causing this. I am confident it is not your mod specifically as I am using enzombies + Patch and also Infection Buff mod. However I would like to ask for your input and see if there's a way to fix is by editing the right file. 

Link to comment
Share on other sites

7 hours ago, DefiantDucky said:

Hey hello, I've been using this mod on my server and it's great! thank you for making this. I have ran into an occurring problem:

 

Infections are incurable...They go down to 0.0% and once antibiotics are warn out, it slowly goes back up again. I am not sure what is causing this. I am confident it is not your mod specifically as I am using enzombies + Patch and also Infection Buff mod. However I would like to ask for your input and see if there's a way to fix is by editing the right file. 

It's a case of elimination and pairing to see which one may need an update or which pairings cause conflict. There was an enZombies release which also changed the infection rates a while ago but I'm not sure if that was removed or remains. If it remained, there is the possibility of compound infection values. Are you using the doughphungus Infection Buff Mod? That only appears to change the time infection rate increases using a random 'bad luck' feature. The Snufkin side of things has no additional infection edits beyond any regular chance as with the default zombies. It'll take time for sure, but running them alone and then in pairs will help show where the 0% infection rate isn't being recognized as a cure and removing the infection.

Link to comment
Share on other sites

Hi arramus :)

 

after i deleted some of the unwanted Zombies,by editing the entitygroups.xml , i wonder does it effect the spawnrates at all?

Some Players report me,they have very low Contacts of any Zombies at the Wasteland.

 

Just need a Hint on where to define the Overall Spawningrates. Is it just in that File or is there a file from the Vanilla Files?

 

I want to ramp up the Spawns in the Wasteland

 

Any Advice would appreciated

 

TY :=)

 

Link to comment
Share on other sites

4 hours ago, mr_renderson said:

Hi arramus :)

 

after i deleted some of the unwanted Zombies,by editing the entitygroups.xml , i wonder does it effect the spawnrates at all?

Some Players report me,they have very low Contacts of any Zombies at the Wasteland.

Deleting unwanted zombies from the entitygroups does not effect the overall spawnrates.

 

Overall spawnrates are governed in the default spawning.xml

The default values for the Wasteland are currently:

 

	<biome name="wasteland">
		<spawn maxcount="1" respawndelay="0.3" time="Day"	entitygroup="ZombiesWasteland" notags="commercial,industrial,downtown" />
		<spawn maxcount="2" respawndelay="0.001" time="Night" entitygroup="ZombiesWastelandNight" notags="commercial,industrial,downtown" />

		<spawn maxcount="4" respawndelay="0.033" time="Day" entitygroup="ZombiesWasteland" tags="commercial,industrial" notags="downtown" />
		<spawn maxcount="4" respawndelay="0.002" time="Night" entitygroup="ZombiesWastelandNight" tags="commercial,industrial" notags="downtown" />

		<spawn maxcount="4" respawndelay="0.0167" time="Day" entitygroup="ZombiesWastelandDowntown" tags="downtown" />
		<spawn maxcount="4" respawndelay="0.002" time="Night" entitygroup="ZombiesWastelandDowntown" tags="downtown" />

		<spawn maxcount="1" respawndelay="0.3" time="Any" entitygroup="EnemyAnimalsWasteland" spawnDeadChance="0" />
	</biome>

 

Changing the very first entry for "Day" to match the values for "Night" below it for the maxcount and respawndelay will stop any comments from players that there is low contact with zombies in the Wasteland. Even though the spawn rate and frequency will be high, depending on your server settings it will still be reasonably mild if daytime is set to non feral and less than sprint.

  • Like 1
Link to comment
Share on other sites

22 hours ago, arramus said:

It's a case of elimination and pairing to see which one may need an update or which pairings cause conflict. There was an enZombies release which also changed the infection rates a while ago but I'm not sure if that was removed or remains. If it remained, there is the possibility of compound infection values. Are you using the doughphungus Infection Buff Mod? That only appears to change the time infection rate increases using a random 'bad luck' feature. The Snufkin side of things has no additional infection edits beyond any regular chance as with the default zombies. It'll take time for sure, but running them alone and then in pairs will help show where the 0% infection rate isn't being recognized as a cure and removing the infection.

I have found the culprit, H7SB office seats: this had coding for infection state to always been enabled regardless of cure stage and also stopped people producing grease monkey bike handle bars.  Unusual but there it is. Thank you for your time in the matter. Out of curiosity, is there a patch to make your pack work with Robeloto’s Custom Zombies? I love both your work so much and I'm wondering since both use the same format and XML's is it possible to have both compatible?

 

Thanks again,

Link to comment
Share on other sites

4 hours ago, DefiantDucky said:

Out of curiosity, is there a patch to make your pack work with Robeloto’s Custom Zombies? I love both your work so much and I'm wondering since both use the same format and XML's is it possible to have both compatible?

 

Thanks again,

I just attempted to run them both together, and the enZombies in the mix as well. Here's just an image on the Robeloto's and their cousin Snufkin's tag teaming.

 

We have the Chicken Demon and Mother Clucker from Robeloto and Snufkin respectively.

The Glow Bear and Snow Bear.

And Rad Robot and Rad Shower Wight.

They make some decent tag team combos.

20220308133252_1.thumb.jpg.9b5dac399d017f418857d70254989a64.jpg

 

I didn't thoroughly check for any issues but they certainly loaded up just fine.

As both mods contain a separate Horde Night spawning list, this may cause some server slow down on a server with many players but I can't be totally sure until it's tested. I believe Robeloto may plan to merge them together once A20 is a little more stable, and is very welcome to do so.

Link to comment
Share on other sites

It's just a SP test with Robeloto's and Snufkin's for a Blood Moon and both sets are spawning very well.

I was eliminating all the Vanilla Zombies until they stopped appearing and it reached max BM spawns.

A nice mix of the two types.

20220308141312_1.thumb.jpg.fabbe85919e944069aa3d53b204b93fa.jpg

 

Link to comment
Share on other sites

11 hours ago, arramus said:

It's just a SP test with Robeloto's and Snufkin's for a Blood Moon and both sets are spawning very well.

I was eliminating all the Vanilla Zombies until they stopped appearing and it reached max BM spawns.

A nice mix of the two types.

20220308141312_1.thumb.jpg.fabbe85919e944069aa3d53b204b93fa.jpg

 

WOW! okay do you use the enzombies patch for both yours and robeloto patch for enzombies? also as a question, some packs of zombies in spawns on the multiplayer server are causing an error log to do with entities spawn inside buildings, doesn't break the game just causes one line of red text. only happens randomly and not all the time though.

 

Edited by DefiantDucky (see edit history)
Link to comment
Share on other sites

1 hour ago, DefiantDucky said:

WOW! okay do you use the enzombies patch for both yours and robeloto patch for enzombies? also as a question, some packs of zombies in spawns on the multiplayer server are causing an error log to do with entities spawn inside buildings, doesn't break the game just causes one line of red text. only happens randomly and not all the time though.

 

Sometimes I use just Snufkin and Robelotos together, and sometimes I use the enZombies plus the patches for Snufkin and Robelotos (although I remove robot1 from the enZombies patch because it no longer exists ;) )

 

It seems the red text, probably an NRE is possibly linked to a certain kind of car 'sedan' as we could check this issue after the enZombies were added inside buildings. It only happened in certain buildings and with that certain vehicle. It is a known issue with the TFP developers.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...