Jump to content
Sign in to follow this  
Mad_Republican

Fresh Install, Game Crash Upon Loading SAVED Random Gen Game

Recommended Posts

Alienware Area-51 R2 Desktop

Intel® Core i7-5930K CPU @ 3.50GHz

Dual NVIDIA GeForce GTX 970 in SLI

Driver version 442.50

2560x1080 monitor, 60Hz

Windows 10 Home, 64-bit

16GB RAM

Alienware 1500 Watt Multi- GPU Approved Power Supply

 

Tried w/Direct X 10 and 11

Tried w/Anti Cheat and w/out

Uninstalled and Reinstalled Game, I usually build a new random gen game, play for hours (great), then next day, attempt to load saved game, which results in game slowing down (FPS drop to single digits), locking up, then crashing into system reboot.

I CAN eventually get back into the game by re-trying after crashes (sometimes the next try, sometimes multiple attempts), but eventually, the game files get corrupted.

 

Here's the most recent log: https://pastebin.com/W9xZFqqh

 

I've been having this problem for many weeks now, but I think I'd like to fix it for good - any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Cool - no responses, so I tried a few things on my own - installed some Windows updates, upgraded to Alpha 18.4b4, loaded a SAVED game that I was enjoying last night and system crashed to reboot within 30 seconds of playing this evening. All I can report is that the framerates looked decent (50-60) right up until the crash freeze, then after about 5 minutes, system rebooted. Here's the really weird thing: no log at all to look at. So instead, I'm going to link the log from my last save, where I believe I exited the game safely. The crash was from trying to load the SAVED game in this save/exit log:

 

https://pastebin.com/D12Bx6k3

 

I DO NOT have a crash log to share, so I'm going to try to play it again, this time WITHOUT EAC and see what happens. More to come!

 

Share this post


Link to post
Share on other sites

Okay, that didn't take long - exact same behavior with EAC turned off. I got to mine a few blocks of stone underground for about 60 seconds before lock up and crash-reboot. Here is the log:

 

https://pastebin.com/pcqgvtb5

 

So here's the deal - I LOVE this game, I've played 3,141 hours of this game and with COVID-19 spreading all around the world, playing this game is exactly how I want to pass the time while this thing either passes over my community or knocks me out with flu symptoms. So...please, any advice at all would be greatly appreciated :)

Share this post


Link to post
Share on other sites

Normally if I get frequent crashes and nothing seems to help, I would reinstall my W10. If that is out of the question, the only other tip I can give is to try setting up a dedicated server on that save and join it. The dedicated server will have the output logs inside the 7 Days to Die Dedicated Server\7DaysToDieServer_Data folder. Paste that log here.

Share this post


Link to post
Share on other sites

Thanks much! I'd rather not reinstall W10, but I can try the dedicated server option and see if that yields more data - thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

If the system is rebooting I would guess it's the power supply. Try stressing your system running furmark and prime95 at the same time.

If it reboots, you're having a hardware failure.

 

Edit, also, you could lower your graphics settings. They seem pretty high for that card and you're running wide screen for extra stress.

Try turning off Shadows and Reflections. I would just try the lowest settings and see if it crashes, if not then work up from there.

Your game may be fubar though so test with a new game.

Edited by Beelzybub (see edit history)

Share this post


Link to post
Share on other sites

As Beelzybub says, it might be the hardware. Check if your graphics cards fans are really working, mechanical parts like the fans have a good chance to wear out after a few years of operation

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks, guys - these are all great ideas. Here's the progress I've made:

 

1. I tried running a dedicated server and then logging into it with the client yesterday. My wife and I played for hours, without incident, and then I shut down the server, thinking all was well.

 

2. Now that wife is at work (night shift nurse), I thought I'd make a different game on the server and just play solo...CRASH to Windows (no reboot). Here are the logs:

Client Log (Using DirectX11) https://pastebin.com/88YEUuj4

Server Log: https://pastebin.com/KSxqwHcM

 

3. I can clearly see the errors in the log about DirectX11, so I go back and force the use of D10 via the command line. This time, the games stalled a bit, then resumed, then stalled, locked up and rebooted. Here are the logs:

Client Log (Using DirectX10) https://pastebin.com/RxZQTxx6

Server Log: https://pastebin.com/tuaCn0QH

 

4. SO THEN....I read your posts about stress testing with Furmark and Prime95 at the same time, which my system does just fine (no power or temp issues, certainly no reboot).

 

5. While shutting down the tests and looking at Task Manager, I notice a process that's sucking us as much power as either of those apps: Microsoft's CompatTelRunner.exe - some sort of app that writes a ton to the hard drive and sucks up power to report compatibility issues back to Mother Microsoft (WTF?). I've disabled the app and now I'm ready to try testing again.

 

6. It's interesting that using Dx11, the Crash Handler was able to run and write to the logs, but Dx10 crashed with reboot and nothing written to the log.

 

Thanks again for the support so far - I'm going to try turning down the settings a bit and see what happens. My rigs is almost 5 years old, but she was top of her line back in the day, so I was pleased to see that she could handle Furmark and Prime95 long enough to bore me. Any advice based on the logs, while I keep testing?

Edited by Mad_Republican (see edit history)

Share this post


Link to post
Share on other sites

Both of your client logs say:

 

Version: Direct3D 11.0 [level 10.0]

 

Actually all of your logs say that.

 

Mine says: Version: Direct3D 11.0 [level 11.0]

 

Something's up there.

 

Have you tried GLCore?

 

And I think your drivers are messed up. I'd uninstall using DDU, then when you reboot

and windows prompts to install a driver, decline the offer and reinstall the latest NVidia driver.

 

 

 

Share this post


Link to post
Share on other sites

Thanks, Beelzybub,

 

I managed to DDU the NVIDIA drivers, and reinstall them. I started a new game and crashed shortly into it, but crash handler was able to capture a log and boot me back out to Windows instead a reboot. Here's the log:

 

https://pastebin.com/wuycBNzd

 

It sure seems to be a Direct X issue - I seem to have difficulty getting it use DX11 instead of 10, no matter what I do. I've tried reading several articles about how to mitigate that, which I'll post on after I try them. I'm going to try GL Core next.

Share this post


Link to post
Share on other sites

I did a file validation and found 1 file out of order, so it was reacquired. GLCore turned on resulted in a crash back to Windows BEFORE I was even able to enter the game (it crashed at the beginning of generating a new random map, maybe 10 seconds into the process). Here is the log:

 

https://pastebin.com/wtpdsVQY

 

Please let me know you have any other ideas to try. Thanks in advance!

Share this post


Link to post
Share on other sites

Checked validation and AGAIN, a 128 byte file was corrupted, so it was reacquired. Trying Open GL Core w/out Exclusive Full Screen setting...Result: Game crashed and system reboot after about 1 minute of playing (managed to make a bedroll and that's about it). Here's the log:

 

https://pastebin.com/eTMztePH

 

Okay, enough failures for one night. I'll try some new Kung Fu on this tomorrow.

Share this post


Link to post
Share on other sites

Ok so im kinda in the same boat as you. Did a fresh install and booted up with directx11 and I noticed it's running the CPU to death up to 99% even at the main menu. Gpu isn't taking any load. Tried GLCore and the CPU was back to normal but crashed trying to load a new level. I feel it might be driver 442.50. I'll try reverting back a bit later. Can you check if your CPU usage is high with directx11?

Share this post


Link to post
Share on other sites

Okay, thanks for the responses.

 

Beelzybub - no overclocking on my system - I never had to do so, so I actually had to look up how to do that just to make sure I wasn't.

 

BeatKidz - I'll give feedback on the CPU and both GPUs on this next run, but keep in mind that I appear to be having difficulty getting DX11 to engage - all my logs indicate DX10 is being used.

Share this post


Link to post
Share on other sites

That didn't take long: CPU at 8%, GPU1 at 1%, GPU2 at 2%, immediately crashed back into Windows upon loading saved game, using GLCore. Here's the log:

 

https://pastebin.com/14gJeChb

 

So basically, it was toast before the system was even close t be stressed. I'm going to back and see if I can solve the DX10/11 issue instead of GLCore.

Share this post


Link to post
Share on other sites
Posted (edited)

Forgetting to go through all the steps...first, I validated files (1 needed to be reacquired), then I tried DX11. Here are the throttles BEFORE loading 7Days and just before crash:

Before Loading: CPU @ 2%, GPU1 @ 0%, GPU2 @ 0%

Just before Crash: CPU @ 18%, GPU1 @ 85%, GPU2 @ 8%

 

This time crash ended in reboot. Here is the log:

https://pastebin.com/k89Qfq8s

 

Beelzybub, I finally got it to use DX11 (Direct3D 11.0 [level 11.1])! I had read a thread about forcing DX10 as a command line option and forgot to go in and delete it. So, now I've DX11 working, I noticed that mine is 11.1 and yours is 11.0 - could that be a problem?

Edited by Mad_Republican (see edit history)

Share this post


Link to post
Share on other sites

Alright, last attempt for the evening. It occurred to me that if I had forgotten about the DX10 override command line option, it was probably confusing to the system when I told it to use GL Core, so I'm going to try GL Core again and see what it does (without the command line DX10 override). First, I verify integrity and reacquire that file that keeps getting corrupted. Generated a new game, and before I could pick enough grass to make a bedroll, crash reboot. Here is the log:

 

https://pastebin.com/2HPFGjAd

 

Happy Friday night and stay safe!

Share this post


Link to post
Share on other sites
Posted (edited)

Woke up this morning and wanted to continue attacking this problem, specifically that Beelzybub and I believe involve DirectX - I HAVE the lastest version installed, but when I try to re-install it, I get the message that it's already up to date (or a newer version exists). Looking at the registry entries for Direct X, I notice that there are four(4) entries under two(2) unique keys:

 

297395577_DirectXRegistryEntries20200314.png.46e4694bfd5e397feac9a6b00b4851b7.png

 

Would anybody out there (who is NOT having problems) please let me know if you have multiple entries in your registry for DirectX? I could be wrong, but I don't think I should have two different versions of the same key, with different values. I THINK the green-circled values are the correct entries, leading me to think that I should delete the others, but messing with the registry can be nasty business and I want to move slowly before trying this. Any thoughts?

Edited by Mad_Republican (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Beelzybub, I finally got it to use DX11 (Direct3D 11.0 [level 11.1])! I had read a thread about forcing

DX10 as a command line option and forgot to go in and delete it. So, now I've DX11 working, I noticed

that mine is 11.1 and yours is 11.0 - could that be a problem?

 

Windows 7 = DX11 (11.0)

Windows 8 = DX11 (11.1)

Windows 8.1 = DX11 (11.2)

Windows 10 = DX11 (11.3)

 

I'm on Win7 so mine says 11.0

I think the version used is up to the game to decide and maybe for win 10/7D2D it uses 11.1? Just guessing.

 

I can't read that screenshot to check registry settings. Maybe you could post it somewhere else,

like imgur or ?

 

Edited by Beelzybub (see edit history)

Share this post


Link to post
Share on other sites

Okay, I may have found a breakthrough and it's exactly what Beelzybub hinted at - something's wrong with my Direct X. Let me finish testing this evening and then I'll share what I have found.

Share this post


Link to post
Share on other sites

Well, crap! I happened to notice that my Direct X was Version 12 and I purchased a tool to help me remove DirectX, then reinstalled just version 11, which seemed to work great! Last night, I was able to generate a random gen game and played for HOURS. I got tired and exited the game and thought I'd continue where I left off this evening. No such luck - crash upon entering the game, but the crash handler caught the log and I didn't suffer a Windows reboot. Here's the log:

 

https://pastebin.com/hsjygkqC

 

The one good thing is that now my DirectX version matches what Beelzbub has in his logs (11.1 instead of 11.2, which I had under DirectX12). So now I'm back to the drawing board. Any advice on what to try next?

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry I'm late to the party but I thought this was likely a simple issue someone else could have figured out right away... guess I was wrong. I'm also not going to read every single post as I have more important things to do right now... like horde some toilet paper, kidding obviously.

 

When you say you did a fresh install of Windows 10, the first thing that comes to mind is drivers and windows updates. Did you complete all the updates, including that annoying 1903 update that does nothing but takes forever to install and sometimes fail for random reasons but allows updates like .NET 4.8 and other things that could stabilize the OS during gaming? Windows 10 is still somewhat unpredictable which is why updates (especially the initial ones) are so important. Did you make sure to install proper Nvidia drivers and not Microsoft's garbage drivers? Also, have you tried disabling SLI mode seeing as how this game doesn't support it anyways? Also, do you have any 3rd party apps that run in the background that could interfere with the game in any way shape or form, such as FPS counters, screen record software, etc... just for the sake of narrowing it down, I'd start with disabling those.

 

EDIT: Ok, so I read your last post... having DirectX12 doesn't mean you don't have the option for DirectX11 in gaming. It just means you have the latest version of DirectX and can run any game using DirectX12 or older, including DirectX8 and DirectX9 games (if you can still remember those). Get yourself back up to DirectX12 as you'll benefit from it with a lot of other games.

 

RE-EDIT: Also, if by chance your OS set you into a blue screen of death or restarted the machine entirely without crash log, then it's more than likely a hardware issue and not software. First test for that would be a free memtest86, then do some stress tests starting with GPU, then CPU, then PSU. And do keep in mind that not all stress tests are created equal. What might seem stable with one stress test might fail with another.

 

RE-RE-EDIT: Also, in case this hasn't been mentioned already as it's usually the go-to answer, but did you verify the integrity of the game files with Steam yet?

Edited by Fox (see edit history)

Share this post


Link to post
Share on other sites

So here's the question I'm facing - what would allow my system to generate a random gen game, play for hours without a hitch, then load that same game the next day and have it crash immediately upon entering the game, without any changes to settings?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...