Jump to content
bbh_blocked_dnftl

Grim's Unity Asset Editor


grimreefer24601

Recommended Posts

I've looked around and most of the 9.0c stuff is considered "outdated" by Windows and will not install. Even the directx 9 Web player crap won't install on windows 8. Is it possible for you to release a simplified import/export plugin just like the audio one? Everything else works perfectly fine except for when the application tries to pull up a texture to display.
Link to comment
Share on other sites

[QUOTE=mrscratch;43356]I've looked around and most of the 9.0c stuff is considered "outdated" by Windows and will not install. Even the directx 9 Web player crap won't install on windows 8. Is it possible for you to release a simplified import/export plugin just like the audio one? Everything else works perfectly fine except for when the application tries to pull up a texture to display.[/QUOTE] [url]http://www.neowin.net/forum/topic/1064760-installing-directx-9-on-windows-8/[/url] There are links and help in that thread to get DX9 installed on Win8.
Link to comment
Share on other sites

[QUOTE=Red Eagle LXIX;36649]This mod is [U]ONLINE compatible[/U]. This will only work when user is host, or server is running it. Tested against local dedicated server run from an unmodified folder. So, if you are running this mod, your single player games (any you host) will not have ZombieDogs, Hornets, or Fat Zombie Cops. If you join a server NOT running this mod, you will still see dogs, hornets, and fat zombie cops. If you join a server running this mod (doubt there is even 1 out there), then you would not see them even if you were not running the mod. I'm not updating the README. :p[/QUOTE] There is now. =]
Link to comment
Share on other sites

[QUOTE=Ekk0;43528]There is now. =][/QUOTE] That is cool to hear. TY, and hope you enjoy. I don't know if you grabbed that version or the new one with more choices so I'll throw the link just in case (A7.1 and A7.2 tested): [url=http://7daystodie.com/forums/showthread.php?5660-MOD-No-Specials-v0-02-A-7DTD-Alpha-7-1%28b1%29-mod-by-Red-Eagle-LXIX][MOD]No Specials v0.02[/url] Thanks again to Grim for this wonderful Utility.
Link to comment
Share on other sites

[QUOTE=grimreefer24601;43610]Here you go mrscratch. This version has all the DX stuff removed. Let me know if it works out for you. [URL="http://www.mediafire.com/download/g4bjx7zxppi69pw/Texture.zip"]No DX Texture.dll[/URL][/QUOTE] Thanks a lot Grim! I'll check it out as soon as I get home.
Link to comment
Share on other sites

I've been cracking away at the mod installer, and I have it working I think. I need a few people to test it on their end. Please try it and let me know your results. It does cause a UAC dialog to appear asking if the program was installed correctly. This is because the file name has "install" in it, but it doesn't write to the registry. If this bothers you, you can change the file name to whatever you like. The installer does not yet back up your files, so it is recommended that you back them up manually. This mod writes to resources.assets , sharedassets0.assets, sharedassets1.assets, and sharedassets2.assets. Changes to look for: Recolored Fun Pimps Logo Recolored 7 Days to Die Logos Recolored Cursor Recolored Backpack Recolored Belt Recolored Yellow Car to Green Replaced Map with my Labeled Map Mod Reverted Stone Blocks to their original Square Shape Let me know how it works for you, and be sure to back everything up. [URL="http://www.mediafire.com/download/5cusvlq7avxbysh/InstallTest.zip"]InstallTest.zip[/URL]
Link to comment
Share on other sites

I'll give the test mod a go in a bit. Also, forgot to mention a small issue I had. I am not sure which is the issue (Paint.Net or UAE) [url]http://7daystodie.com/forums/showthread.php?5825-DDS-editing-woops[/url] UAE with new texture plugin reported the file as ARGB. In Paint.Net if I saved it as A8R8G8B8 (ARGB) I got the blue-tinted version. If I saved as A8B8G8R8 (ABGR) I got the expected output. Just thought I should mention it.
Link to comment
Share on other sites

Mod Installer Test Report Bug 1 (multiple reproductions): Clicking Back<>Next multiple times between the description and the install path will give this: C:\C:\C:\C:\C:\C:\C:\C:\C:\C:\C:\ Same thing occurs if the Install location fails to verify and you click back to the install path. Or if you click browse and then cancel for the path selection dialog. Bug 2: Path listed was "C:\Program Files (x86)\Steam\SteamApps\common\7 Days To Die" Selected install path was: "D:\Games (Steam)\SteamApps\common\7 Days To Die" Unable to verify install location. also tried: "D:\Games (Steam)\SteamApps\common\7 Days To Die\7DaysToDie_Data" I do not have a default path on C:\ for program files or Steam. So I can not test that as my windows install is highly customized via install scripts that changed a few locations based on my preferences and hardware layout.
Link to comment
Share on other sites

ok, I see why it took so long. It modifies all files that have the same names as the ones it is looking for in any and all subfolders under the target folder. So it modified all my backups as well. I need a few minutes to check a few more things after I do a verify integrity of game cache to restore files. Initial report: Install success. First time I loaded the game it crashed the instant I tried opening backpack. It did not do that on second attempt. I did get the changed graphics in all expected places (you really like green or something?). I also had the square stone when placing stone blocks. (Are you planning on doing that as full mod of some sort?)
Link to comment
Share on other sites

Thanks for testing it out. I hadn't thought about someone keeping back ups with the same name. I always just append .bak to my files. Do you just make a new folder and put them in it? Anyway it's something I'll have to address, thanks for pointing it out. I like green, but it's also really easy in Photoshop to drag a bar in the hue saturation, and get noticeable results. I don't know about modding the game back to square blocks. Maybe later if people still want it, but I like the new terrain.
Link to comment
Share on other sites

[QUOTE=grimreefer24601;44047]Thanks for testing it out. I hadn't thought about someone keeping back ups with the same name. I always just append .bak to my files. Do you just make a new folder and put them in it? Anyway it's something I'll have to address, thanks for pointing it out. I like green, but it's also really easy in Photoshop to drag a bar in the hue saturation, and get noticeable results. I don't know about modding the game back to square blocks. Maybe later if people still want it, but I like the new terrain.[/QUOTE]Exactly what I did, since it was going to impact all the assets files I just made a folder and threw copies in that folder. I still had an original resources.assets because I had backed that up earlier as "resources.A72(b2)_ORIGINAL.assets" and it did not touch that (good). I'm going to test 1 or 2 other things. Will report again in a bit.
Link to comment
Share on other sites

Additional testing notes. Cleared out any same named copies of the files and tried the install again. Much faster. Notes about the modded files themselves. The game has a very prominent lag when using the supplied mod comparative to the unmodded version and to the manually modded versions I was using before (changes on the ones I was using before include your map in resources.assets and my compass in sharedassets2.assets). That is part of what has taken so long, comparing the 3 versions for performance. I placed a stone while in the normal organic mode, and then loaded the same save with the modded settings and it looked interesting: [img]http://cloud-3.steampowered.com/ugc/487818227912749930/EA2D5F36F47550AE7C519C6C2B90B8AA4F14425D/[/img]
Link to comment
Share on other sites

The stone applies to all stone not just ones set after using the mod. It likely this that causes the lag. I've noticed differing lag across different areas. In my mine I get terrible Z Fighting between natural blocks and the stone. Perhaps if all the blocks were returned to square it would not lag, but I think there's too much intersection going on only changing the one block.
Link to comment
Share on other sites

I was going to say, blocks placed after the mod appear without the merging like in this screenshot: [img]http://cloud-4.steampowered.com/ugc/487818227913154648/5CDA89E1CF72F17E1E5C09E369EB01B3DBC5246D/[/img] Overall, great work. I'd call the installer a success. Worked fine and quickly once I cleared out the excess same named files from subfolders. (Serious OCD issue, that was a new save I did just for these tests, but when a spiderzombie smashed a tree to the ground I had to go get the wood even though I KNOW I won't ever actually be playing that save as a real game). Liked your 7DTD_logo_top. I think I'll be using that going forward. Disappointed you didn't include smiling spiderzombie shirt, my art skills stink so I'm no good blending such things onto textures and having them look right and keep the proper perspective when wrapped onto the model.
Link to comment
Share on other sites

Thanks again for testing it. I hope I can get a couple of more people to try it before I release v0.2. I feel better know it's been through a non standard install though. Course the real test will happen when it's used to distribute mods. I'm pretty happy with it right now, and it creates identical files to one's created in the editor, so I'm pretty confident it will work for most people. And I'm positive it will fail for others.
Link to comment
Share on other sites

[QUOTE=grimreefer24601;44087]Thanks again for testing it. I hope I can get a couple of more people to try it before I release v0.2. I feel better know it's been through a non standard install though. Course the real test will happen when it's used to distribute mods. I'm pretty happy with it right now, and it creates identical files to one's created in the editor, so I'm pretty confident it will work for most people. And I'm positive it will fail for others.[/QUOTE] Well, another positive, I also tested it against files that had changes and the install worked there as well. So that was good too. In the release v0.2, will it work to open the pre-packed mods and see what it contains? Also, your models_2.xml is from A7.1 that file did change between A7.1 and A7.2 for one line: A7.1[code] [/code] A7.2[code] [/code] Noticed while looking for which method you used to restore stone to square.
Link to comment
Share on other sites

[QUOTE=Eleazaros;44229]Odd - It won't open the resources.assets file. It just crashes. It does open the other asset files, just not that big one.[/QUOTE]Use the newer one: [url]http://7daystodie.com/forums/showthread.php?5030-Grim-s-Unity-Asset-Editor-V0-1&p=39614&viewfull=1#post39614[/url] Post# 55 in the thread.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...