Jump to content

IndexOutOfRangeException: Index was outside the bounds of the array. Unmodded Navezgane MP Local


cm272

Recommended Posts

Hello!  As per my title, I've been getting "IndexOutOfRangeException: Index was outside the bounds of the array." errors on my unmodded Navezgane MP Local server when my friend is also in the server with me.  No issues when alone.  This began in our late 70s as far as day and I cant think of what would have initially triggered it.  

 

The console will randomly open 1-3 times a second, making my experience unplayable; no matter how quickly I dismiss the console, it just keeps coming back. 

It's inconsistent, though;  Sometimes I will go 5+ seconds where no error occurs.  It may be related to him moving/taking action.  He doesn't experience any issue whatsoever.

 

This only in certain unexplored areas (potentially near the N/S borders of the map, as we've only come across it in the desert and arctic).  We can replicate the issue by having him cross over an invisible line.  For example, as soon as he enters the parking lot at Red Mesa, I'm inundated with console notifications.

I've tried searching the forums for similar issues, but it seems most come across this with modded servers, or in relation to placing blocks/being on inventory screen, neither of which applies to us.

 

What I've tried:

-Verifying game integrity through steam.

-Restarting server, computers/steam innumerable times.

-Being very far away from friend when he enters problem area.

-Having friend be very far away from me while I enter the problem area.

-Both of us having an empty paper doll and inventory

 

Where I'm stuck:

-want to try having him host, but following the instructions to migrate a world file is not working for us as it doesn't show up in world list in game menu, despite being in appdata/roaming/7daystodie/saves/navezgane

-cant find info on deleting player profile, and would rather not do this if all he has to do is drop an item or abandon a quest or something to fix this.  I only just came up with this idea because one of the sub-errors in the log below mentions a treasure map.

-The game also seems fine other than console interruption, so if there's some sort of way to disable console popping up that would be great, but my searches of the forums lead me to believe this isn't possible.

 

Example log. Searching for "Index" will get you what you need.

https://pastebin.com/icD9EDA4

 

Thanks kindly!

Link to comment
Share on other sites

34 minutes ago, cm272 said:

Hello!  As per my title, I've been getting "IndexOutOfRangeException: Index was outside the bounds of the array." errors on my unmodded Navezgane MP Local server when my friend is also in the server with me.  No issues when alone.  This began in our late 70s as far as day and I cant think of what would have initially triggered it.  

 

The console will randomly open 1-3 times a second, making my experience unplayable; no matter how quickly I dismiss the console, it just keeps coming back. 

It's inconsistent, though;  Sometimes I will go 5+ seconds where no error occurs.  It may be related to him moving/taking action.  He doesn't experience any issue whatsoever.

 

This only in certain unexplored areas (potentially near the N/S borders of the map, as we've only come across it in the desert and arctic).  We can replicate the issue by having him cross over an invisible line.  For example, as soon as he enters the parking lot at Red Mesa, I'm inundated with console notifications.

I've tried searching the forums for similar issues, but it seems most come across this with modded servers, or in relation to placing blocks/being on inventory screen, neither of which applies to us.

 

What I've tried:

-Verifying game integrity through steam.

-Restarting server, computers/steam innumerable times.

-Being very far away from friend when he enters problem area.

-Having friend be very far away from me while I enter the problem area.

-Both of us having an empty paper doll and inventory

 

Where I'm stuck:

-want to try having him host, but following the instructions to migrate a world file is not working for us as it doesn't show up in world list in game menu, despite being in appdata/roaming/7daystodie/saves/navezgane

-cant find info on deleting player profile, and would rather not do this if all he has to do is drop an item or abandon a quest or something to fix this.  I only just came up with this idea because one of the sub-errors in the log below mentions a treasure map.

-The game also seems fine other than console interruption, so if there's some sort of way to disable console popping up that would be great, but my searches of the forums lead me to believe this isn't possible.

 

Example log. Searching for "Index" will get you what you need.

https://pastebin.com/icD9EDA4

 

Thanks kindly!

 

Since the error mentions a treasure chest he should delete all quests from his active quest list. If this doesn't help you should too. Probably a good idea to restart the server after deleting.

 

If that doesn't help removing and destroying all his belongings including armor would be the next step. Later you can resupply him from creative menue.

 

 

Link to comment
Share on other sites

7 hours ago, meganoth said:

If that doesn't help removing and destroying all his belongings including armor would be the next step. Later you can resupply him from creative menu.

 

Just to clarify, the above has nothing to do with trying to fix the problem, it's just for Not only could the above advice fix your problem, it's also a great way for venting your frustration. 😄

 

(Edit: rewritten for more obvious silliness.)

Link to comment
Share on other sites

39 minutes ago, Boidster said:

 

Just to clarify, the above has nothing to do with trying to fix the problem, it's just for venting your frustration. 😄

 

Oops, yes, he already tried that and it didn't work.

 

But I assume you think it would never help in the described case? If yes, I would disagree as the null refs sometimes seem to point to the wrong causes

 

Link to comment
Share on other sites

Hi @cm272

 

Sorry you guys are putting up with this; the cause is a known issue where someone reads a treasure quest note near water and the game keeps trying to pick a spot in water for the chest to spawn (and the game doesn't like that). Sometimes it seems it goes into an infinite loop for some reason, so try to figure out who read a treasure note and delete the quest. If the quest has been done or has failed/deleted, you may have the worst case scenario. I would, at this point, simply have whoever read the note put all their stuff up, you delete the profile afflicted, then they come back in and you can use console commands to add levels/whatever books they had.

 

You will find the player profile in %appdata%/7daystodie and follow the path to your navezgane save.

Link to comment
Share on other sites

3 minutes ago, meganoth said:

But I assume you think it would never help in the described case?

 

No no no, I was just trying to make a funny. "Destroy all of your friend's equipment" seems like a funny go-to move in case of problems. "Hey Mark, this bear just glitched through the wall, I'm going to have to destroy all of your stuff again." LOL

 

OP absolutely should do as you suggest.

Link to comment
Share on other sites

44 minutes ago, Boidster said:

 

No no no, I was just trying to make a funny. "Destroy all of your friend's equipment" seems like a funny go-to move in case of problems. "Hey Mark, this bear just glitched through the wall, I'm going to have to destroy all of your stuff again." LOL

 

OP absolutely should do as you suggest.

Ah ok. I'll up the humor factor next time and will recommend wiping the hard disk platters with a clean cloth  😁

Link to comment
Share on other sites

1 minute ago, meganoth said:

Ah ok. I'll up the humor factor next time and will recommend wiping the hard disk platters with a clean cloth  😁

Don't forget to recharge the motor by opening it up then attaching a neodymium magnet onto the top platter and spinning it right round, like a record player.

Link to comment
Share on other sites

4 minutes ago, Jugginator said:

Don't forget to recharge the motor by opening it up then attaching a neodymium magnet onto the top platter and spinning it right round, like a record player.

Usually people don't have good neodyms around, so I tell them how to reach the same effect with common household chemicals, a lighter and a knife. Much safer that way, you could pinch your finger with a good neodym 😁

Link to comment
Share on other sites

10 minutes ago, meganoth said:

Usually people don't have good neodyms around, so I tell them how to reach the same effect with common household chemicals, a lighter and a knife. Much safer that way, you could pinch your finger with a good neodym 😁

Ah! I see you fancy the tactics of MacGyver too

Link to comment
Share on other sites

I just bought the game today, and got same error, everytime i opened my storage container. Console spamming errors and i can't move/close panels,or exit game. Only via Alt-F4. Tried verification of steam files, same again.

Here's the log error:

 

https://pastebin.com/f1d2z6P2

 

Any clue what is about? Game in unplayable atm, since as soon as i go to open storage, kaput. Thanks in advance.

 

Edit: Deleted/reinstalled, verified again. Loaded saved game, again the same. Started new game, no issues at all so far. Perhaps save file gets corrupted somehow?

 

 

 

 


Link to comment
Share on other sites

7 hours ago, Jugginator said:

@iDoser That's an entirely different error but deleting %appdata%/7daystodie should help that out (those are left after uninstalling). I'm asking what the errors may be related to.

 

Do you remember what you were crafting?

The game isn't even fully loaded into the save when it gets the first error. I'm not sure he was crafting anything. Might be an indication of corrupted xml data.

Link to comment
Share on other sites

2 minutes ago, SylenThunder said:

The game isn't even fully loaded into the save when it gets the first error. I'm not sure he was crafting anything. Might be an indication of corrupted xml data.

Yeah the idea about crafting is the ui errors are pointing to item crafting/queue.

Link to comment
Share on other sites

15 hours ago, iDoser said:

Any clue what is about?

What's this line from your output log?

 

2021-04-27T22:16:21 4.071 INF Looking for mods dll at Z:\Steam\steamapps\common\7 Days To Die\7DaysToDie_Data\Managed/Mods.dll

2021-04-27T22:16:21 4.071 INF Trying to add mods.dll

 

I've never seen that in a log before.

Link to comment
Share on other sites

14 hours ago, Jugginator said:

@iDoser That's an entirely different error but deleting %appdata%/7daystodie should help that out (those are left after uninstalling). I'm asking what the errors may be related to.

 

Do you remember what you were crafting?

 

Sorry for late response. I didn't crafted anything at all. Just every time i opened my storage container, console started the infinite errors and i was unable to move/close console/game. Alt+F4 only.

 

7 hours ago, Beelzybub said:

What's this line from your output log?

 

2021-04-27T22:16:21 4.071 INF Looking for mods dll at Z:\Steam\steamapps\common\7 Days To Die\7DaysToDie_Data\Managed/Mods.dll

2021-04-27T22:16:21 4.071 INF Trying to add mods.dll

 

I've never seen that in a log before.

 

Tried a mod to remove crosshairs, but i don't think that was the cause of console error. Aiming with bow and everything related, game was fine. Just as soon as i opened my storage container, game started to act in weird manners. But as i said, even after un-installed/re-installed, went through integrity verifications, again same problem with personal S.Containers. Now started a new game, and problem went away. 

 

Out of topic point,but , performance is really impressive now, and has nothing to do with older versions. Last time i played was back in 2019, and i refunded the game after 30mins due to really horrible optimization. At the moment, everything runs superb (1440p) without a single hiccups/stutterings, etc, at my 6h of game time. Thanks to steam reviews that made me bought it again.

 

PS: If any of the devs etc looking into that thread, please give us option to hide the X style crosshair.It asked from a lot of people since years,and it really hurts the immersion in a great game. Thanks in advance.

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...