Jump to content
Sirillion

SMXhud - (Alpha19)

Recommended Posts

turns out its a glitch with SMXhudTHB

 

Did you install the core modlet from Sphereii that the SMXhudTHB modlet is dependent on?

Share this post


Link to post
Share on other sites
No, Could i get a link?

 

It is on the Mod Launcher. That is the reason this modlet should only be installed installed via the Mod Launcher as per instructions on the OP as the Mod Launcher does the patching of the dll when installing his modlet. Keep in mind that when installing this you will lose the ability to play on EAC enabled servers.

Share this post


Link to post
Share on other sites
It is on the Mod Launcher. That is the reason this modlet should only be installed installed via the Mod Launcher as per instructions on the OP as the Mod Launcher does the patching of the dll when installing his modlet. Keep in mind that when installing this you will lose the ability to play on EAC enabled servers.

 

Thank you, installing now!

Share this post


Link to post
Share on other sites
Thank you, installing now!

 

Remember to turn EAC off in the 7DTD launcher before starting the game. I think you can do that via the Mod Launcher also if launching from there but I am not sure.

Share this post


Link to post
Share on other sites
Remember to turn EAC off in the 7DTD launcher before starting the game. I think you can do that via the Mod Launcher also if launching from there but I am not sure.

 

Yeah its automatically ticked off

Share this post


Link to post
Share on other sites

Hi @Sirillion

 

First of all, thanks for your excellent work. I love your MODs.

 

I've been having a problem with the MOD SMXhudTHB, there's no information of the zombie's health.

I just got the black bar, but no info (as seen on the screen shots) even if I hit a Zombie.

 

I deactivate the EAC with the MOD Launcher.

I have installed the SMXhud MOD first, then the THB one. I've done manually and with the MOD Launcher.

I'm out of ideas.

 

Thanks and good afternoon.

Makurth.

Share this post


Link to post
Share on other sites
Hi @Sirillion

 

First of all, thanks for your excellent work. I love your MODs.

 

I've been having a problem with the MOD SMXhudTHB, there's no information of the zombie's health.

I just got the black bar, but no info (as seen on the screen shots) even if I hit a Zombie.

 

I deactivate the EAC with the MOD Launcher.

I have installed the SMXhud MOD first, then the THB one. I've done manually and with the MOD Launcher.

I'm out of ideas.

 

Thanks and good afternoon.

Makurth.

 

 

Hi, sorry to see you are having some issues.

 

You are probably missing the mod from SphereII that this modlet is dependent on. The 0-SphereIICore modlet.

Share this post


Link to post
Share on other sites

Thank you good sir!!!

Indeed that was the problem, the ShepereII core modlet.

 

Now I'm enjoying your wonderful MOD.

Thanks for answer in no time.

 

Regards,

Makurth.

Share this post


Link to post
Share on other sites
Thank you good sir!!!

Indeed that was the problem, the ShepereII core modlet.

 

Now I'm enjoying your wonderful MOD.

Thanks for answer in no time.

 

Regards,

Makurth.

 

Awesome, glad to see you got that fixed :)

Share this post


Link to post
Share on other sites

I'm a new player to the game and I love this UI so far.

It's beautiful.

Thank you very much for making it.

Share this post


Link to post
Share on other sites
I'm a new player to the game and I love this UI so far.

It's beautiful.

Thank you very much for making it.

 

You are most welcome. I am glad to hear you like it :)

Share this post


Link to post
Share on other sites

ERR [XUi] Failed initializing window group optionsVideo

 

@Sirillion

 

A new bug has cropped up with the latest update to 7 Days to Die. I am guessing this is because the devs added a new option to the video settings for terrain quality. If you go into video options from the main menu with your modlet installed, all you get is a blank screen.

 

I tried removing the SMXmenu modlet and the error below went away.

 

 

 

 

 

2019-12-04T12:47:43 10.205 ERR [XUi] Failed initializing window group optionsVideo

2019-12-04T12:47:43 10.205 EXC Object reference not set to an instance of an object

NullReferenceException: Object reference not set to an instance of an object

at XUiC_OptionsVideo.Init () [0x001a5] in <090ac70841964a1faa431f23e2b8e0e3>:0

at XUiController.Init () [0x00023] in <090ac70841964a1faa431f23e2b8e0e3>:0

at XUiWindowGroup.Init () [0x00009] in <090ac70841964a1faa431f23e2b8e0e3>:0

at XUi+<LoadAsync>d__199.MoveNext () [0x00276] in <090ac70841964a1faa431f23e2b8e0e3>:0

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

UnityEngine.DebugLogHandler:LogException(Exception, Object)

UnityEngine.Logger:LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

Logger:masterLogException(Exception)

Logger:Exception(Exception)

Log:Exception(Exception)

<LoadAsync>d__199:MoveNext()

UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

 

(Filename: <090ac70841964a1faa431f23e2b8e0e3> Line: 0)

 

2019-12-04T12:47:43 10.404 INF [steamworks.NET] Login ok.

 

 

Share this post


Link to post
Share on other sites
@Sirillion

 

A new bug has cropped up with the latest update to 7 Days to Die. I am guessing this is because the devs added a new option to the video settings for terrain quality. If you go into video options from the main menu with your modlet installed, all you get is a blank screen.

 

I tried removing the SMXmenu modlet and the error below went away.

 

 

 

 

 

2019-12-04T12:47:43 10.205 ERR [XUi] Failed initializing window group optionsVideo

2019-12-04T12:47:43 10.205 EXC Object reference not set to an instance of an object

NullReferenceException: Object reference not set to an instance of an object

at XUiC_OptionsVideo.Init () [0x001a5] in <090ac70841964a1faa431f23e2b8e0e3>:0

at XUiController.Init () [0x00023] in <090ac70841964a1faa431f23e2b8e0e3>:0

at XUiWindowGroup.Init () [0x00009] in <090ac70841964a1faa431f23e2b8e0e3>:0

at XUi+<LoadAsync>d__199.MoveNext () [0x00276] in <090ac70841964a1faa431f23e2b8e0e3>:0

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

UnityEngine.DebugLogHandler:LogException(Exception, Object)

UnityEngine.Logger:LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

Logger:masterLogException(Exception)

Logger:Exception(Exception)

Log:Exception(Exception)

<LoadAsync>d__199:MoveNext()

UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

 

(Filename: <090ac70841964a1faa431f23e2b8e0e3> Line: 0)

 

2019-12-04T12:47:43 10.404 INF [steamworks.NET] Login ok.

 

 

I see, I guess they moved 18.2 to stable. I have just left for work so I cannot give an estimate on when I will have an update for it. But for now, the SMXmenuPatch should be viable to fix this issue as it was made for experimental and should work just as well for stable.

Share this post


Link to post
Share on other sites

i added the smxmenu to our clients along side the smxhud and the hug no longer is working, did i modify it wrong to update it?

Share this post


Link to post
Share on other sites
i added the smxmenu to our clients along side the smxhud and the hug no longer is working, did i modify it wrong to update it?

 

I messed up when packing up the latest SMXhud version and it has an extra folder. So I guess that could be the issue you are facing. Check the folder hierarchy, it should be Mods\SMXhud\ModInfo.xml

 

If any extra folder is present like \Mods\Mods then you need to move SMXhud one level up and it will work.

Share this post


Link to post
Share on other sites
I found time, new version of SMXmenu is up, go to the SMXmenu thread to find it.

 

Thank you for the quick fix.

 

I apologize for posting in the wrong mod thread and not seeing the experimental patch you had posted previously. I mixed up your various mods.

Share this post


Link to post
Share on other sites
Thank you for the quick fix.

 

I apologize for posting in the wrong mod thread and not seeing the experimental patch you had posted previously. I mixed up your various mods.

 

No worries, it is not that big of a deal with most errors as I am able to identify the modlet at fault myself but sometimes bugs can be trickier and in those cases knowing which modlet is the culprit can be very helpful :)

 

When it comes to SMX, as a rule of thumb, everything menu related is SMXmenu, both main and in-game menus and menu windows. Everything you see in the world(when you can move around and execute actions) is SMXhud. Everything you navigate through in the window panels is SMXui.

Share this post


Link to post
Share on other sites

when I use the mod I get the error

NullReferenceException: Object reference not set to an instance of an object

at XUiC_BuffPopoutList.Update (System.Single _dt) [0x002c0] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

at XUiController.Update (System.Single _dt) [0x0004f] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

at XUiController.Update (System.Single _dt) [0x0004f] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

at XUi.OnUpdateDeltaTime (System.Single updateDeltaTime) [0x0014d] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

at XUiUpdater.Update () [0x0003f] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

at GameManager.gmUpdate () [0x0002e] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

at GameManager.Update () [0x00000] in <e37ed47c6bbc4ff88bb27cec364cf24f>:0

 

just to let you know I get an error with the SMX-menu mod to

Edited by dragonslayer770 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...