Jump to content

🧙 Sorcery Staff Weapons Now LIVE! (v0.96) 🔥❄️


Devrix

Recommended Posts

Kinda just here to report an observation/bug and ask a question. When using a custom randomly generated map, things such as the burnt trees and coal ores above ground don’t give fire essence. But I can still get the others. And has there been any update on when we would get the other elements?

Edited by Stra1ghtSlay1n (see edit history)
Link to comment
Share on other sites

A PET WOLF?!!!! WOW MAN!

 

Can i have/summon multiple wolves? Also is there anyway to just have this feature of the mod? i mostly play vanilla but SP is lonely as hell.A few furry friends would be awesome

Link to comment
Share on other sites

You should check the description of the higher perk of the summoning.

I think you could have 2 or 3, and the highest level remove the time limit.

But once you use a vehicle you will outrun them and they despawn.

And maybe you allready notice self their AI isn't that clever. It is mosttimes better to spawn a new one indoors while exploring a new room then to wait for the other to find the way to you.

 

Link to comment
Share on other sites

hello, couple questions,

1 is this mod compatible with 19.4 stable?

2 is this mod compatible with any other mods other than darkness falls?

 

and finally, if i install lets say undead legacy (with the launcher) how do i install this one to use with that other mod?

 

thanks!

Link to comment
Share on other sites

You need to differ between mods and overhauls.

Mod that just add things to the vanilla gameplay shouldn't have problems with Sorcery.

But Overhaul's like DF or UL change alot of the vanilla structures and gameplay, you need a compactiblity patch version of Sorcery.

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi, thank you for developing and maintaining great mods!

 

For new character this mod works charm, but for existing character I cannot gain spirits(mana?) so cannot cast any spells.

Is there any way to fix this?

Link to comment
Share on other sites

  • 3 weeks later...
On 3/30/2021 at 12:26 AM, m09 said:

Hi, thank you for developing and maintaining great mods!

 

For new character this mod works charm, but for existing character I cannot gain spirits(mana?) so cannot cast any spells.

Is there any way to fix this?

No, it does require a new game to work correctly. 

Link to comment
Share on other sites

  • Devrix changed the title to 🧙 Sorcery A19 is now LIVE! (v0.922) 🔥❄️
  • 2 weeks later...
  • 3 weeks later...
46 minutes ago, Razehail said:

Is there an update on when the Ice portion of this mod will be released to the public?

The Ice update releases this Friday 5/28 and includes a Fire overhaul, Class Runes, along with a handful of additional features. 🍻 

Link to comment
Share on other sites

  • Devrix changed the title to 🧙 Sorcery ICE A19 now LIVE! (v0.94) 🔥❄️
Posted (edited)

sorcery-ice-a19-v094.jpg

 

 

SORCERY ICE A19 (v0.94) NOW LIVE!

  • Added: Ice Element
  • Added: Ice Spells
  • Added: Ice Arrow & Bolt
  • Added: Ice Spell Turret
  • Added: Ice Potions
  • Added: Ice Scrolls
  • Added: New Quests
  • Added: New Runes
  • Added: Class Runes
  • Added: Spell Traps
  • Added: Wisp Entities
  • Added: Shatter Feature
  • Added: Health Bar to Fallen
  • Added: Spell Pushback
  • Added: Fire Element Overhauled 
  • Changes & Fixes: Visit the Discord #Changelog

‼️New game is required‼️

 

sorcery-class-rune-alchemist.gif

 

 

 

 

 

 

 

YOU AGREE TO THE FULL TERMS OF USE AND DISCLAIMER HEREIN BY DOWNLOADING AND USING THE SORCERY MOD:

 

DOWNLOAD SORCERY

  1. Download: Sorcery-master.zip (latest version)
  2. Unzip: Sorcery-master.zip
  3. Drag-n-Drop: The two folders (Sorcery + Deep Pockets), found within the unzipped (Sorcery-master\Mods) folder, directly into your Mods folder (\7 Days To Die\Mods). Create the Mods folder here if it doesn't already exist.
  4. Verify Mod Path: (\7 Days To Die\Mods\Sorcery) + (\7 Days To Die\Mods\Deep Pockets)
  5. Deport The Undead back to Hell: You're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

 

MOD LAUNCHER

If you already have the latest version of the Mod Launcher, simply run it and install Sorcery there. Otherwise, follow these steps to get started:

 
  1. Steam Sync: Open Steam, right-click 7 Days to Die, select Properties, select Local Files, select Verify Integrity of Game Files. This will ensure you're using a clean version of the game, which is required for use with the Mod Launcher.
  2. Download Launcher: 7D2D Mod Launcher
  3. Install Launcher: Run the launcher installer SetupInstaller.msi
  4. Run Launcher: Locate and select Sorcery within the mods list.
  5. Install Sorcery: With Sorcery selected, click Install Game Copy.
  6. Delete Mods Folder: You may be prompted to delete a detected Mods Folder; I recommend selecting "Yes". You can install additional Mods with Sorcery later, if desired.
  7. Pre-Sync Mod: Finally, select Pre-Sync Mod, then "Yes" you would like to download it.
  8. AWAKEN ESSENCE: Play Mod and you're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

** Game Updates: You must Uninstall and Reinstall Sorcery through the launcher when new game updates are released. Don't worry, your saves are safe and will be retained. If you experience any errors, repeat step #1.

** Visit @sphereii's 7D2D Mod Launcher Thread for more info regarding it

 

 

 

CREDIT

TFP for creating and improving this ridiculously awesome game, while also providing the ability to making this type of modding available.

 

👑Supporters

Supporters make ongoing development possible! Without your help, it would not be possible to put in the immense amount of time and effort required to design and create the plethora of unique assets that make Sorcery. 

 

 

 

sorcery-discord-logo.png

 

Edited by Devrix
DF Compatibility Patch pending update (see edit history)
  • Like 1
Link to comment
Share on other sites

Posted (edited)

While playing the new Ice Sorcery update, I receive the following error when trying to place the Ice Spellforge:

"IndexOutOfRangeException: Index was outside the bounds of the array."

 

I created the spellforge at the Sorcery Desk. I restarted the game, then attempted to place a Creative version. The same error occurs.

I am playing the mod along with Darkness Falls 3.4 on A19.4. I also have the compatibility patch installed.

 

EDIT: After the above error, the spellforge shows up after a few seconds delay. Hovering over it does present the Use command, but pressing E does nothing. I removed the compatibility patch to see if perhaps that was the issue, but it is still occurring. This was also a new game.

 

EDIT2: I removed the Darkness Falls mod, and now the error no longer occurs, and the ice spellforge appears to work properly.

Edited by Razehail
Additional Info (see edit history)
Link to comment
Share on other sites

14 hours ago, Razehail said:

While playing the new Ice Sorcery update, I receive the following error when trying to place the Ice Spellforge:

"IndexOutOfRangeException: Index was outside the bounds of the array."

 

I created the spellforge at the Sorcery Desk. I restarted the game, then attempted to place a Creative version. The same error occurs.

I am playing the mod along with Darkness Falls 3.4 on A19.4. I also have the compatibility patch installed.

 

EDIT: After the above error, the spellforge shows up after a few seconds delay. Hovering over it does present the Use command, but pressing E does nothing. I removed the compatibility patch to see if perhaps that was the issue, but it is still occurring. This was also a new game.

 

EDIT2: I removed the Darkness Falls mod, and now the error no longer occurs, and the ice spellforge appears to work properly.

An updated Compatibility Patch is being worked on for Darkness Falls + Sorcery v0.94+ today. It'll be posted here and in the Sorcery Discord once it's finished. 🍻

Link to comment
Share on other sites

  • Devrix changed the title to 🧙 Sorcery ICE A19 now LIVE! (v0.94+) 🔥❄️
Posted (edited)

 

 Sorcery-Logo-Menu.png

 

 

DF+SORCERY NEW COMPATIBILITY PATCH

  • Added: Spell Arrows to Taza's Bow
  • Added: Spell Bolts to Titanium Crossbow
  • Added: Spell Turret Crafting Tiers
  • Added: Spellcast Crafting Tiers
  • Added: Sorcerer Armor Crafting Tiers
  • Added: Missing Spellcast Tier perks
  • Added: Rad Remover to Spellcasts, Spell Turrets
  • Added: Rad Remover disables Fallen Heal Ability (self + allies)
  • Added: Blessed Metal to Spellcasts, Spell Turrets
  • Added: Blessed Metal enables Spells to do double damage against Demons, Undead and Fallen
  • Added: Missing Spell FX on DF Entities
  • Fixed: Spellforges can't be placed (conflict with DF mechanics)
  • Fixed: Spellforge UI now looks and functions as intended


PLAY DARKNESS FALLS WITH SORCERY

If you already have the latest version of the Mod Launcher, simply run it and install Sorcery there. Otherwise, follow these steps to get start:

1.) Download Sorcery: http://download.sorcerymod.com (#📋terms-disclaimer | #📌changelog)
2.) Download Compatibility Patch: http://df-download.sorcerymod.com/
3.) Unzip: Sorcery-master.zip AND SorceryCompatibilityDF.zip
4.) Drag-n-Drop: The single folder (Sorcery), found within the unzipped (Sorcery-master\Mods) folder, directly into the Mods folder (\Darkness_Falls_Directory\Mods). Create the Mods folder here if it doesn't already exist.
5.) Drag-n-Drop: The folder (SorceryCompatibilityDF) directly into the Mods folder (\Darkness_Falls_Directory\Mods) of your Darkness Falls root directory
6.) Verify Mod Path: (\Darkness_Falls_Directory\Mods\Sorcery) + (\Darkness_Falls_Directory\Mods\SorceryCompatibilityDF)
7.) Deport The Undead back to Hell: You're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!


 

SORCERY+DF SUPPORT

Do NOT bother Khaine about Sorcery+DF compatibility issues or ask for him to make changes between the two. If you're having a problem, or want to request a feature, there are dedicated channels on the Sorcery Discord. I alone update and ensure compatibility between the two.

 

 

 

 

 

sorcery-discord-logo.png

 

Edited by Devrix (see edit history)
Link to comment
Share on other sites

Support Sorcery

 

 

CLASS SET RUNE UPDATE NOW LIVE! (v0.943 | 6/4)

Added: Spell Knight (Class Runes)
Added: Spell Gunner (Class Runes)
Added: Spell Archer (Class Runes)
Added: Enchanter (Class Runes)
Added: Ritualist (Class Runes)
Added: Scholar (Class Runes)
Added: Silence Rune (stops Fallen + Ally Healing)
Added: New Mastery (Scholar)
Added: Fire Spellcast FX (player arm)
Added: Alchemy Mastery 5/5 now Boosts Ally Potion Potency
Added: Rune Mastery 5/5 now Boosts Ally Rune Effectiveness
Added: Lightning FX+Spells (Shock, Electrocute)
Changed: Rune Mastery now unlocks Runes and Transmutations in this order - 1: Common, 2: Transmutations (convert), 3: Rare (Silver), 4: Legendary (Gold), 5: Transcendent (Orange)
Changed: Class Runes Drop Rate increased even more!
✔️Works with existing saves! No restart needed.✔️

 

 

Support Sorcery

 

 

 

sorcery-discord-logo.png

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hey Devrix, quick modding question, have you had any luck disabling zombie attack with buffs? I have sorcery downloaded and was trying to use the code from your ice freeze spell as an example to try it, but it seems they're ignoring all of the passive effects, and I don't know of a way to dynamically change properties. Thanks for your time.

P.S. Love the mod btw, easily one of the most ambitious ones out there.

Edited by TheWolfssegen (see edit history)
Link to comment
Share on other sites

  • 2 weeks later...
On 6/24/2021 at 4:32 PM, TheWolfssegen said:

Hey Devrix, quick modding question, have you had any luck disabling zombie attack with buffs? I have sorcery downloaded and was trying to use the code from your ice freeze spell as an example to try it, but it seems they're ignoring all of the passive effects, and I don't know of a way to dynamically change properties. Thanks for your time.

P.S. Love the mod btw, easily one of the most ambitious ones out there.

Thanks, glad you're liking Sorcery! 🍻
I've had the best luck disabling movement and attacks of enemies using the following:
 

<effect_group name="FREEZE">
	<passive_effect name="WalkSpeed" operation="perc_set" value="0"/>
	<passive_effect name="RunSpeed" operation="perc_set" value="0"/>
	<passive_effect name="CrouchSpeed" operation="perc_set" value="0"/>
	<passive_effect name="JumpStrength" operation="perc_set" value="0"/>
	<passive_effect name="AttacksPerMinute" operation="perc_set" value="0"/>
	<passive_effect name="RoundsPerMinute" operation="perc_set" value="0"/>
	<passive_effect name="WalkSpeed" operation="base_set" value="0"/>
	<passive_effect name="RunSpeed" operation="base_set" value="0"/>
	<passive_effect name="CrouchSpeed" operation="base_set" value="0"/>
	<passive_effect name="JumpStrength" operation="base_set" value="0"/>
	<passive_effect name="AttacksPerMinute" operation="base_set" value="0"/>
	<passive_effect name="RoundsPerMinute" operation="base_set" value="0"/>
</effect_group>

Beyond that, there's not much else we can do atm to my knowledge.

Link to comment
Share on other sites

7d2d-sorcery-class-runes-supporters.gif

 

 

SORCERY CLASS RUNES (v0.944) NOW LIVE!

  • Added: Spell Knight (Class Runes)
  • Added: Spell Gunner (Class Runes)
  • Added: Spell Archer (Class Runes)
  • Added: Spell Trapper (Class Runes)
  • Added: Enchanter (Class Runes)
  • Added: Ritualist (Class Runes)
  • Added: Scholar (Class Runes)
  • Added: Silence Rune (stops Fallen + Ally Healing)
  • Added: New Mastery (Scholar)
  • Added: Fire Spellcast FX (player arm)
  • Added: Alchemy Mastery 5/5 now Boosts Ally Potion Potency
  • Added: Rune Mastery 5/5 now Boosts Ally Rune Effectiveness
  • Added: Lightning FX+Spells (Shock, Electrocute)
  • Changed: Improved Spell Traps
  • Changed: Rune Mastery now unlocks Runes and Transmutations in this order - 1: Common, 2: Transmutations (convert), 3: Rare (Silver), 4: Legendary (Gold), 5: Transcendent (Orange)
  • Changed: Class Runes Drop Rate increased even more!
  • Changes & Fixes: Visit the Discord #Changelog

New game is NOT required for existing v0.94x games.

 

 

 

YOU AGREE TO THE FULL TERMS OF USE AND DISCLAIMER HEREIN BY DOWNLOADING AND USING THE SORCERY MOD:

 

DOWNLOAD SORCERY

  1. Download: Sorcery-master.zip (latest version)
  2. Unzip: Sorcery-master.zip
  3. Drag-n-Drop: The two folders (Sorcery + Deep Pockets), found within the unzipped (Sorcery-master\Mods) folder, directly into your Mods folder (\7 Days To Die\Mods). Create the Mods folder here if it doesn't already exist.
  4. Verify Mod Path: (\7 Days To Die\Mods\Sorcery) + (\7 Days To Die\Mods\Deep Pockets)
  5. Deport The Undead back to Hell: You're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

 

MOD LAUNCHER

If you already have the latest version of the Mod Launcher, simply run it and install Sorcery there. Otherwise, follow these steps to get started:

 
  1. Steam Sync: Open Steam, right-click 7 Days to Die, select Properties, select Local Files, select Verify Integrity of Game Files. This will ensure you're using a clean version of the game, which is required for use with the Mod Launcher.
  2. Download Launcher: 7D2D Mod Launcher
  3. Install Launcher: Run the launcher installer SetupInstaller.msi
  4. Run Launcher: Locate and select Sorcery within the mods list.
  5. Install Sorcery: With Sorcery selected, click Install Game Copy.
  6. Delete Mods Folder: You may be prompted to delete a detected Mods Folder; I recommend selecting "Yes". You can install additional Mods with Sorcery later, if desired.
  7. Pre-Sync Mod: Finally, select Pre-Sync Mod, then "Yes" you would like to download it.
  8. AWAKEN ESSENCE: Play Mod and you're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

** Game Updates: You must Uninstall and Reinstall Sorcery through the launcher when new game updates are released. Don't worry, your saves are safe and will be retained. If you experience any errors, repeat step #1.

** Visit @sphereii's 7D2D Mod Launcher Thread for more info regarding it

 

 

 

CREDIT

TFP for creating and improving this ridiculously awesome game, while also providing the ability to making this type of modding available.

 

👑Supporters

Supporters make ongoing development possible! Without your help, it would not be possible to put in the immense amount of time and effort required to design and create the plethora of unique assets that make Sorcery. 

 

 

 

sorcery-discord-logo.png

 

Link to comment
Share on other sites

  • Devrix changed the title to 🧙 Sorcery ICE A19 now LIVE! (v0.944) 🔥❄️

Hi, thanks for the mod, even though I have yet to use it!

I am using the 7D2D Mod Launcher. Installed Darkness Falls with that. Then manually copied the Sorcery and Sorcery DF Compatibility folder into the Mods folder. The mod launcher program sees both folders, as modlets, so all seems well there.

I have leveled up past 10, but on purpose I have not activated sorcery IN game, but not using the mod initiator, the sorcery awakening book.

Now to the point of this post.

When I use the R key whilst holding a primitive bow, I only see 4 circles. Each circle is for the arrow type. I see two for sorcery, - spell types fire and ice, the other two are scrap iron and stone.

When I use the R key whilst holding an iron crossbow I see 8 circles, the two from sorcery - fire & ice, the others I presume are vanilla & DF.

Is this expected behaviour ? i.e. is it something about the primitive bow?

Yes I have a multitude of arrow types on my person when performing this test.

Basically at my stage of the game I am prevented from using better than scrap iron arrows.

I thought I would check in here first, as it might be an issue with not activating the sorcery mod yet, which might be an odd case, since I presume most downloaders of this mod would immediately initiate it, rather than not using it until a certain level is reached (bit of rp value and well DF is hard).

 

Talking of hard, and a different issue, what is with these 1000 hit point fallen? chasing me around the map? Even from level 1? They have big ranges spells that really hurt when wearing none sorcery armor. The spot me from long range, where other z'ds do not, they run even during daylight. They per-sue for a long distance. Other z'ds seem to be about 300 hp? These @%$#s seem a bit op. Is there an issue with them turning up in game too soon? ie when the player is low level? or is it that the player is expected to already be a sorcerer and that gives them some protection vs spells? Since as I say I have not activated the mod in game yet I have nothing but guesses to go on.

 

So yeah, once I again, thanks for the mod, I look forward to eventually getting round to using it :)

Link to comment
Share on other sites

  • Devrix changed the title to 🧙 Sorcery Staff Weapons Now LIVE! (v0.96) 🔥❄️

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...