Jump to content

Keyboard Input Lag Issues


bigmanthrust

Recommended Posts

For some reason tonight I began having issues with key input lag. When I tap any of the W A S D keys to move, sometimes I move the normal amount, sometimes I continue to slide.

I have the same issue with the E key when attempting to interact with various objects such as a storage container or workbench. When I tap E, it sometimes reads it as a long press and won't work.

 

I have already uninstalled/reinstalled by following steps from a forum post. I have tried quality settings at Medium, Low and Lowest, no changes. Reflections off, etc.

 

The game worked just fine previously, including yesterday. I have over 250 hours of play time. I only play in single player. I typically play in a random gen world, however the same issue occurs even when I start a new game in Navezgane.

 

I have restarted laptop multiple times. I have not installed any new windows updates or video drivers. Drivers are up to date.

 

I'm not sure that lag is the best way to describe the long key press issues, it almost seems like the keys are sticky. Everything else works like normal.

 

I'm using Windows 10, 16GB memory, 8core i7 processor, solid state hard drive, NVIDIA GeForce GTX 1660ti, on a laptop.

 

I haven't been able to find any other forum posts with the same issue.

 

Let me know if you need any additional information. I'm a noob when it comes to log files or anything like that.

 

Thank you for your time.

Edited by bigmanthrust (see edit history)
Link to comment
Share on other sites

Windowskey+R "%APPDATA%/7DaysToDie/logs"

 

May help with a log file, please put that on pastebin.com. That issue can, but not the only cause, be related to an overloaded CPU, perhaps your laptop is overheating and it's throttling itself to lower the temperature.  But, log file and try what Beelzy said to start.

Edited by Jugginator (see edit history)
Link to comment
Share on other sites

Thank you for your responses. Fortunately I just loaded a game and the issue seems to have resolved itself.. Although I only tried to recreate the issue for a minute, it seems to be fixed.

 

I did already test the "Use native input" yesterday, however it did not make a difference. I forgot to mention that in my original post. The native input box was unchecked prior to the issue and the issue still occurred with the box checked.

 

I'm still not sure what caused the issue. I don't believe it was overheating because like I said I've played many times including just a day prior without any issues. The issue would also occur right away, as soon as it loads. I also had the quality on lowest settings, restarted laptop multiple times, tested it multiple times throughout the night, etc.

 

Yesterday I did see some old posts about possible server lag, however I'm not sure if that's relevant for single player.

 

Thank you again for taking the time to respond with suggestions, I appreciate it.

 

Edit: If you're still interested in seeing a log file I'm happy to provide it, however it looks like there were 8 log files generated last night when I was experiencing the issue, I'm not sure which would be the best to provide.

Edited by bigmanthrust (see edit history)
Link to comment
Share on other sites

My guess is CPU related. If you have junk like antivirus or recording software or something else running in the background that isn't necessary, disable it while gaming. Having an Intel CPU, it's probably safe to say the laptop runs hot and gets thermal throttled a lot while gaming reducing the frequency to probably around 2GHz which isn't much when considering the fact that the game only benefits from 4 core threads.

 

So clean up the junk running in the background and maybe even find a way to cool the laptop more. Not only will it help with input lag but also increase fps in gaming. Maybe consider something like an "Opolar LC06" fan which really works well at cooling the internals and isn't nearly as loud as laptop fans usually get, so long as it fits the laptop. If the laptop has 2 exhaust areas (one for CPU, one for GPU), then a second fan mounted would be necessary for balance, otherwise there'd likely be a fan fight to the death (Opolar fan would pull so much air that it would probably greatly hinder the other exhaust fan).

Edited by Fox (see edit history)
Link to comment
Share on other sites

Yeah, see overheating may not present itself in a warning or hotter than usual temps on the case. The system will force the CPU to run slower to maintain the heat levels, so it'll be the same temps as before but way lower clock speed. Any of the recent log files will help, just want to see a couple of things. In fact, you can simply run task manager while running the game to see the CPU clock speed, like this image.png.d5c20bddde7238b33ff0aa5388c38316.png

 

Open it by searching for it, the start menu, or ctrl + shift + esc

 

Also, what Fox said. Laptops in general overtime will gather dust/whatnot, and Intel CPUS already run hot naturally. Note, you can also use HWINFO64 (free) to see this. Free Download HWiNFO Sofware | Installer & Portable for Windows, DOS, just run it before loading into the game and play for a few minutes and check it. Scroll down to the CPU part where you see temperatures, and they have a nice Throttle detection that will say Yes or No. image.png.821a4aa067b24ec3311ce7d8a09629b1.png

 

 

15 hours ago, bigmanthrust said:

Thank you for your responses. Fortunately I just loaded a game and the issue seems to have resolved itself.. Although I only tried to recreate the issue for a minute, it seems to be fixed.

 

I did already test the "Use native input" yesterday, however it did not make a difference. I forgot to mention that in my original post. The native input box was unchecked prior to the issue and the issue still occurred with the box checked.

 

I'm still not sure what caused the issue. I don't believe it was overheating because like I said I've played many times including just a day prior without any issues. The issue would also occur right away, as soon as it loads. I also had the quality on lowest settings, restarted laptop multiple times, tested it multiple times throughout the night, etc.

 

Yesterday I did see some old posts about possible server lag, however I'm not sure if that's relevant for single player.

 

Thank you again for taking the time to respond with suggestions, I appreciate it.

 

Edit: If you're still interested in seeing a log file I'm happy to provide it, however it looks like there were 8 log files generated last night when I was experiencing the issue, I'm not sure which would be the best to provide.

 

Link to comment
Share on other sites

Thank you again for all of the tips and advice.

 

Here is the pastebin link for one of the log files from when the issue was occurring: https://pastebin.com/hDbFPZcW

I removed the user folder name and player name from the log.

 

I do not have recording software running however I do have Windows security and Google drive running. I never closed them in the past but I will going forward.

 

The laptop is always elevated on a laptop cooling pad, however I did not have the fans running while gaming.

 

I went ahead and played for a few mins with HWiNFO running in background. I did this test with the same background processes running as before (drive, antivirus), with the cooling pad fans off and quality settings on lowest. I'll do another test later with antivirus and drive disabled and with cooling fans running.

 

I'm not sure of the best way to include a screenshot with this message, however it did show thermal throttling under the maximum tab for each core. It also shows core power limit exceeded. The key input lag issues did not occur during this test.

 

Thanks again for your help, let me know if you need any additional info.

Link to comment
Share on other sites

You're welcome thanks for the update. Try running the normal settings with Dynamic Mesh set to Off. Although it shouldn't affect much, you never know and that is a little CPU intensive. You can turn it off in the options menu.

 

You may be able to just paste screenshots into the chat, if not, use something like https://imgbb.com

Edited by Jugginator (see edit history)
Link to comment
Share on other sites

Thank you. I played for another few mins with HWiNFO running, with antivirus disabled, drive closed, cooling pad fans on and dynamic mesh set to No.

 

It showed core power limit exceeded prior to loading into the game. After playing for a bit it shows core thermal throttling occurred on 7 of the 8 cores.

 

So I'm not sure that the throttling can be fixed.. This laptop is less than a year old by the way.

 

Thanks again I appreciate you taking the time to help.

Link to comment
Share on other sites

2 hours ago, bigmanthrust said:

So I'm not sure that the throttling can be fixed.

You may be able to reduce temps by limiting your framerate. I'd try 48 first just as an experiment to see if it actually helps. Then move up to 70 and see how it plays.

image.thumb.png.c765f784621869fc7b60004ab5c69351.png

Link to comment
Share on other sites

2 hours ago, bigmanthrust said:

I'm not sure that the throttling can be fixed.

Some other thoughts on cooling the thing down.

 

1: Maybe you can speed the fans up. There's probably a fan control section in the bios you could check, and

if not, there's a great program called Fan Control that will allow you to speed up your fans.

2: While in your bios see if there's any overclocking that you can reduce.

3: What brand is your laptop? Asus, Acer, HP, Dell etc. all come with quite a lot of bloatware running in the

background that will increase temperatures. Get rid of it all.

4: Get a blow through laptop cooler, similar to this. You'll need to find one that fits your particular laptop,

but these work great for reducing laptop temps by actually forcing air through the machine.

Link to comment
Share on other sites

FYI, cooling pads do as much good in cooling as setting the laptop down on a normal desk. Blowing air at the underside of the laptop doesn't do anything to increase the airflow inside the laptop nor does it actually cool the outside of the laptop which is meaningless anyway even if it did. This is a proven fact tested by multiple tech youtubers (even I myself used to have one back in the dual core days).

 

Depending on the kind of vents you have on your laptop, the Opolar might be your best bet at lowering the temps by more than 10 degrees Celcius even on auto fan setting.

Edited by Fox (see edit history)
Link to comment
Share on other sites

Thank you.

 

I'm not seeing any fan settings or overclock settings in the BIOS. I do still have "Armoury Crate" that was pre-installed which gives me 4 options: Windows, Silent, Performance and Turbo. These options seem to not only adjust fan speed but I believe also adjusts CPU clock speed. I typically leave it on Performance when plugged in. I think the fans may run a bit faster on Turbo, however I think the processor also works harder. I believe silent lowers CPU speed but also lowers fan speed and doesn't help with temperatures, however it's been a while since I've messed with it.

 

Thank you, I set the frame rate cap at 48 and I'll test it soon.

 

It is an Asus laptop. aside from Armoury Crate and MyAsus, I already removed all bloatware that I could. Only necessary programs on startup. Armoury Crate and MyAsus do not load with startup.

 

Thank you for the fan suggestions, I will consider purchasing one.

 

There are openings on the bottom of my laptop and I believe exhaust vents on the rear and right side of the laptop. Definitely exhaust on the right side, but I'll have to double check the rear vents again when the fans crank up.

 

I'm aware that the cooling pads don't do much, that's why I typically don't use the fans. It's primarily to just have more airflow beneath it as well as just a stand that makes the screen closer to eye level.

 

Even with the thermal throttling/power limit exceeded, the original issue with key lag still hasn't occurred since the day that I posted about it. So the throttling may not even be what caused the issue. Any idea if the core power limit exceeded could potentially cause any damage?

 

Thanks again!

 

I just tested with the 48 frames cap and it ran slightly cooler (91° max for the CPU package, which went as high as 98° on an earlier test) and the fans were silent the majority of the time. Still shows power limit exceeded on all cores and thermal throttling occurred on just 4 cores this test (previously was 7 - 8 cores). Thank you.

 

Oh and the air vents on the rear are also blowing hot air like the side vent.

Edited by bigmanthrust (see edit history)
Link to comment
Share on other sites

48 minutes ago, bigmanthrust said:

There are openings on the bottom of my laptop and I believe exhaust vents on the rear and right side of the laptop. Definitely exhaust on the right side, but I'll have to double check the rear vents again when the fans crank up.

 

Just a quick question to get rid of the obvious, but

 

Are you playing with your laptop sitting on a hard surface and not having it lay on a pillow in your lap?

 

I knew someone that complained their laptop was overheating all the time until I pointed out to them they were blocking the air vents.

Link to comment
Share on other sites

1 hour ago, bigmanthrust said:

It is an Asus laptop. aside from Armoury Crate and MyAsus, I already removed all bloatware that I could. Only necessary programs on startup. Armoury Crate and MyAsus do not load with startup.

 

Make sure nothing Asus is running. Their software has caused so many issues for gamers. This includes GameFirstVI and any other "boosters". I've noticed their services can sometimes run in the background even if you removed them from startup. Have to go into services.msc for that one (right click them, properties, change the startup type to disabled; in theory, manual should be "user has to start this for any programs to be able to use it", but you never know).

Link to comment
Share on other sites

That's correct. The laptop is always on a cooling pad on top of a hard surface.

 

Hmm you're right, there are 9 Asus services running in background. I'm not sure if I should disable all of them right now, don't want to cause any issues.. I'll probably Google each one before disabling. But there is Asus app service, Asus link near, Asus link remote, Asus optimization, Asus software manager, Asus switch, Asus system analysis, Asus system diagnosis, AsusCertService. Startup type for all of them is Automatic.

 

I want to keep Armoury Crate so I don't want to disable anything that will conflict with that.

 

Thank you all again for all of your help. I set frame rate cap at 55 and played for a while with no issues. Laptop is running cooler now and fans aren't working as hard.

Link to comment
Share on other sites

Armory Crate is fine... that's just the RGB stuff, the rest I have no idea what they are as I uninstalled them once I figured out they were bloatware nonsense that I didn't need. Without Armory Crate, you'll probably either have the RGB off completely or end up with rainbow puke.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...