Jump to content

GameServer.LogOn timed out issues - no player can connect my dedicated server.


cistehovado
 Share

Recommended Posts

 
I started dedicated server, forwarded ports, (26900-26910) but server still goes to time out. (see last row from log). It is pretty annoying, tried clean install of server even with default configuration (nothing changed) but still - GameServer.LogOn timed out, playet who want to join ends with message: waiting for Steam verification.
Any help please?

Complete log from console, I noticed weird path ...Data\/Navezgane... but it works, data are in there.
2021-09-22T13:04:24 1.239 INF Awake done in 1200 ms
2021-09-22T13:04:26 3.026 INF [GSM] GameSparks Connected
2021-09-22T13:04:27 3.927 INF NET: Starting server protocols
2021-09-22T13:04:27 3.934 INF NET: LiteNetLib server started
2021-09-22T13:04:27 3.934 INF [Steamworks.NET] NET: Server started
2021-09-22T13:04:27 3.935 INF Started thread SteamNetworkingServer
2021-09-22T13:04:27 3.936 INF StartGame
2021-09-22T13:04:27 3.936 INF NetPackageManager Init
2021-09-22T13:04:27 4.184 INF Persistent GamePrefs saved
2021-09-22T13:04:27 4.282 INF StartAsServer
2021-09-22T13:04:27 4.332 INF [GSM] Skipping me
2021-09-22T13:04:31 8.242 INF Block IDs with mapping
2021-09-22T13:04:31 8.242 INF BlockIDs from Mapping
2021-09-22T13:04:34 11.076 INF Item IDs with mapping
2021-09-22T13:04:34 11.077 INF ItemIDs from Mapping
HDR Render Texture not supported, disabling HDR on reflection probe.
2021-09-22T13:04:50 26.972 INF createWorld: Navezgane, Armageddon, GameModeSurvival
2021-09-22T13:04:50 26.973 INF Occlusion: Disabled
2021-09-22T13:04:50 27.020 INF Started thread ChunkRegeneration
2021-09-22T13:04:50 27.021 INF Started thread ChunkCalc
2021-09-22T13:04:50 27.124 INF World.Load: Navezgane
2021-09-22T13:04:50 27.135 INF BloodMoon SetDay: day 8, last day 0, freq 8, range 2
2021-09-22T13:04:50 27.136 INF BloodMoon SetDay: day 9, last day 0, freq 8, range 2
2021-09-22T13:04:53 29.659 INF Started thread GenerateChunks
2021-09-22T13:04:54 30.667 INF Calculating world hashes took 910 ms (world size 177 MiB)
2021-09-22T13:04:54 30.828 INF Loading dtm raw file took 1122ms
2021-09-22T13:04:54 30.885 INF Biomes image size w= 3072, h = 3072
2021-09-22T13:04:54 31.093 INF Loading and creating biomes took 264ms
2021-09-22T13:04:55 31.782 INF Loading and creating shader control textures took 688ms
2021-09-22T13:04:55 32.436 INF Loading and parsing of generator took 654ms
2021-09-22T13:04:55 32.493 INF Started thread SaveChunks E:\Servers\7dtd\ServerGameData\GameData\/Navezgane/Armageddon\Region
2021-09-22T13:04:57 33.849 INF [DECO] read 77132/
2021-09-22T13:04:57 33.979 INF AstarManager Init
2021-09-22T13:04:58 34.694 INF Weather Packages Created FROM BIOMES
2021-09-22T13:04:58 34.694 INF createWorld() done
2021-09-22T13:04:58 34.696 INF Loading players.xml
2021-09-22T13:04:58 34.784 INF Loaded player
2021-09-22T13:04:58 34.835 INF VehicleManager E:\Servers\7dtd\ServerGameData\GameData\/Navezgane/Armageddon/vehicles.dat, loaded 0
2021-09-22T13:04:58 34.943 INF Setting for 'DropOnDeath' does not match the default (server will go to the modded category): current = 2, default = 1
2021-09-22T13:04:58 34.943 INF Setting for 'BloodMoonEnemyCount' does not match the default (server will go to the modded category): current = 10, default = 8
2021-09-22T13:04:58 34.943 INF Setting for 'LootRespawnDays' does not match the default (server will go to the modded category): current = 23, default = 30
2021-09-22T13:04:58 34.943 INF Setting for 'LootAbundance' does not match the default (server will go to the modded category): current = 115, default = 100
2021-09-22T13:04:58 34.943 INF Setting for 'AirDropFrequency' does not match the default (server will go to the modded category): current = 62, default = 72
2021-09-22T13:04:58 35.236 INF [EAC] Starting EAC server
2021-09-22T13:04:58 35.241 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:628][Windows][EAC Server] [Info][SetLogCallback] Procedure: 0000025D43DE1930 LogLevel: Verb.
2021-09-22T13:04:58 35.242 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:628][Windows][EAC Server] [Info][Initialize] ServerName: '7 Days To Die' RegisterTimeout: 60.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 1h EventName: 'game_round_start' Parameters: { map_name (string) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 2h EventName: 'game_round_end' Parameters: { winning_team_id (uint32) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 3h EventName: 'player_spawn' Parameters: { player (client), team_id (uint32), character_id (uint32) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 4h EventName: 'player_despawn' Parameters: { player (client), player_death (uint32), player_killer (client) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 5h EventName: 'player_revive' Parameters: { player_revived (client), player_reviving (client) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 6h EventName: 'player_tick' Parameters: { player (client), player_position (vec3f), player_viewrotation (quat), player_health (uint32), player_tickflags (uint32) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 7h EventName: 'player_useweapon' Parameters: { player (client), player_position (vec3f), player_viewrotation (quat), player_fov (uint32), weapon_id (uint32), melee_attack (uint32) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 8h EventName: 'player_takedamage' Parameters: { player_victim (client), player_victim_position (vec3f), player_victim_viewrotation (quat), player_attacker (client), player_attacker_position (vec3f), player_attacker_viewrotation (quat), player_attacker_fov (uint32), weapon_id (uint32), hitbone_id (uint32), damage_taken (uint32), damage_flags (uint32) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: 9h EventName: 'player_downed' Parameters: { player_victim (client), player_attacker (client) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: Ah EventName: 'player_death' Parameters: { victim (client), victim_shots_fired (uint64), victim_shots_landed (uint64), attacker (client), attacker_shots_fired (uint64), attacker_shots_landed (uint64) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: Bh EventName: 'game_round_start_v2' Parameters: { map_name (string), mode_name (string), round_time_seconds (uint32), start_frame_number (uint64), start_delta_seconds (uint32) }.
2021-09-22T13:04:58 35.245 INF [EAC] Log: [EAC Server]  [Info] [13:04:58:632][Windows][EAC Server] [Info][Cerberus] [RegisterEvent] EventID: Ch EventName: 'game_round_start_v3' Parameters: { gamesessionid (string), map_name (string), mode_name (string), round_time_seconds (uint32), start_frame_number (uint64), start_delta_seconds (uint32) }.
2021-09-22T13:04:58 35.398 INF Loading permissions file at 'E:\Servers\7dtd\ServerGameData\GameData\/webpermissions.xml'
2021-09-22T13:04:58 35.399 INF Loading permissions file done.
2021-09-22T13:04:58 35.417 INF Started thread SSE-Processing_/sse/
2021-09-22T13:04:58 35.422 INF Started Webserver on 8082
2021-09-22T13:05:06 42.672 INF Web:IconHandler: Icons loaded - 7249 ms
2021-09-22T13:05:06 42.673 INF (BCM) Loading world config.
2021-09-22T13:05:06 42.676 INF (BCM) It's Alive!!! (AIEvents Activated)
2021-09-22T13:05:06 42.676 INF Started thread NeuronInvoker
2021-09-22T13:05:06 42.685 INF StartGame done
2021-09-22T13:05:06 42.714 INF [Steamworks.NET] GameServer.Init successful
2021-09-22T13:05:06 42.716 INF [Steamworks.NET] Making server public
2021-09-22T13:05:35 72.448 ERR [Steamworks.NET] GameServer.LogOn timed out

 

Link to comment
Share on other sites

Adding log what is happening upon player joins:

 

2021-09-22T13:16:20 717.155 INF [Steamworks.NET] Authenticating player: MastaOfDisasta SteamId: * * * TicketLen: 1024 Result: k_EBeginAuthSessionResultOK
2021-09-22T13:16:35 732.501 INF Time: 12.07m FPS: 20.00 Heap: 1112.8MB Max: 1112.8MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2114.3MB
2021-09-22T13:17:05 762.506 INF Time: 12.57m FPS: 20.00 Heap: 1115.6MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2114.3MB
2021-09-22T13:17:35 792.514 INF Time: 13.07m FPS: 20.00 Heap: 1096.6MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2114.2MB
2021-09-22T13:18:05 822.517 INF Time: 13.57m FPS: 20.00 Heap: 1098.2MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2114.3MB
2021-09-22T13:18:35 852.523 INF Time: 14.07m FPS: 19.99 Heap: 1100.0MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2114.3MB
2021-09-22T13:19:05 882.529 INF Time: 14.57m FPS: 20.00 Heap: 1102.5MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2114.3MB
2021-09-22T13:19:35 912.542 INF Time: 15.07m FPS: 20.00 Heap: 1096.9MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2091.3MB
2021-09-22T13:20:05 942.547 INF Time: 15.57m FPS: 20.00 Heap: 1098.5MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2091.3MB
2021-09-22T13:20:35 972.550 INF Time: 16.07m FPS: 20.00 Heap: 1100.2MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2091.3MB
2021-09-22T13:21:05 1002.555 INF Time: 16.57m FPS: 19.99 Heap: 1102.9MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2091.3MB
2021-09-22T13:21:35 1032.567 INF Time: 17.07m FPS: 20.00 Heap: 1110.4MB Max: 1115.6MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2089.6MB

 

Link to comment
Share on other sites

Still same issue,

reinstalled windows from scratch, installed dedicated server only,

Forwarded ports - I tested ports, I have forwarded correct ports but the port tester shows them closed except the ports 8080 (control panel), 8081 (telnet) and  8082 which is the map port (have alloc installed), I can reach any of these services through internet.

I disabled firewall, port 27015 still shown closed, my port forwarding table follows(yep server is on 192.168.1.50)

Service Name External Ports Internal Ports Internal IP address
           
2 7DaysToDie 27000-27030 27000-27030 192.168.1.50
3 7DtD Config port 8080-8088 8080-8088 192.168.1.50

 

My network config part:

 

<!-- Networking -->
	<property name="ServerPort"						value="27015"/>				<!-- Port you want the server to listen on. Keep it in the ranges 26900 to 26905 or 27015 to 27020 if you want PCs on the same LAN to find it as a LAN server. -->
	<property name="ServerVisibility"				value="2"/>					<!-- Visibility of this server: 2 = public, 1 = only shown to friends, 0 = not listed. As you are never friend of a dedicated server setting this to "1" will only work when the first player connects manually by IP. -->
	<property name="ServerDisabledNetworkProtocols"	value="SteamNetworking"/>	<!-- Networking protocols that should not be used. Separated by comma. Possible values: LiteNetLib, SteamNetworking. Dedicated servers should disable SteamNetworking if there is no NAT router in between your users and the server or when port-forwarding is set up correctly -->
	<property name="ServerMaxWorldTransferSpeedKiBs" value="1024"/>				<!-- Maximum (!) speed in kiB/s the world is transferred at to a client on first connect if it does not have the world yet. Maximum is about 1300 kiB/s, even if you set a higher value. -->

	<!-- Slots -->
	<property name="ServerMaxPlayerCount"			value="16"/>					<!-- Maximum Concurrent Players -->
	<property name="ServerReservedSlots"			value="0"/>					<!-- Out of the MaxPlayerCount this many slots can only be used by players with a specific permission level -->
	<property name="ServerReservedSlotsPermission"	value="100"/>				<!-- Required permission level to use reserved slots above -->
	<property name="ServerAdminSlots"				value="0"/>					<!-- This many admins can still join even if the server has reached MaxPlayerCount -->
	<property name="ServerAdminSlotsPermission"		value="0"/>

 

Link to comment
Share on other sites

19 minutes ago, cistehovado said:
<property name="ServerPort"						value="27015"/>

Your base port is in a range that I hear Steam likes to use. Try something in the 26000 range for your base port to avoid that possible conflict.

Also, your port forwarding chart says 2 external ports for the game. It should be 4. Your base port + 3. For example if you chose 26500 as a base port you should have 26500 through 26503 open in both your firewall and router.

Also "service" on your chart is blank. It should be showing UDP and or TCP.

 

Link to comment
Share on other sites

5 minutes ago, Beelzybub said:

Your base port is in a range that I hear Steam likes to use. Try something in the 26000 range for your base port to avoid that possible conflict.

Also, your port forwarding chart says 2 external ports for the game. It should be 4. Your base port + 3. For example if you chose 26500 as a base port you should have 26500 through 26503 open in both your firewall and router.

Also "service" on your chart is blank. It should be showing UDP and or TCP.

 

 

I dont know what do you mean, I have 30 free ports from 27000 to 27030, the protocols are TCP and UDP (they are not listed here).  Top table row is shifted 2 columns sorry for that. Let me set it up to 26900-26930 and paste the result.

The same result as before, - no firewall enabled:

ports 8080, 8081, 8082 are open and works Ports 26900 closed

 

	<!-- Networking -->
	<property name="ServerPort"						value="26900"/>				<!-- Port you want the server to listen on. Keep it in the ranges 26900 to 26905 or 27015 to 27020 if you want PCs on the same LAN to find it as a LAN server. -->
	<property name="ServerVisibility"				value="2"/>					<!-- Visibility of this server: 2 = public, 1 = only shown to friends, 0 = not listed. As you are never friend of a dedicated server setting this to "1" will only work when the first player connects manually by IP. -->
	<property name="ServerDisabledNetworkProtocols"	value="SteamNetworking"/>	<!-- Networking protocols that should not be used. Separated by comma. Possible values: LiteNetLib, SteamNetworking. Dedicated servers should disable SteamNetworking if there is no NAT router in between your users and the server or when port-forwarding is set up correctly -->
	<property name="ServerMaxWorldTransferSpeedKiBs" value="1024"/>				<!-- Maximum (!) speed in kiB/s the world is transferred at to a client on first connect if it does not have the world yet. Maximum is about 1300 kiB/s, even if you set a higher value. -->
Service Name:
7DaysToDie
Protocol:TCP/UDP
External port range:26900-26930
Please specify ports and port ranges split by commas, example: 30, 50 - 60, 65500 - 65510

Internal port range: 26900-26930
Please specify ports and port ranges split by commas, example: 30, 50 - 60, 65500 - 65510
Internal IP address: 192.168.1.50

 

Link to comment
Share on other sites

4 hours ago, Beelzybub said:

This should be open to tcp/udp. Are you saying you set your router and firewall to open it, and it is still not open?

 

I am saying I have opened it through the router, and I disabled firewall completely. Strange thing is that ports 8080-8082 are working.

I suspect there must be something wrong with Server application. 

Link to comment
Share on other sites

I made some tests - I did not change port forwarding (stays at 26900 - 26930) and I installed filezilla server, I set filezilla at port 26911, that port is successfully opened when testing from internet. Then I set filezilla server to use all the ports starting from 26900 to 26930 and all of them were working from internet. Port check passed.

So I am still pointing at that there may be issues with server app. 

50 minutes ago, Beelzybub said:

Try enableing Steamnetworking. If that works, then your ports are not opened correctly. What's the server ip? I'll try to connect.

 

Private message sent.

I removed Steamnetworking (so it should be enabled), but still I got the same error:

 

2021-09-22T21:45:12 39.744 INF [Steamworks.NET] GameServer.Init successful
2021-09-22T21:45:12 39.746 INF [Steamworks.NET] Making server public
2021-09-22T21:45:34 61.457 INF [DECO] written 77132, in 10ms
2021-09-22T21:45:34 61.460 INF [DECO] write thread 2ms
2021-09-22T21:45:42 69.676 ERR [Steamworks.NET] GameServer.LogOn timed out

 

Link to comment
Share on other sites

Update, I was googling to find out how can I find opened ports (listening) at local machine, as I want to see opened ports (for 7days to die),

command for windows is netstat -ab

I am attaching a filtered output, I can currently see that ports 8080 and 8081 are opened and listening for incoming connections (and they works through port forwarding, 8082 is not listed as I removed every mod I had). There is no listening port at 26902 which is set in config, and it should be.

<property name="ServerPort"  value="26902"/>

The ports 25282 and 25281 are unknown for me, but I believe the server app wants to connect somewhere. 

 

C:\Windows\system32>netstat -ab

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:8080           DESKTOP-B7DJSDP:0      LISTENING
 [7DaysToDieServer.exe]
  TCP    0.0.0.0:8081           DESKTOP-B7DJSDP:0      LISTENING
 [7DaysToDieServer.exe]
  TCP    127.0.0.1:25281        DESKTOP-B7DJSDP:25282  ESTABLISHED
 [7DaysToDieServer.exe]
  TCP    127.0.0.1:25282        DESKTOP-B7DJSDP:25281  ESTABLISHED
 [7DaysToDieServer.exe]

 

Link to comment
Share on other sites

I got two errors trying to connect to that server.

 

INF NET: LiteNetLib trying to connect to: (ip address:port)
[NM] DataReceived: bad! (x11)

LiteNetLib: Connection failed: ConnectionFailed

 

and then

 

WRN [Steamworks.NET] NET: Requesting rules from TCP failed due to connection problems

(No connection could be made because the target machine actively refused it.

Link to comment
Share on other sites

Couple of things (but take these with a grain of salt, I am a Noob when it comes to setting up servers)

 

ST has a great pinned post on sever setups, especially ports

 

 

Also, based on your error messages, have you tried reinstalling Steam as you may have some bad files there.  Recommended action on the internet is to go into your Steam folder and delete everything but the steamapps folder (your installed games) and steam.exe.  Then launch steam.exe and allow it to redownload all the files it needs.

Link to comment
Share on other sites

7 minutes ago, BFT2020 said:

Couple of things (but take these with a grain of salt, I am a Noob when it comes to setting up servers)

 

ST has a great pinned post on sever setups, especially ports

 

 

Also, based on your error messages, have you tried reinstalling Steam as you may have some bad files there.  Recommended action on the internet is to go into your Steam folder and delete everything but the steamapps folder (your installed games) and steam.exe.  Then launch steam.exe and allow it to redownload all the files it needs.

Thanks for info.

I am using server on separate machine, there is no Steam client, only Steamcmd and the server files. (and of course W10 OS). I reloaded server software multiple times (and checked). Everything looks ok. I also tested if ports are forwarded with another software, they are. I just dont get it why it does not work.

Link to comment
Share on other sites

I did a last try:

- removed every 3rd party software in windows 10 (completely clean)

- disabled all windows protection (antivirus and firewall, application check etc)

- downloaded dedicated server from the scratch, (did not change anything in config - leaving default build)

- connected the machine directly to internet (bypassing router), machine got internet IP

- I tested the connectivity (using browser and ping)

- started the dedicated server, last 5 logs lines here:

2021-09-24T23:03:13 34.532 INF [Steamworks.NET] GameServer.Init successful
2021-09-24T23:03:13 34.534 INF [Steamworks.NET] Making server public
2021-09-24T23:03:40 61.245 INF [DECO] written 77258, in 11ms
2021-09-24T23:03:40 61.247 INF [DECO] write thread 2ms
2021-09-24T23:03:43 64.556 ERR [Steamworks.NET] GameServer.LogOn timed out

 

And server is still unreachable (Waiting for steam authentication)

I don't know really what to do more, this is like madness.

 

Server specs:

Asrock Deskmini H470, Intel i7 11700, 16GB DDR4 SO-DIM (kingston), nvme hdd Blue WD 240GB

 

Link to comment
Share on other sites

7 hours ago, cistehovado said:

I did a last try:

- removed every 3rd party software in windows 10 (completely clean)

- disabled all windows protection (antivirus and firewall, application check etc)

- downloaded dedicated server from the scratch, (did not change anything in config - leaving default build)

- connected the machine directly to internet (bypassing router), machine got internet IP

- I tested the connectivity (using browser and ping)

- started the dedicated server, last 5 logs lines here:

2021-09-24T23:03:13 34.532 INF [Steamworks.NET] GameServer.Init successful
2021-09-24T23:03:13 34.534 INF [Steamworks.NET] Making server public
2021-09-24T23:03:40 61.245 INF [DECO] written 77258, in 11ms
2021-09-24T23:03:40 61.247 INF [DECO] write thread 2ms
2021-09-24T23:03:43 64.556 ERR [Steamworks.NET] GameServer.LogOn timed out

 

And server is still unreachable (Waiting for steam authentication)

I don't know really what to do more, this is like madness.

 

Server specs:

Asrock Deskmini H470, Intel i7 11700, 16GB DDR4 SO-DIM (kingston), nvme hdd Blue WD 240GB

 

 

The message about steam authentication seems to point more into the direction of steam not being able to connect, i.e. it may not be about port 26900 but ports 26901-26905.

 

But you still didn't post a complete log (actually a log from server and client would be needed in such a case), foiling the best chance for someone here to get the right idea and largely wasting our time searching half-blind in the darkness. I'm out.

 

 

 

Edited by meganoth (see edit history)
Link to comment
Share on other sites

*SOLVED* 

mostly thanks to Beelzybub 

 

Issue was dedicated server was downloaded through SteamCMD and executed via batch file. Together with Beelzy, I tried to create server through client on another machine and it worked. So network outside was ok. I tried several extreme things including changing router. Then I was thinking what was different between my server and my gaming pc. - A steam client.

So I created new account on Steam, installed it on Server, downloaded the 7DtD dedicated server via Steam client, started it - and it finally worked!

I tried to disable client - Server was unreachable again.

 

So solution was to install Steam client and keep it running then the server works.

 

21 minutes ago, meganoth said:

 

The message about steam authentication seems to point more into the direction of steam not being able to connect, i.e. it may not be about port 26900 but ports 26901-26905.

 

But you still didn't post a complete log (actually a log from server and client would be needed in such a case), foiling the best chance for someone here to get the right idea and largely wasting our time searching half-blind in the darkness. I'm out.

 

 

 

I also pasted complete log as you requested, at Thursday at 09:31 PM (edited), the rest of logs were no different.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...