Jump to content

Blocks that do not exist


Recommended Posts

Well, I have this problem, since I don't remember at least alpha 18. It is the same even in a19.

As you can see in the images below, some blocks I see are not there. Typically windows, holes I create with axe in the wall. Small objects (vases and pillars) appear with small boxes embedded in them.  All of these blocks have the same texture, are completely clip-less and once I go through them, they are not visible from the other side.

Relogging worked 100% in a18 and works sometimes in a19. I guess it works in large chunks of the world (not the chunks in the normal sense of the word).

Example of small boxes:

This window is actually empty:


There is a hole where you see the blocks in the middle. These do not have the usual marble-like texture, which is quite rare:


There is a regular hole in this door:


Sometimes you can see two textures clipping over each other. When you change angle of view, the textures change as well:


This is happening outside. As it usually occurs inside, it's again quite rare:


Clipping texture plus the window between the two red supports is broken and you can go through:


Standing inside this glitch looks like this:



Has anyone seen anything like this? Can I do anything to prevent it? I've had this happen to me in single and in multiplayer game and some of my friends rarely encounter this as well (like once in 10 hours of play, my rate is much higher).

Link to comment
Share on other sites

The same thing happens to me every time I play; it ranges from the trader's door to vast expanses of marble-tiled blocks that spread across large segments of various POIs like a weird flood of green marble tile.


The barn at the farm is COMPLETELY flooded with these intangible visible blocks.


The worst part is how it makes it impossible to see zombies sneaking up on you.

Link to comment
Share on other sites

So it seems I'm not alone and everyone sees the same marble texture. I wonder what can we make of it. It almost seems to me as if it had something to do with the far-distance models. It appears in places that used to be a building but were long ago eaten by zombies or dynamite.

Link to comment
Share on other sites

Y'all, when you get this error, if you exit the game (into menu) and reenter (via join or continue), does it ever persist?

In A18 I pretty much always entered our multi game, immediately left and entered again and this was fixed. In A19 I have this problem less often but it sometimes comes back. Insteresting thing is, it never happens in woods or plains or even mountains. It is always around "man-made" structrures. But I have yet to see it on a house built from scratch. I suspect distant terrain more and more. What if - I am at a place someone is seeing from afar and those blocks are dummies that player sees as a far-model? It does not solve the mystery of this happening in single-player game, though.

Link to comment
Share on other sites

There is another topic with the same error (we posted hours apart - what a coincidence!) and one user cleverly pointed out that what we are seeing is crude model of far-distance version of the building. It has nothing to do with either RAM or graphic card brand (at least it seems to at this point) but for some reason the far-model is not removed when the real model is loaded when you come closer.

I suspected seeing other person's far-model but I have seen this in single player AND in multi, I usually play lone-wolf type, far away from others even further than far-models are rendered. It has to be a bug in the renderer of the game, I suppose.

Link to comment
Share on other sites

I've had this issue since a week ago.  Never had it before.  It definitely seems to be an issue of swapping between the distant textures and the close up textures.  I was told that the View Distance setting should change when the swap between textures occurs, but moving it from low to high does not seem to have any noticeable differences (I typically just leave it on Medium).


As for playing when you have the issue, the only thing I've found that works is the console command "pois" which turns off the distance texture rendering.  This means you don't see distant buildings anymore, but it also makes the POI's around you have the normal, close textures since they don't have to swap from distant textures to close ones.


This is a pretty crappy fix, honestly.  You can still see distant towns by seeing the roads/city layouts, but for wilderness POI's, they're virtually invisible until you get relatively close.


Typing in "pois" again after fixing the close textures seems to bork everything even further, so once the issue starts, you either use "pois" to get close textures or have to restart the game to load the textures.


I would love to have a console command that just forces a re-load of the close textures in your area/chunk.  I think that would solve this issue until the root cause can be ferreted out.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...