Jump to content
Sign in to follow this  
XPho3nixRisingX

FPS Issues

Recommended Posts

Having trouble running the game at more than 30FPS on a decent rig at medium/high settings...

 

Specs are as follows:

OS: Windows 7 Ultimate X64

CPU: Intel Core I7-4770K @ 4.2Ghz

GPU: MSI GTX 960 4GB

RAM: 28GB DDR3 1600

SSD: Samsung 840 EVO

 

I have Norton installed, but have added exceptions as advised.

 

Am I missing something?

Share this post


Link to post
Share on other sites

30 FPS is pretty weak for that setup, so you've definitely got something going on.

 

If you could read the Sticky thread that tells you to read it before posting, I'd love to see the following....

1. A game client log.

2. A screenshot of your video settings.

3. A link to a published Speccy log.

 

For example, I'm running on the following with FPS very stable over 80.

http://speccy.piriform.com/results/HnyWBsKUKInh3xCvpwGgjCJ

 

Now, as you can see, I've got it OC'ed quite a bit. (Will be testing with more in a few days.)

 

Here's my specs at a glance.

 

i7-3930k overclocked at 4.25GHz

32GB DDR3 RAM at @2000Mhz

GTX1060 6GB SSC that's overclocked a tad past what it shipped with.

OS and game on separate SSD's, save data on ultra-fast SSHD's in RAID 0

 

Here's a screenshot of my current in-game settings.

d1e00fcc68c9f65dff8461d5bcecb184.png

 

Share this post


Link to post
Share on other sites
u sure you have 28 GB Ram? that makes no sense[/url]

 

3 x 8GB sticks and 1 x 4GB stick?

 

 

Share this post


Link to post
Share on other sites

 

3 x 8GB sticks and 1 x 4GB stick?

 

 

Will kill dual-channel and halve your RAM speeds, but possible.

Share this post


Link to post
Share on other sites

i said it makes no sense, not that it is impossible.

you can run dualchannel with uneven dimms, it is just dumb.

8+4 on one channel would mean that you effectively run 4+4 in dual channel speed, and the remaining 4gb of the 8gb stick are only singlechannel, this can lead to weird performance issues because you have _some_ data which you can address with 100% performance and some with 50%. very unpredictable.

Share this post


Link to post
Share on other sites

If I read the log correctly you set textures to full, which I think is problematic with only 4G VRAM. And yes. like the others said, fix your motherboard RAM issue, sticks in the same channel have to be equal size.

 

Share this post


Link to post
Share on other sites

Just get rid of 2 sticks of RAM and have a look if something changed. This game doesn't need that much RAM anyway. I'm running full textures with 16Gbs RAM and a 4Gb Radeon 555X. Guess GTX 960 is way more productive than my 555X.

Share this post


Link to post
Share on other sites

@xpho3nixetc Just lower your graphics settings. Those settings are trying to do more than your card can handle.

 

Try Sylens settings or try these and report back. Also wouldn't hurt to fix your memory setup as everyone has suggested.

4 matching dimms would be best. The 2x8 GB would work for this game as well. Make sure they're in the correct slots.

 

1871514881_7D2DSettings.thumb.jpg.0551568000b8fb32a6d5e647e4fb313e.jpg

 

 

 

 

 

 

 

3 x 8GB sticks and 1 x 4GB stick?

 

 

Nailed it.

Share this post


Link to post
Share on other sites

Ok, for the Speccy.

 

1. Turn off BlackGlassEnhanced. Your transparent theme is just wasting resources. Just it looks pretty, but that isn't something we care about on an aging system.

 

2. Remove DexPot. Win10 already has this feature enabled by default. Just another worthless program wasting resources. (You should take the free upgrade to W10 BTW.)

 

3. You have Norton. I sincerely hope you didn't pay for it. Make absolutely certain that the client is fully excluded. Personally you probably want to exclude all of Steam. Instructions are in the Sticky FAQ. Next time you go to renew, get BitDefender. Better performance using less system overhead, and better protection by far than Norton.

 

4. Just pull that 4GB RAM stick out. All of your other sticks are 800MHz, and that one is only 667. It's just slowing everything down. You should be able to set XMP at 1866 afterwards instead of just 1600.

 

 

Share this post


Link to post
Share on other sites

Well after reading all of these replies I've since attempted several fixes...

 

I first tried to lower settings, thinking "well maybe I'm pushing my system too hard."

Using most of the presets appears to yield roughly 30 FPS regardless, with the exception of Lowest & Low.

Which of course my rig should be able to run, but is laughable compared to what should be possible with my specs.

 

I removed completely Dexpot & BlackGlassEnhanced. Which yielded no results.

I made sure to exclude not only 7DTD but also all steam-related applications in Norton with no improvement.

I've removed the 4GB stick as advised. Though from experience I know it couldn't have such a ridiculous performance penalty.

And it didn't change anything, so I decided to try variations on 4, 8 , 16, and 24 GB as well. The only differences in performance were framerate dips with the 4 & 8GB configurations.

I've even tried running the RAM in all of those configurations at 1866Mhz

 

At this point, i'm not sure what else I could try.

Share this post


Link to post
Share on other sites

You saw improvements of 30 FPS from 30 meaning 60 FPS which is the maximum with a normal monitor and vsync. Could it be that you forgot to turn off vsync?

 

60 FPS is totally fine by the way. 7d2d is a voxel game and has much higher demands on CPU and GPU. Don't expect 3 digit FPS just on account of a graphics comparison with more traditional polygon-based games. I have a non-highend Ryzen PC and I get about 80-90 fps with below-medium settings.

 

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Not exactly, I see roughly 30 FPS from medium settings all the way up to ultra regardless. Not gains "unfortunately" or losses either way... I'd love to see 60+ even if it meant running the game at medium settings. Though that would still be unsatisfactory.

Edited by XPho3nixRisingX (see edit history)

Share this post


Link to post
Share on other sites

@phoenix

Try Texture quality half. Even my 1080 struggle with full textures. Should give a nice performance boost. Ah, and if you planted hundreds of trees, chop them using loads of performance ;)

Share this post


Link to post
Share on other sites

@Ente I'm looking into other solutions right now. Like I said I've gotten the same results from medium to ultra. Meaning I get the same results even with half textures...

 

And I'm loading a default Navezgane map in both the desert & snow biomes. Results are still effectively the same sadly...

Share this post


Link to post
Share on other sites

Do you have 3 screens attached to your PC? I would do a quick test and disconnect two of them, restart the PC and check again. Just to be sure.

 

Share this post


Link to post
Share on other sites
Posted (edited)

As it should, but that's just simply not so for me personally...

At this point I am certain of a few things...

 

1: I've tried everything I can do on my end to fix this

2: It only got bad after alpha 18 "The first version."

3: As far as I am aware I began having these issues somewhere in the alpha 17 versions "certainly by alpha 17.4"

 

Which has so far been my favorite, but leaving personal opinions aside I've been playing the game nearly since launch and never had it run this poorly.

I've tried everything from re-installing windows, lowering settings, reseating hardware, loading from different hard disks, overclocking cpu, gpu, and memory, unplugging memory and monitors, turning off the Intel IGPU, lowering settings, allowing security exceptions, switching to GL Core rendering, running the game with easy anti-cheat enabled/disabled, updating/changing my graphics driver, and uninstalling "possibly conflicting software", without any improvements.

And it just doesn't make any sense. My settings pretty close to match @SylenThunder 's, perhaps changes made with the recent alpha simply put more stress on my hardware. But I've been told by many with similar specs that something is wrong... I suspected some sort of vsync issue as the 30FPS number just seems too ridiculous for it NOT to be the case. But it most certainly isn't enabled and changing it to on doesn't seem to do much except lower it the 3-5 extra fps I'd be above 30...

Edited by XPho3nixRisingX (see edit history)

Share this post


Link to post
Share on other sites

Did you try setting v-sysnc off in your Nvidia menu? If it simply caps at 30 all the time then it can be the issue. My FPS is nothing of constant, I can get high 60+ indoors facing the wall, but as soon as I turn around it gets like 26-40

Share this post


Link to post
Share on other sites

1: Install two 8 GB sticks. Make sure they are in dual channel mode.

2: Set your graphics to match what I posted.

3: Play the game for 20 minutes.

4: Post your log from that game.

 

Maybe someone can find something in your log.

Share this post


Link to post
Share on other sites

game is poorly optimized because "alpha", i would NOT expect more than barely playable 30 fps with this rig.

 

but we will get some drones and sledge turrets soon, it will be fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...