Jump to content

'Radial' Error when trying to get a new Quest from Trader


Recommended Posts

After completing Tier 1 quests and moving up to Tier 2 quests, talking to Trader Bob will sometimes throw an error when trying to get a new Tier 2 quest, or when trying to turn in a completed quest.


Here is the error when I try to talk to Trader Bob:

2023-02-03T11:02:58 529.609 ERR [XUi] Error while updating window group 'radial':
2023-02-03T11:02:58 529.613 EXC Object reference not set to an instance of an object.


A bit of background:

- Running Alpha 20.6, Single Player (SP) Client

- Verified Steam files with no problems found

- This is for a modified vanilla-generated 10K map

- No Mods running apart from MapToolz for map editing

- This instance of Trader Bob has been placed (not generated by the RWG) as part of a new 'town' (Really an airport)

- All other Prefabs in this 'town' have also been placed by me, including Random World Generated (RWG) tiles, parts, remnant buildings and quest-able POIs

- Some of these Prefabs have been created by me, including nine quest-able POIs;

  * Two Tier 1 POIs

  * Two Tier 2 POIs

  * Two Tier 3 POIs (Three instances of one of them; airport_hangar_01)

  * Two Tier 4 POIs

  * One Tier 5 POI

  * Over two dozen other prefabs including RWG tiles, Remnants and Parts seems to work fine

- All of these prefabs that have been created by me work in the Editor/Playtest just fine

- The rest of the placed Prefabs are all Funpimps generated, from the Prefab library

- Most of my player-made POI's quests work via Trader Bob, but I will always encounter the above error at some point or another

  * Some Tier 2 POIs (both mine and Fun Pimps-made POIs) worked just fine, too, before Bob throws an error

- Through a combination of console commands and advancing quest Tiers via other instances of Trader Bob, Tiers 3, 4, and 5 have also been tested;

  * Same error is encountered for Tier 3 and 4 as well as Tier 2 quests

  * Tier 1 and Tier 5 quests seem to work fine, again including those Tier 1 and Tier 5 quest-able POIs created by me

- I have tried 4 separate playthroughs, each with a new save (as well as deleted and regenerated Region files for each save)

  * Have always encounter the same error at some point when getting Tier 2+ quests from this player-placed instance of Trader Bob

- Other RWG-placed trader Bobs (3 more on the map)  as well as other traders in other towns on the map seem to work just fine


Full Log Files for the latest playthrough here;




Edited by AH64_Jimbo (see edit history)
Link to comment
Share on other sites

Kind of hard to read on that site on a phone, but I notice that right before you get those errors, the server shuts down.  Might want to check that.


Also, this error would generally relate to a problem with a specific POI.  You might want to note which POIs show up in the quest list when it is working as that will narrow down which POI is causing problems and you can look into that for any issues.  Any that show up should be fine. You'd be trying to find one that never shows up when it is working as it is probably the one causing an error when it does end up trying to show up.


I don't know if it would cause that error, but setting a quest as fetch or fetch/clear without having something to fetch in the POI could potentially be an issue.  If it were something like that, you could see it working on the editor and even in the game when getting a clear quest and think it is fine, but when it tries a fetch, it fails.  Similarly a generator night quest without generators.  May not be it, but just something to get you an idea what you might look for.

Edited by Riamus (see edit history)
Link to comment
Share on other sites

Yes that one is tough to read as it's all run together rather than separated by lines. Picking through it there are a ton of poi errors though it's difficult to see which poi's are suspect. If it were a vanilla game, I'd suggest verifying files twice which would fix any vanilla poi errors but since you have custom poi's it would be more difficult to root out. A tedious process would be to start over, add one poi at a time and do tier one quests then try to go to tier two. If no errors then add another poi. It just might be something isn't configured correctly on your custom poi's.

Link to comment
Share on other sites

  • 2 weeks later...

I figured it out. I was looking in the wrong place the whole time; Turns out that some of my non-quest-able "remnant" POIs had QuestTags in their XML files. Probably happened inadvertently when I was doing some copy and pasting. 


So the 'Object reference' error was most likely the Trader not finding a Rally Marker at the POI


Troubleshooting steps taken;

  • Removed all of my POIs except RWG tiles
  • Saved the world and started a new game
  • Quested with the trader just fine, indicating that the problem indeed was with one of my POIs
  • One-by-one added a POI back, started a new game and quested until I satisfactorily reached the appropriate level for the POI
  • Repeated the above step until the game broke and threw the same error
  • When it did, it clued me in that it was my NON-ques-table POIs (i.e. remnant or burnt aircraft)
  • This prompted me to look into those XML files and make changes


As you could imagine this process took a very long time. Still it is finished, and the airport looks great! I have shared it here


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...