Jump to content

Creative Mode issue? Inventory broken, everything lost, Level reset


Recommended Posts

I'll begin with saying I'm playing using the Darkness Falls Mod and this is the first time I've had this issue ever, even though I've been playing with the mod with no issues in normal mode.

So I created a random world and activated creative mode to mess around, build things, etc. Picked out all the gear I wanted, vehicles, things to build with all from the creative menu. Played for multiple hours, everything working fine. Built a cool base, no problems. Then I get done for the day, log out. Come back the next day, log back in and my inventory I had is gone, my tool belt is completely empty, my character is back to level 1 and with half stats, 50 instead of 100 on health and stamina. However, the base I built and anything I stored in boxes is all still there and I can move it into my inventory. So no problem, I can get everything I had back. However, my biggest issue is my inventory (backpack) is broken. So anything I put in my backpack doesn't register as me having it. i.e. - I can put a pistol on my tool belt, and pull it out. I'll have 600 9mm ammo in my backpack and it shows I have 0. I can move that 600 ammo to my tool belt and the gun now shows I have 600 ammo. So my back pack is completely broken. Everything will only loot to my tool belt and I have to move anything in my backpack manually by clicking and dragging only. shift clicking will put items in tool belt and when my tool belt is filled up. It will say my inventory is full even though nothing is in my backpack.

Is this a creative mode issue? As in you're only good to play till your done and then you can't come back? This is the only time I've ever had problems. When I play with friends and don't use creative mode, we come and go freely with no issues like this. I can also say that I've tried this twice now, with persistent profiles on and off. In the settings for the server it's even set to drop nothing on logout. Although with that said, my character is still resetting randomly and my health and stamina also halved.


Any insight would be appreciated. I've tried to google my issue and only found one post somewhere that mentioned the same issue a year or two ago, but the only reply it had didn't really provide anything. Even looking through the log shows nothing in red and I tried googling the only line that's in yellow, but that line seems to be in everyone's log regardless of issue.

Link to comment
Share on other sites

Nothing to do with creative mode. Most likely explanation is that your savegame is broken. First try to delete your player data (in the directory Players in the savegame) and if that doesn't help search your logfile for errors (except shader errors)


Link to comment
Share on other sites

Khaine made some changes to the backpack with his mod, you have an item at the start that unlocks the full backpack.  If your save game was messed up, then it probably messed up the backpack portion which is why you are having issues with it.  You might just have to restart a new game at this point.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...