Jump to content

A18 Dedicated Server


car1bo

Recommended Posts

I've just updated my A17 dedicated server machine to A18 (fresh install)

 

Firing it up for the first time I've noticed heavy CPU load, even before any clients connect. In fact one of my CPU cores is maxed out constantly at 100%!

 

Is anyone else having this issue or is it just me?

 

-----------------------------------------------------

 

Oops, just realised I posted in the console forum by mistake!

Link to comment
Share on other sites

Yeah I just went for PREGEN01 instead of RWG, so the map just loaded almost instantly, No lines in the event log after 15 minutes or so (no clients connected at that point)

 

Everything seems fine apart from the resource usage, clients are now connecting and it seems stable enough!

Link to comment
Share on other sites

I can understand using all cores while the map is generating, but this is happening after map generation while the server is empty/idle listening for client connections. A17 used very little resources with no clients connected.

 

It seems someone else on reddit has noticed this too with the same symptoms on Linux while I'm running on a Windows machine.

Link to comment
Share on other sites

Thanks for the heads up, but it's only a single core that's maxing out, There's 6 cores on the machine so it shows 25% utilisation currently in task manager (other processes bump up utilisation).

 

For reference:

 

Capture1.jpg.3cfb3682fd996de3cbc7bfeebae591cb.jpg

 

Capture2.jpg.8108964aad03c84a9e0e4771cf641223.jpg

Link to comment
Share on other sites

I can confirm all of this as well. Tested on multiple machines and configs. Idle CPU avg is around 13-15% with zero players online, the server looks to be sleeping like it did in previous alphas (no zombies, no time progression even ran a killall just to make sure). The CPU usage during RWG creation is understandable due to the amount of time it still takes to create the new detail data, but no server should be idling with no one on that high.

 

If it's a new system that's been added, can we please have an option to tell the server to sleep after X seconds from last player.

Link to comment
Share on other sites

My A18 7 days to die server docker container is idling at 20%+ CPU utilization with no one on. On the same server, I have an A17 instance and it sits around 0.9% so something's up in the experimental build for now. It is experimental after all. :)

 

Hi, how did u set up your server in Docker, i tried with https://github.com/mudfly/7dtd-server-docker (edited install.txt) but isnt working, can you share your docker?

Link to comment
Share on other sites

Hi, how did u set up your server in Docker, i tried with https://github.com/mudfly/7dtd-server-docker (edited install.txt) but isnt working, can you share your docker?

 

I use Unraid for my server and there's a docker container there by a person specifically for 7 days. Not using the mudfly one. If you run Unraid its easy to find in the Apps section

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...