Jump to content

Native Linux server (with management scripts)


Alloc
 Share

Recommended Posts

Better :D

Im now getting data in the /logs directory (2014-07-12_15-39-43_output.log and output_log.txt) so that seems to be solved.

 

However the logging in players.xml still isnt adding an entry on my test instance and my hook still refuses to fire the welcoming message :o

Btw, should I always be stopping the instances before updating scripts?

Link to comment
Share on other sites

Updating the scripts while instances are running shouldn't hurt but if there are changes to the logging stuff those won't affect running instances but only after the next start of an instance.

 

Regarding the player logging: Gotta test this again, thought it was working by now ;)

Link to comment
Share on other sites

Non-existant :D

I only have the old players.log in the instance-directory. In /logs I only have the <date>_output.log, stdout.log and output_log.txt.

 

The only Error Message I see popping up in the log is the following btw:

2014.07.13 11:35:12: Fallback handler could not load library /home/sdtd/engine/7DaysToDie_Data/Mono/x86/SteamworksNative

Link to comment
Share on other sites

Yeah, sure ^^

 

Ok, just to sum it up to this point:

You have updated to scripts version 29

Restarted the instance after that

Got nothing besides <date>_output.log, stdout.log and output_log.txt?

<date>_output.log contains normal entries though? Also lines like "<datetime> RequestToSpawnPlayer ...."?

Link to comment
Share on other sites

Didnt work, however I am getting an exception now which seems to prevent the instance from starting:

Exception: <player> has malfored lastlogin attribute!

at PersistentPlayerData.ReadXML (System.Xml.XmlElement root) [0x00000] in <filename unknown>:0

at PersistentPlayerList.ReadXML (System.String filePath) [0x00000] in <filename unknown>:0

at GameManager.ل¢µل™ƒ () [0x00000] in <filename unknown>:0

at GameManager.Awake () [0x00000] in <filename unknown>:0

 

(Filename: Line: -1)

Link to comment
Share on other sites

o.O

 

Looks like locale setting is a problem here :(

If you do not have done anything saved in that instance yet please delete the players.xml in the save game folder.

 

 

/EDIT:

Looks like deleting that players-file will do just two things:

- Reset friendships

- Remove landclaim-block <-> player associations

Edited by Alloc (see edit history)
Link to comment
Share on other sites

Will this affect an already running instance though? As in will I have a problem once I stop the instance and want to restart it?

 

I deleted the players.xml from the test instance and could then start it. PLUS players.xml in instance folder is now getting correct values AND the hook is working for that instance! So this seems to have fixed it, good job! :D

 

Edit: Im guessing the malformed LastLogin mm/dd vs dd/mm is the problem? I might just try and correct it then, because deleting the players.xml on the other instance isnt really an option :D

Edited by Isalof (see edit history)
Link to comment
Share on other sites

So I switched the date-Format in the players.xml and it still didnt work which made me nuts :D

A few hours later I thought about it again and it hit me, the Ban-List in the admins.xml file has dates in it :D

 

So that fixed it, all is well now, thanks for the help with these great scripts Alloc!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...