Jump to content

HELP: 2 questions about InspectUI window & text


Recommended Posts

Hi people if I could have someone explain how to do this please that would be great...


When you first load up the game online, Inside the InspectUI window some people have what looks like a Pic with their own txt in it, Does anyone know how to do this either client side cos my files need downloading anyway or server sided...


When in game you craft a recipe, But !! there are NO gaps in the words, an example would be..


GenericSlugAmmo.... Instead of Generic Slug Ammo, This is whats viewed by the player on the left when creating the recipe..


Thanks for any help as ive tried & tried & not got anywhere....

Link to comment
Share on other sites

that could be because its a custom made item, in the items.xml


it would be something like


<item id="1530" name="GenericSlugAmmo">

<property name="CustomIcon" value="an icon name"/>






so what you would see is GenericSlugAmmo when mouse over


so its down to who made it


and as xmls get pushed from the server, it wont matter what you do, try contacting the creator to see if they can fix it

Link to comment
Share on other sites

<item id="1530" name="GenericSlugAmmo">


Can this have spaces in the XML ? like


<item id="1530" name="Generic Slug Ammo">


Is there anyway to write it so it works as ive edited the code


I wrote this code in myself keepting to what the old code looked like, tried different ways but it doesnt seem to work, The original code doesnt have spaces & that has spaces when in game ? so something is different..


Ok just tested it with a space in the wording & it works lmao..... I never thought to check that as no spaces exist in any of the coding yet there are spaces in game, dont figure...


<item id="2393" name="Tazas Stoneaxe Thor">

<property name="DescriptionKey" value="tazasStoneaxeDesc"/>

<property name="Extends" value="stoneAxe"/>

<property name="Meshfile" value="Items/Weapons/Melee/Axe/stone_axePrefab"/>

<property name="EconomicValue" value="800"/>

<property name="CustomIcon" value="stoneAxe"/>

<property name="CustomIconTint" value="ffb0d8"/>

<property class="Action0">

<property name="Stamina_usage" value="0.1"/>

<property name="DamageBonus.wood" value="2"/>

<property name="DamageBonus.head" value="1"/>

<property name="DamageBonus.glass" value="1"/>

<property name="DamageBonus.earth" value="1"/>

<property name="DamageBonus.stone" value="2"/>

<property name="DamageBonus.metal" value="1"/>

<property name="DamageBonus.organic" value="1"/>

<property name="ToolCategory.harvestingTools" value="1.8" param1="1"/>

<property name="ToolCategory.harvestingToolsBonus" value="1.6" param1="1"/>

<property name="ActionExp" value="4" />

<property name="ToolCategory.Butcher" value="0" param1="10"/>


<property class="Action1"> <!-- UseAction -->

<property name="Class" value="Repair"/>

<property name="Delay" value="0.4"/>

<property name="Repair_amount" value="350"/>

<property name="Upgrade_hit_offset" value="-2"/>

<property name="Sound_start" value="repair_block"/>

<property name="Allowed_upgrade_items" value="wood,clayLump,dirtFragment,snowBall,scrapIron,forgedIron,forgedSteel,steelPolish,concreteMix,cobblestones,yuccaFibers"/>


<property class="Attributes">

<property name="EntityDamage" value="7,19" />

<property name="BlockDamage" value="50,90" />

<property name="DegradationMax" value="900,2000" />

<property name="DegradationRate" value="1,1" />

<property name="DismembermentBaseChance" value="0.075,0.2"/>

<property name="DismembermentBonus" value="0,0"/>




This works to my surprise...

Link to comment
Share on other sites

yes it will work fine for you in single player


but when you join a dedicated server that has a different recipe/item list you wont see what you've seen in single player as all xmls get pushed from the dedicated server


so to fix your original problem the dedicated server xmls will need to have the spaces in the names

Link to comment
Share on other sites

Yeah i found that yesterday when testing :) I run a moddified version of Dwalls wicked WOTW so ppl need to download an Icon pack that is needed anyway so any changes can be installed either way, My biggest issue at the MO is ive changed so many things I need people to have a rough run down when they join the test server, Problem is Ive tried messing with the InspectUI window but havent made anything work... Ive noticed in WOTW when you press ESC your greeted with a window with TXT, That i cant figure out either lol...


Any help would be great, Oh & NO one has these files that ive modded so ive protected the fact that its Dwallordes work, 99% is pushed from the server so no files are kept, only I have the originals

Link to comment
Share on other sites

for the custom text on opening of backpack/inventory you want to edit: Window name=emptyInfoPanel.


Use a URL linked texture for the image as textures and sprites arent pushed from the server.

Change the label to include the text you wish.


To change the menu when you press escape you will need to edit: window name="ingameMenu".

Link to comment
Share on other sites

Sorry I have NO experience with this part of modding what so ever, When you say use an Url as in like a web page / image.... Can you explain in Dummy form how I go about maybe loading up an image thats hosted if possible... Dimensions allowed & so on ?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...