Jump to content

Can´t join own Dedicated Server


Recommended Posts

So I´ve been at this for a few days now so this is getting a bit frustrating.

I´ve been trying to run a Dedicated server on my Linux machine, it worked for the last 2 Alpha versions but now i just can not get it to work.

It starts and loads just fine but when trying to connect to it i get the error "Kicked by Steam: Your Authentication data is from another game".

I also can conect to other servers just fine so its just mine, but i have abulutly no clue of what i´m doing wrong.

Any help would be greatly appreciated!

 

Log from the server: https://pastebin.com/yqmfkYHp

Link to comment
Share on other sites

Game version mismatch usually means that the server is running a different version than the player. The server is definitely running A20.5. Start the game up and your version will be listed in the upper righthand corner of the screen. If your game says it’s also running A20.5, post the log from your pc.

Link to comment
Share on other sites

2 hours ago, Hirobrine03 said:

i´ve had a friend try and he cant as well

i´ll send you the details

I got the same error in my log, and same message on screen. 

Quote

2022-08-06T16:09:11 11027.034 INF [NET] Kicked from server: Platform auth failed: GameMismatch

For some unknown reason, the server sends bad info to the client about the version being run. I would delete all game files, including

all data from the .local/share/7DaysToDie folder and start over clean.

Link to comment
Share on other sites

well probelm is even that doesn´t help

I´m using Pufferpanel for the conviniance and i´ve tried on multible servers now with the same result

everytime a new server is created and downloaded its a compleatly seperate install of everything so it cant be broken files

 

(Every new server instance runns this at the start:

mkdir steamcmd

tar --no-same-owner -xzvf steamcmd_linux.tar.gz -C steamcmd

steamcmd/steamcmd.sh +login anonymous +force_install_dir .. +app_update 294420 +quit

mkdir -p .steam/sdk32

cp steamcmd/linux32/steamclient.so .steam/sdk32/steamclient.so)

Link to comment
Share on other sites

2 hours ago, Hirobrine03 said:

steamcmd/steamcmd.sh +login anonymous +force_install_dir .. +app_update 294420 +quit

That's the old command string to install. It was changed a while ago.

This is the correct syntax:

steamcmd +force_install_dir "your\install\path\here" +login anonymous +app_update 294420 -validate +quit

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...