Jump to content

A20, cannot generate random world. Nullreferenceexception error keeps popping up after a cpl minutes of generating world

Mr Lucky

Recommended Posts

So, I can play A20 but only in a PreGen world so far. When I tried to generate a new random gen world it starts generating, but after a cpl of minutes the console menu drops down and in red letters it says "EXC Nullreferenceexception: Object reference not set to an instance of an object".


 It will not continue loading after that point. Everything just stops. I read some stuff about deleting save game files, I did. I even uninstalled the game and reinstalled and just tried it again, still... Same issue comes up when trying to generate any new random gen worlds... I seem to be the ONLY person having this issue bc everyone I see on YouTube is able to gen a new world and play just fine... What the HELL do I do? If anyone knows how to fix this, PLEASE tell me. I am not the most tech savvy, but can follow instructions well, lol... Please. Help! I deleted all mods I had also from A19 I think so idk what else to do... 

Link to comment
Share on other sites



Having the same issue here.  Game throwing a NullReferenceException after "Writing Map Data Complete"  when generating random worlds.  Ive cleaned my files via the game launcher, saves and data. 

Never used mods before or edited prefabs using the ingame editor or otherwise. 

Happens on B231 and b232/233.  Haven't tried b230 yet...


Cleaned out my prefab folder, turns out i had some old files from 2017 in there.  Seems to have fixed the issues

Edited by UncleFatherOscar (see edit history)
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...