Jump to content

Game hangs on launch; Error 0xC0030004


Recommended Posts

     A friend of mine previously made a thread about this in my stead a while ago, but after extensive research I have not been able to find a solution for this that works. This problem occurred ever since the release of A19 experimental and persists through A19 Stable. I cannot launch 7 Days with EAC enabled, but if I turn off EAC via the launcher, I am able to play but am mostly limited to single player.

Here are the troubleshooting steps I have taken (note, there has been several, several appropriately timed restarts between all steps):

-Uninstalled and reinstalled game
-Verified game cache several times
-Running as administrator from the .exe from main folder (not in steam)
-Uninstalling, reinstalling, and repairing EAC
-Antivirus turned off
-Windows up to date
-Video card up to date
-Excluding both client and EAC from antivirus + firewall, and excluding entire steam game folder as well
-Verifying connectivity to EAC
-Closing as many unnecessary files as possible
-Cleaning game files via 7 Days launcher
-deleting C:\Program Files(x86)\Easy Anti Cheat\easyanticheat.sys (another solution I found on a separate forum for the same EAC error)

*Basically everything I could think of except a clean install of windows. Highly doubt it's hardware, because my specs are quite a bit above minimum, and all of the parts in my PC are less than a year old and reputable brands*

     Honestly, I've never had any EAC related issues with any other EAC enabled game I've played, and this is incredibly frustrating. None of these troubleshooting steps have worked, so I just haven't played the game since A19 ex, since I can't even play with all of my friends. 😕 If anyone has ANY other troubleshooting I could try, please let me know.


Link to comment
Share on other sites

Well, I'd run the EAC repair tool under admin (right click, run as administrator), then perhaps to eliminate any Windows errors, run these two in powershell or command prompt (Run [or search], cmd or powershell.exe)


sfc /scannow


DISM /Online /Cleanup-Image /RestoreHealth


The second one will require you to be online.


Welcome to the forums, btw, hopefully this gets resolved for ya.

Link to comment
Share on other sites

Hmm. Would you mind uploading a Dxdiag report? (Click save all as and save it somewhere type it into the run box or search box).


This doesn't appear to be a 7 Days issue but one with EAC, so it's either a hardware error or, more likely, some issue between EAC hooking into the kernel api on startup and Windows; something isn't cooperating. Maybe a Windows refresh can help, too, although DISM should have caught anything off.



mdsched.exe  (choose the option to scan at reboot)

chkdsk /f /r

Link to comment
Share on other sites

@GoTentaBeth, did you ever uninstall in that order Sylen suggested? I was going to suggest that after confirming you don't have any obvious hardware issues.  mdsched.exe is a memory checker built into Windows, not a cure :)


I would try that uninstall and reinstall order, it'll help with conflicts if there are any. If not...  head into Recovery (from update and security on the top of my head, but searching for recovery, or using your recovery media (i.e. search for "hp computer recovery console") > Reset this PC > Choose keep my files. Or, if you're feeling spunky and have backups or if the former doesn't cure anything, do a complete reinstall.


This is of course you're willing to just jump into doing that. But, such a localized issue leads me to think something went wrong with your Windows... ya know, since Windows updates never causes any issues 🙂, although I will say this is excessive and there should be a singular issue to troubleshoot. May also be worth opening a ticket in with EAC, although after looking up this error on their support page, they go for reinstalling Windows.

Link to comment
Share on other sites

😅 Hahah, yeah, I figured it wasn't really a cure so much as test kinda deal. I had previously uninstalled and reinstalled in the order that Sylen recommended. Honestly,  I think nothing short of a fresh install might fix it, but I really don't want to go into all that effort for one game. No idea why they decided to go with EAC as opposed to Battleye, or even steam VAC, but oh well.

There was a previous thread on this issue and I had followed all of the steps in the exact order, but nothing seemed to changed and I still keep getting that error. Strange that 7Days ran smoother than butter previous to A19


Step 1: Exclude the client from your antivirus and anti-malware software. (I cover this in detail in the Sticky FAQ) This error is usually caused by security software not allowing EAC to do it's job.


Step 2: Open C:\Program Files (x86)\EasyAntiCheat\EasyAntiCheat.exe. Select 7 Days, and click Uninstall. Reboot your computer. Run EasyAntiCheat.exe again, select 7 Days, and select Install. Then reboot your computer.


Step 3: Verify the client files in Steam two times. Once does not always catch everything, and it's very likely your security software screwed something else up.

^ This one. I even followed EAC's troubleshooting steps, short of a fresh install.

I've honestly been hunting for weeks for a viable solution online. Seems a lot of people are getting this same error with EAC, just with other games, but their solutions have been short of ineffective.


Link to comment
Share on other sites

Yeah I've seen about the same with your error.For further debugging, type into an admin-ran command prompt:


tasklist > C:\Users\[USERNAME]\Desktop\processes.txt


Replace username with your username of course. Or just put C:\processes.txt and it'll be in your root C drive location. Throw that list up here.



Link to comment
Share on other sites

@Jugginator Here is the process list pastebin for ya:


I really do appreciate all your help. I'm more hardware savvy than software savvy, so it's nice to have a different set of eyes to help me with this. :)

Also, this computer was built maybe less than four months ago, so it was fairly recent that a fresh copy of windows was installed on a brand new hard drive. Baffles the hell out of me.

Link to comment
Share on other sites

13 minutes ago, GoTentaBeth said:

@Jugginator Here is the process list pastebin for ya:


I really do appreciate all your help. I'm more hardware savvy than software savvy, so it's nice to have a different set of eyes to help me with this. :)

Of course you're welcome. Let's try this again but with everything non-vital to Windows closed. I will exclude your RGB stuff in case that's something you really want (I've never seen this software really do anything bad, but if you don't mind for science include this too). I'll just give you a general list here, most of these are multiple processes from the same program.


NVDisplay.Container.exe (Close all of that stuff)









I'd go on but you get the drift. Most of it is Corsair and Nvidia stuff that's not needed at all. Close all of that stuff down and then some, if there's something vital to Windows it'll tell you so.


Link to comment
Share on other sites

Okay, so I figured it out on my own. I don't know if this solution will work for everyone, but holy crap was it the silliest ever.

First thing I did was going into C:\Program Files (x86)\EasyAntiCheat and then ran the eac .exe and uninstalled it from there. 

Then I went into C:\Program Files (x86)\Steam\steamapps\common\7 Days to Die and just deleted the entire EasyAntiCheat folder itself. Don't delete anything else from the 7 Days folder.

Finally, I opened up the Steam launcher, right clicked 7 Days, then properties, went to the local files tab and verified files. As soon as that was done, I was able to launch 7 Days with no issues.

No restart required! YAY!

It seems like uninstalling EAC via the utility doesn't catch everything. You gotta treat it like a virus.  🤣


I guess, good thing I'm ridiculously stubborn and like to bash my head against problems for hours on end. 🤣😂

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...