Jump to content

Console errors I cannot ID.


Recommended Posts

Can anyone point me to where I can find what these errors are referring to?

Trying to clear up the red lol.

 

2020-05-23T02:20:27 165.725 ERR LootContainer 251 uses an unknown loot_quality_template "baseTemplate"
2020-05-23T02:20:27 165.725 ERR LootContainer 252 uses an unknown loot_quality_template "baseTemplate"

 

If someone has an idea of where to start looking I'd be grateful.

Thanks in advance.

Link to comment
Share on other sites

On 5/23/2020 at 6:18 PM, Pra3t0r 0f R0m3 said:

Can anyone point me to where I can find what these errors are referring to?

Trying to clear up the red lol.

 

2020-05-23T02:20:27 165.725 ERR LootContainer 251 uses an unknown loot_quality_template "baseTemplate"
2020-05-23T02:20:27 165.725 ERR LootContainer 252 uses an unknown loot_quality_template "baseTemplate"

 

If someone has an idea of where to start looking I'd be grateful.

Thanks in advance.

Do you have a mod installed? loot containers are defined in Data/Config/loot.xml , 251 could be an id (but in vanilla there is no id 251). There are also two templates defined in that file, a qualBaseTemplate and a baseProbTemplate, maybe someone forgot to add either "qual" or "Prob"

 

Link to comment
Share on other sites

7 hours ago, meganoth said:

Do you have a mod installed? loot containers are defined in Data/Config/loot.xml , 251 could be an id (but in vanilla there is no id 251). There are also two templates defined in that file, a qualBaseTemplate and a baseProbTemplate, maybe someone forgot to add either "qual" or "Prob"

 

Thank you, I found exactly what I needed to.

I found it in of all things the Large Storage Containers mod (which seems to have a dead forum and links), however, what this loot.xml file has to do with the specific storage containers it creates is beyond me.

Since "cobwebs" don't appear in the mods blocks file, I should be safe to remove it?

 

<configs>
    <append xpath="/lootcontainers">

        <lootcontainer id="251" count="0" size="14,10" sound_open="UseActions/open_chest" sound_close="UseActions/close_chest" loot_quality_template="baseTemplate">
            <item name="cobweb" count="1,2"/>
        </lootcontainer>
        
        <lootcontainer id="252" count="0" size="14,10" sound_open="UseActions/open_safe" sound_close="UseActions/close_safe" loot_quality_template="baseTemplate">
            <item name="cobweb" count="1,2"/>
        </lootcontainer>
        
    </append>
    
    <set xpath="/lootcontainers/lootcontainer[@id='4']/@size">14,10</set>
</configs>

Link to comment
Share on other sites

Cobweb is a regular block, though it's not used as often lately.

 

<block name="cobweb">
    <property name="Material" value="Mcloth"/>
    <property name="Shape" value="ModelEntity"/>
    <property name="Collide" value="melee"/>
    <property name="Model" value="Entities/Decor/cobwebPrefab"/>
    <drop event="Destroy" count="0"/>
    <property name="FilterTags" value="fdecor,fother"/>
</block>

 

Link to comment
Share on other sites

What I find strange is that I have never ever seen cobwebs in loot even though they are still in loot.xml.

 

From reading loot.xml (or maybe a comment in XML.txt) I get the impression that it is sort of the NOP operation of loot, meaning it is replaced with emptiness (internally), because a really empty loot container definition is not empty but some default loot.

 

Your best option to get it working IMHO is to change "baseTemplate" to "qualBaseTemplate"

 

 

Link to comment
Share on other sites

5 hours ago, SylenThunder said:

Cobweb is a regular block, though it's not used as often lately.

 


<block name="cobweb">
    <property name="Material" value="Mcloth"/>
    <property name="Shape" value="ModelEntity"/>
    <property name="Collide" value="melee"/>
    <property name="Model" value="Entities/Decor/cobwebPrefab"/>
    <drop event="Destroy" count="0"/>
    <property name="FilterTags" value="fdecor,fother"/>
</block>

 

 

1 hour ago, meganoth said:

What I find strange is that I have never ever seen cobwebs in loot even though they are still in loot.xml.

 

From reading loot.xml (or maybe a comment in XML.txt) I get the impression that it is sort of the NOP operation of loot, meaning it is replaced with emptiness (internally), because a really empty loot container definition is not empty but some default loot.

 

Your best option to get it working IMHO is to change "baseTemplate" to "qualBaseTemplate"

 

 

Ah ok good, thank you both for the input. I'll give it a shot.

Link to comment
Share on other sites

On 5/25/2020 at 6:49 AM, meganoth said:

What I find strange is that I have never ever seen cobwebs in loot even though they are still in loot.xml.

 

From reading loot.xml (or maybe a comment in XML.txt) I get the impression that it is sort of the NOP operation of loot, meaning it is replaced with emptiness (internally), because a really empty loot container definition is not empty but some default loot.

 

Your best option to get it working IMHO is to change "baseTemplate" to "qualBaseTemplate"

 

 

This worked like a charm, thanks again...now just one more set of red errors and I'm down to a few yellow did not apply, and over downgrade limit warnings and I'll be all good.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...