Jump to content

Server process got killed in Linux server. Please help.


Recommended Posts

Hi there,


I brought a cloud server and want to setup the server to play with my friend. I used to have a windows server which worked fine. This time I got a Linux server.


after I enter "./startserver.sh -configfile=./serverconfig.xml" the process get started. However, half minute later it got killed like:


"./startserver.sh: line 37: 6495 Killed ./7DaysToDieServer.x86_64 -logfile $SERVERDIR/7DaysToDieServer_Data/output_log__`date +%Y-%m-%d__%H-%M-%S`.txt -quit -batchmode -nographics -dedicated $PARAMS".



here is the log:



Would anyone please help? Thanks a lot.

Link to comment
Share on other sites

If I startup a server with an 8K world, memory consumption jumps to about 3.5GB. You can at least start a 4k or 8k server if you only have 4GB.


If you are running Windows, then you need more because Winbloze itself takes a huge chunk of resources, so now you need a good 8K to get your server to start and run.


If you want bigger worlds, you add a lot more memory. My server with a 12K world takes about 10.5GB at startup. Last time I ran a 16K world, the server was using more than 16GB ram give or take. I ended up putting 32GB in the box and memory problems all went away.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...