Jump to content
psouza4

MeanCloud's Mining modlet (A18) with copper, zinc, and excavators

Recommended Posts

intro.png

 

INTRO & CREDIT:

You've seen it before: copper and zinc together to make brass! What I've done here is extended support for ore-laden sub-biomes by adding copper and zinc metal boulders and vein generation to the random world generator. You can smelt these meterials together to make brass directly in the forge. Additionally, I added automated mining excavators (inspiration and permission from stallionsden's modlet) that will automatically produce a variety of raw ores, stones, and even asphalt, gravel, bones, soil, and glass -- but the cost to make them is steep.

 

After retrieving raw ores, you can use the new rock crusher machine to crush them up for you into usable resources. Finally, lots of effort has been made to add copper and zinc as salvagable metals throughout the game from appliances to metal piping as well as automotive pieces and chain-link fences. This mod gives you plenty of options for finding new ways to get brass for all your munitions needs, not to mention all the other ores at a reasonable pace.

 

Credit to Del_Stryker for putting together some copper and zinc boulder models.

 

DOWNLOAD & INSTALL:

Alpha 18.0: MeanCloud__Mining_v1.01.zip (version 1.01, 2019-10-28)

Alpha 18.1+: MeanCloud__Mining_v1.04.zip (version 1.04, 2020-03-21)

 

Download and extract this modlet to your 7 Days to Die /Mods folder.

 

For Steam users, that's <steamdir>\steamapps\common\7 Days To Die\Mods (create 'Mods' if it doesn't exist).

 

Once extracted, move the files in the mod's /Prefabs folder to your 7 Days to Die /Data/Prefabs folder.

 

For Steam users, that's <steamdir>\steamapps\common\7 Days To Die\Data\Prefabs ('Prefabs' will already exist; if you can't find it, you're in the wrong place).

 

USING THIS MOD:

To get started mining, I highly recommend you create a new random world. If you try to install this mod in an existing game, the new copper and zinc ores and veins will not be generated. You will still find copper and zinc while salvaging and scavenging, but you will not find it while mining unless you create a new random world (see notes further down in this post). Once you've found some copper or zinc to mine (or have otherwise looted some), take it to the forge and you'll find that it now accepts the additional metals which can be smelted down into scrap brass or forged directly into bullet casings. Note that you still need the relevant perk to craft bullet casings and the crucible to pour brass back out of the forge as normal.

 

copper_and_zinc.png

 

This modlet also adds excavators, which are automated mining machines that will drill into the ground and resurface with materials every so often. While they are expensive to make, they will surely make up for their cost in the materials they mine up. Most of the mined ore must be processed by a rock crusher, which this mod also adds. The rock crusher is a new workbench (it's built from an old industrial clothes washing machine) that uses ore blocks and sand to crush the usable materials out of the ore.

 

forge_and_crusher.png

 

Excavators will go through various stages as they mine through the ground:

 

excavators_all.png

 

Have fun mining!

 

WANT MORE?

Try my Regenerating Boulders mod that lets ore boulders regenerate. There's a subversion of that mod that works for these copper & zinc ore boulders.

 

NOTE FOR MULTIPLAYER:

The current version of Alpha 18 does not push localization data to users. If you are playing multiplayer (either hosting or via dedicated server), each player will need to install the mining mod themselves to get the proper descriptions of items, blocks, UI labels, etc. that this mod changes.

 

NOTE ABOUT WORLD GENERATION:

This modlet adds ore generation in the form of sub-biomes for copper and zinc metal boulders and ore veins. If you do not generate a new world, these boulders and veins will be absent (but you can still definitely acquire copper and vein materials by salvaging and scavenging during normal gameplay). I would recommend that you start a new game if you intend to use this mod.

 

NOTE ABOUT THE FORGE CHANGES:

If you are adding this modlet to an existing game, please be aware that your existing forges will have all contents erased except for fuel and anything that was queued. This is because this modlet is adding extra input materials (copper and zinc) and the 7 Days to Die game engine does not gracefully handle this kind of change. Make sure you're okay with all players losing forge contents the first time this mod is installed into an existing game world.

 

NOTE ABOUT MODLET COMPATIBILITY:

This modlet is not compatible with stallionsden's mining truck and rain collector modlet, which uses some of the same block names and lootcontainer IDs.

 

Additionally, this modlet is not compatible with the S420's SimpleUI-ForgeInput modlet that changes forges to have three inputs. This modlet already includes forges with three inputs anyway, but S420's overwrites what resources are accepted by the forge, causing errors to be logged to the console since this modlet requires copper and zinc to be accepted by the forge.

 

Neither is this modlets compatible with many modlets that reskin the forge at all.

 

ERRORS ON STARTUP?

If you fail to install the prefabs correctly, 7 Days to Die will log errors in the console window. You need to install the prefabs to the correct location, even if you aren't generating a new world or are playing on a dedicated server.

 

TESTERS:

This is one of my bigger mods -- looking for people to test and provide details of any bugs or issues, or simply want to give feedback on their experiences with the mod such as game balance.

 

SUPPORT ME:

PayPal Donation if you enjoyed my work and want to encourage me to do more.

All of my modlets for 7 Days to Die.

Edited by psouza4 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

I feel like I should mention this, although I don't plan to use this mod. For whatever reason, using this while generating a RWG (4096 x 4096), it will say that I've spawned in (in the console), yet I'm stuck on the "generating environment" or whatever screen.

Share this post


Link to post
Share on other sites
I feel like I should mention this, although I don't plan to use this mod. For whatever reason, using this while generating a RWG (4096 x 4096), it will say that I've spawned in (in the console), yet I'm stuck on the "generating environment" or whatever screen.
Hmm, and how long have you been generating? I assume no other mods (because who knows what might conflict). Any errors in the console? I've generated several 4K, 8K, and one 16K world in dedi and SP (Steam version) without issues but I'm only running a few mods that I know aren't going to give me grief.

Share this post


Link to post
Share on other sites

Tried loading in to an existing game, got a failed to load biomes.xml error, when it finally loaded in to the world was spammed with NRs.

 

Tried making a 4k random world, no issues generating the map, then when trying to load in to the world same failed to load and game never loaded.

Share this post


Link to post
Share on other sites
Tried loading in to an existing game, got a failed to load biomes.xml error, when it finally loaded in to the world was spammed with NRs.
You did not take the extra step to install the Prefabs correctly.

 

Please see the instructions in the main post for installing/use and the sub-note for errors-on-startup.

Share this post


Link to post
Share on other sites

I have latest A18, i got zinc and copper, but forge input 2 and 3 does not work and copper and zinc is not smelting even in input slot 1

Share this post


Link to post
Share on other sites
I have latest A18, i got zinc and copper, but forge input 2 and 3 does not work and copper and zinc is not smelting even in input slot 1
Sounds like the mod is not installed entirely. Is this in a single-player (self-hosted) game? Do you have any errors in the console or log (hit F1)?

Share this post


Link to post
Share on other sites
Sounds like the mod is not installed entirely. Is this in a single-player (self-hosted) game? Do you have any errors in the console or log (hit F1)?

 

Yes single player game, self-hosted, no error at all...only message in console that mode has loaded.

Share this post


Link to post
Share on other sites
Yes single player game, self-hosted, no error at all...only message in console that mode has loaded.

 

Can you please post or PM me your log from /7DaysToDie_Data/output_log_2019-10-25-*.txt ?

Share this post


Link to post
Share on other sites

Been having an issue getting this running. This is the error I get when I try to join my server that I am hosting running this. My friends trying to join also get this. I've got the files in a folder in Mods, and moved the Prefab folder and merged the files in to the one in the root 7dtd folder

 

https://cdn.discordapp.com/attachments/426486758461538306/637458312106999858/unknown.png

 

Edit: There is another regarding the mod specifically that I couldn't capture because of how rapidly the error spam is going.

Edited by Arigas (see edit history)

Share this post


Link to post
Share on other sites
Been having an issue getting this running. This is the error I get when I try to join my server that I am hosting running this. My friends trying to join also get this. I've got the files in a folder in Mods, and moved the Prefab folder and merged the files in to the one in the root 7dtd folder

 

https://cdn.discordapp.com/attachments/426486758461538306/637458312106999858/unknown.png

 

Edit: There is another regarding the mod specifically that I couldn't capture because of how rapidly the error spam is going.

 

Open your log file and post the issues that occur before this?

Share this post


Link to post
Share on other sites

Not sure how to do tidy layout for text, but this is the copy/paste of it. I can upload the full log file as well if you would like.

 

2019-10-25T21:11:01 32.445 ERR XML loader: Loading and parsing '' failed

2019-10-25T21:11:01 32.446 EXC Parsing biomes. Prefab with name 'deco_zinc_vein.tts' not found!

Exception: Parsing biomes. Prefab with name 'deco_zinc_vein.tts' not found!

at WorldBiomes.parseBiome (System.Byte id, System.String name, System.Xml.XmlElement biomeElement, System.Boolean _instantiateReferences) [0x00c68] in <242df21e063444d18cf17717626ca012>:0

at WorldBiomes.parseBiome (System.Byte id, System.String name, System.Xml.XmlElement biomeElement, System.Boolean _instantiateReferences) [0x00148] in <242df21e063444d18cf17717626ca012>:0

at WorldBiomes.readXML (System.Xml.XmlDocument _xml, System.Boolean _instantiateReferences) [0x0011d] in <242df21e063444d18cf17717626ca012>:0

at WorldBiomes..ctor (System.Xml.XmlDocument _genxml, System.Boolean _instantiateReferences) [0x0003d] in <242df21e063444d18cf17717626ca012>:0

at WorldStaticData+<LoadBiomes>d__35.MoveNext () [0x00013] in <242df21e063444d18cf17717626ca012>:0

at ThreadManager+<CoroutineWrapperWithExceptionCallback>d__40.MoveNext () [0x00044] in <242df21e063444d18cf17717626ca012>:0

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

UnityEngine.DebugLogHandler:LogException(Exception, Object)

UnityEngine.Logger:LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

Logger:masterLogException(Exception)

Logger:Exception(Exception)

Log:Exception(Exception)

<>c__DisplayClass54_0:<handleReceivedConfigs>b__0(Exception)

<CoroutineWrapperWithExceptionCallback>d__40:MoveNext()

UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

 

(Filename: <242df21e063444d18cf17717626ca012> Line: 0)

 

2019-10-25T21:11:01 32.678 ERR XML loader: Loading and parsing '' failed

2019-10-25T21:11:01 32.678 EXC An item with the same key has already been added. Key: ParticleEffects/p_snowstorm1

ArgumentException: An item with the same key has already been added. Key: ParticleEffects/p_snowstorm1

at System.Collections.Generic.Dictionary`2[TKey,TValue].TryInsert (TKey key, TValue value, System.Collections.Generic.InsertionBehavior behavior) [0x000c1] in <1f0c1ef1ad524c38bbc5536809c46b48>:0

at System.Collections.Generic.Dictionary`2[TKey,TValue].Add (TKey key, TValue value) [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0

at DictionaryList`2[T,S].Add (T _key, S _value) [0x00000] in <242df21e063444d18cf17717626ca012>:0

at BiomeParticleManager.RegisterEffect (System.String biome, System.String prefabName, System.Single chunkMargin) [0x00066] in <242df21e063444d18cf17717626ca012>:0

at WorldBiomes.parseBiome (System.Byte id, System.String name, System.Xml.XmlElement biomeElement, System.Boolean _instantiateReferences) [0x007e2] in <242df21e063444d18cf17717626ca012>:0

at WorldBiomes.readXML (System.Xml.XmlDocument _xml, System.Boolean _instantiateReferences) [0x0011d] in <242df21e063444d18cf17717626ca012>:0

at WorldBiomes..ctor (System.Xml.XmlDocument _genxml, System.Boolean _instantiateReferences) [0x0003d] in <242df21e063444d18cf17717626ca012>:0

at WorldStaticData+<LoadBiomes>d__35.MoveNext () [0x00013] in <242df21e063444d18cf17717626ca012>:0

at ThreadManager+<CoroutineWrapperWithExceptionCallback>d__40.MoveNext () [0x00044] in <242df21e063444d18cf17717626ca012>:0

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

UnityEngine.DebugLogHandler:LogException(Exception, Object)

UnityEngine.Logger:LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

Logger:masterLogException(Exception)

Logger:Exception(Exception)

Log:Exception(Exception)

<>c__DisplayClass54_0:<handleReceivedConfigs>b__0(Exception)

<CoroutineWrapperWithExceptionCallback>d__40:MoveNext()

UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

 

(Filename: <1f0c1ef1ad524c38bbc5536809c46b48> Line: 0)

Share this post


Link to post
Share on other sites
2019-10-25T21:11:01 32.445 ERR XML loader: Loading and parsing '' failed

2019-10-25T21:11:01 32.446 EXC Parsing biomes. Prefab with name 'deco_zinc_vein.tts' not found!

Exception: Parsing biomes. Prefab with name 'deco_zinc_vein.tts' not found!

 

You forgot to perform the Prefabs step of installation.

Share this post


Link to post
Share on other sites

I'm 99% sure I moved everything from the Prefab folder to the folder on the server as well, but I'm giving it another shot after re-copying it. Only difference is I'm leaving the prefab folder in the mod folder as well, just in case. Also, quick question, would I need to add the prefab files in locally to my client?

Share this post


Link to post
Share on other sites
I'm 99% sure I moved everything from the Prefab folder to the folder on the server as well, but I'm giving it another shot after re-copying it. Only difference is I'm leaving the prefab folder in the mod folder as well, just in case. Also, quick question, would I need to add the prefab files in locally to my client?

 

Yes, you do.

 

From my first post:

 

If you fail to install the prefabs correctly, 7 Days to Die will log errors in the console window. You need to install the prefabs to the correct location, even if you aren't generating a new world or are playing on a dedicated server.

 

:smile-new:

Share this post


Link to post
Share on other sites

Yup, did that after I posted that, worked perfectly. Now to get my friends to give it a quick try lol. Thanks for the help! Look forward to playing with this :D

Share this post


Link to post
Share on other sites
Yup, did that after I posted that, worked perfectly. Now to get my friends to give it a quick try lol. Thanks for the help! Look forward to playing with this :D

 

Brilliant, let me know how it works out for you and any feedback :D

Share this post


Link to post
Share on other sites

After installing this, it seems that when I find nodes that I think are potassium nitrate, they're actually zinc. Also, the "resourceZinc" item I pick up from these nodes and loot has no icon in the game. When I look at my webmap for my server, I can see the proper icon in player inventories.

 

Does this mod overwrite all potassium nodes, or have I just not actually seen potassium nodes yet and these are using the same model? How do I get the icon(s) to appear in the game? BTW, I've already copied the icons to my local icons folder for my client, no change.

 

**EDIT** Nevermind, I'm a fool and didn't place the mod into my mods folder.

Edited by Skizzo316 (see edit history)

Share this post


Link to post
Share on other sites

Mod updated to v1.01:

 

  • Rebalanced copper yield (doubled)
  • Rebalanced zinc yield (halved)
  • Rebalanced excavators (reduced quantity of precious ores, add non-ore coal)
  • Added a recipe that copies the cement mixer's crushing of small stone into crushed sand to the rock crusher
  • Rock crusher queue can now hold 10 jobs
  • Updated and refined several item icons

Share this post


Link to post
Share on other sites

This mod looked pretty interesting and I saw you just updated it so I went to download it. The link on the main page says it is to v1.01 but the file it gave me says "MeanCloud__Mining_v1.00".

Share this post


Link to post
Share on other sites
This mod looked pretty interesting and I saw you just updated it so I went to download it. The link on the main page says it is to v1.01 but the file it gave me says "MeanCloud__Mining_v1.00".
Sorry about that!

 

I've fixed the link to point to the newest 1.01 version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...