Jump to content

Xbox series controller


Recommended Posts

I have been playing since alpha 15 and love this game. I have played with my xbox 360 controller, then an xbox one controller. Now I upgraded to two xbox series controllers. They both fail to work correctly in 7 days. If I enable direct input in the launcher they work but only for a few minutes in game then stop working. If I disconnect the controller by turning it off and then back on again it works for a few minutes and then stops responding. This doesn't happen in other games. The controller work fine.


Steps I've tried so far: enable direct input, tried my modded version and vanilla version of the game. Tried verifying integrity of files. Tried a clean install. Tried removing other usb devices. Rebooting pc. 



Link to comment
Share on other sites

Here is the log, it happened at about 0555 in the game. I immediately logged out. It does not happen when the controller is wired. I can use xbox one controller with no problems. This only affects the newer series x controller. It will stop responding and then resume sometimes after a second or two or a few minutes. This only happens in this game. thanks 


about 0555 in the game




this time at 0618



Edited by Onewondershoe (see edit history)
Link to comment
Share on other sites

Thanks. The logfile shows the controllers being added but there is no error when it drops out.


One possible cause: There was a bug on AMD 400 to 500 series motherboards with USB connectivity often dropping out. THis bug was found and corrected by AMD in March and should have resulted in BIOS updates for your motherboard being available somewhere in April or May.

In other words: Update your BIOS and make sure the new BIOS has AGESA version or newer.


**IF** that does not help it might be a Unity issue and I would suggest making an official bug report (see the link in the green banner above)


Link to comment
Share on other sites

Side note for amd bios issues. I have an amd 500 series mb and suffer from usb power issues. I have installed the latest bios beta of from Asus and still suffer from bios power issues unless I use a powered usb hub. So if you are using one of these motherboards, try using a powered usb hub before giving up. The newest bios is an improvement but the problem is far from fixed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...