Jump to content

Could not load file SharpSvn.dll


Leolowen
 Share

Recommended Posts

Im trying to download/install DarknessFalls version 3.3 for 7D2D Stable version 19.3 and i keep getting "Could not load file or assembly 'SharpSvn.dll' or one of its dependencies. The specified module could not be found." Now i looked up what i could and saw someone mention i needed Microsoft C++ 2010 Redist, so i installed that. but i still get the error. it happens when i try to presync, this is a fresh install of the modlauncher, and fresh install of 7d2d so i cant even get the mod installed on it. 
https://imgur.com/a/pH2Zo7v

Link to comment
Share on other sites

I'm not 100% certain but this looks like an issue with the Mod Launcher, not with Darkness Falls. That DLL is the one that you would use to access SVN (an older version control system, similar to Git). I think the Mod Launcher uses it as a library to access some of the mod repositories.

 

@sphereii Maybe you could weigh in here, since you authored the Mod Launcher?

Link to comment
Share on other sites

On 2/24/2021 at 12:18 AM, Leolowen said:

Im trying to download/install DarknessFalls version 3.3 for 7D2D Stable version 19.3 and i keep getting "Could not load file or assembly 'SharpSvn.dll' or one of its dependencies. The specified module could not be found." Now i looked up what i could and saw someone mention i needed Microsoft C++ 2010 Redist, so i installed that. but i still get the error. it happens when i try to presync, this is a fresh install of the modlauncher, and fresh install of 7d2d so i cant even get the mod installed on it. 
https://imgur.com/a/pH2Zo7v

https://www.microsoft.com/en-us/download/details.aspx?id=13523

 

You need this, then the mod launcher will be happy.

Link to comment
Share on other sites

  • 4 months later...
On 3/3/2021 at 12:31 PM, sphereii said:

https://www.microsoft.com/en-us/download/details.aspx?id=13523

 

You need this, then the mod launcher will be happy.

I tried to download this, but windows said that this download is no longer available, any assistance with this would be greatly appreciated. I am having the SharpSvn error as the person before me was. Thank you.

Link to comment
Share on other sites

  • 6 months later...

Thanks for the identifying and re-hosting this solution; Visual C++ Redistributable Packages.  It has reconciled issues  for a few of my players and got them into either Darkness Falls and Ravenhearst. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...