Jump to content

Cannot load mod - Unity error -. has a higher serialized file version


Recommended Posts

I think it may be because I built the files in the wrong Unity version. I think it was 2019.2.x. So now I have tried to build the files with older versions, for example; 2019.1.4, 2019.1.2 and 2019.1.14, but I do not get the option anymore to build the file. Even though I have imported the asset MultiPlatformExportBundles.cs file. I have done this so many times and cannot understand why it is not working anymore.

Link to comment
Share on other sites

If you dont have the option to export the finished prefab it is either because the multiplatformexport script isnt added to the new project or that script is being blocked from running due to another script erroring. Check the console in unity and delete the listed bad scripts from the project.

Link to comment
Share on other sites

906529987_UnityPackageManagerError.jpg.f0d6052d4ed106ca46356323635c41fa.jpg

 

1913949512_Unityprojectinvaliddependencies.jpg.bff97c99456dca7450dc8f58b5ce85eb.jpg

 

If you dont have the option to export the finished prefab it is either because the multiplatformexport script isnt added to the new project or that script is being blocked from running due to another script erroring. Check the console in unity and delete the listed bad scripts from the project.

 

Thanks for answer. I will try to do that!

Link to comment
Share on other sites

I updated the Tutorial2019.1 project. Not sure why you got errors but i rebuilt the project just in case.

 

I do not really know why either. The problems just started out of the blue, cause I am 100% sure it worked earlier with the same build. I have read about it when I searched up the problem on google: https://forum.unity.com/threads/package-manager-strange-error.659809/

 

Anyway, renaming that json file was a solution.

 

And

 

The alternative is to make a backup of the json file and then delete the lines in the manifest.json file with the packages that can't be found, ie:

 

 

com.unity.2d.sprite

com.unity.2d.tilemap

com.unity.modules.androidjni

com.unity.package-manager-ui

 

 

 

 

Link to comment
Share on other sites

So... Hi.

 

i have the exact same error message (Cannot load mod - Unity error -. has a higher serialized file version)

 

but do not have any errors in unity. I get this in the console of 7DTD after loading my mod (it's a flag texture modification from Xyth tutorial).

 

Do not know if this is a hijacked or not but i didn't feal creating a thread while there's another one with the same title three post bellow

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...