Jump to content
  • Buried chest circle not visible on Linux


    Accepted buried supplies quest, traveled to location, clicked exclamation mark. No circle appeared.

    Started digging, circle moved a couple of times. I see some yellow distortions, but not a solidly visible line as before in A19.

    Log: https://pastebin.com/h1QKKxJ2


    Quit game trying to restart, because it was using lots of memory. Forgot that existing game fails quest.

    Quest marker remains on the map, can not be removed or hidden.

    User Feedback

    Recommended Comments

    I have this same issue, Ubuntu 20, using GLcore.

    Tried in Win10 (same machine, dual boot), and the circle appears.


    You DO hear the sounds of the circle shrinking, but it doesn't show.

    Just tested, and yep, using Vulkan the circle IS there.

    Switch back to GLcore,  nope, no circle at all.


    NV 1080, using their drivers, latest avail.



    Link to comment
    Share on other sites

    Same here, didn't see the circle at all with GLcore. Haven't tried vulcan yet, because the launcher says "not fully supported".


    At least you can see if you are inside the unvisible circle by the flashing red chest symbol on the compas.


    Also noticed very high memory usage under linux. Was at ~18GB JUST for 7d2d, when i exited the game.

    Link to comment
    Share on other sites

    Sometimes you can see it flashing, and when digging same thing if you're on the spot where it would be, it pops in.


    Keep the icon red as you dig, and when the circle would be gone, you do get the icon on the ground showing where the chest is.

    (that's new)


    I don't use vulkan because of the warning, but tried it just to test, and yep the circle is there. (performance was ugh, but..)


    Link to comment
    Share on other sites

    To follow up I switched it to Metal (not supported yet) like the others were switching to Vulcan and the circle appeared but the zombies trees and other renders were messed up.


    Link to comment
    Share on other sites

    I can confirm this occurs 100% of the time on Mac (x86) using the default OpenGL renderer.  Here is a screenshot where you can see the tiny bit of the orange circle that flashes off and on.




    On a hunch, I turned off temporal anti-aliasing, and the bit of the orange circle that was rendering disappeared entirely.

    Link to comment
    Share on other sites

    15 hours ago, BasicallyACat said:

    This doesn't help Mac users.


    When @cheebsco says confirmed, that's a courtesy to us, to let us know that TFP testers have successfully reproduced the bug.  That's the first step to getting it fixed.


    Since you mention it, I can confirm Galaktus's finding that the orange ring does render when using the Metal renderer, although that's not supported and has other major rendering issues.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...