Jump to content

Resolution Error and black screen.


Recommended Posts

A few days ago, when I tried to launch the game, It gave me a Resolution error,

"Switching to resolution 0x0 failed, trying lower one

Switching to resolution 0x0 failed, trying lower one

All resolution switches have failed" crashed. It also sometimes rather than 0x0 showed a large negative number like -14563635xn, I'm not sure how to recreate that.


After some googling, I tried reinstalling my graphics driver,

verifying the integrity of game cache,

launching without EAC/launching with GLcorerenderer,

made sure that it was set to use my card and not the integrated graphics,

reinstalling the game,

And using crl while launching to select the resolution (also used regedit to change the resolution.)


The only success i have had has been when changing the resolution to launch in windowed mode I get a black window, that otherwise seems to work perfectly. steam overlay works, and i can use all the features of it. But the game itself is picture-less. All the sound plays, and I have managed to start a new game, it loaded in completely, I could hear myself running jumping and punching the dirt.


Today, For some reason, im not getting the switching resolutions error, and when trying to launch in full screen i get sound, but i cant maximize it and there is no window. windowed mode is working the same and previously.



16GB ram

GXT880m (390.65) (before this happend I was running v 370.xx)

I havent tried installing a previous version of the driver.


Open to suggestions at this point.





Link to comment
Share on other sites

Not the same error, but i figured I would give it a try, no dice.


Several other youtube videos had very similar errors, but I only found one in english, and the solution was to uninstall d3dgear which I don't have


thanks for offering a suggestion

Link to comment
Share on other sites

Weird, cause the output log has the error and same exact error. OH! Its a laptop!! Here's something:



But if it isn't compatable, why is it installed.. Possibly a video driver version issue.


OH: Here's about switching the graphics:


Link to comment
Share on other sites

I have selected the card to be used instead of the integrated graphics.

Upon reading that thread, I checked and I still had drivers installed that came from the manufacturer. Its likely that was causing issues with the newly installed version. I was hoping that uninstalling and updating from lenovo would solve the issue but no luck so far, still the same symptoms.

Link to comment
Share on other sites

Having the exact same issue.


Resolution error notice. Game wouldn't even load

Updated nvidia drivers for 640M

Game now loads with black screen. Audio is fine.

Validated files with Steam

Reinstalled game


Game still only loads a black window with audio.


Before this, I had made no changes to my PC, just standard windows updates, etc.



Link to comment
Share on other sites

At least I'm not alone. you having issues with any other games? My others seem to work just fine.


Edit to this post: I didn't have them installed on my laptop, but i checked and a few other games built with Unity are showing the exact same symptoms. Im not sure how it works, but is there a unity library or driver or something I can update or repair?

Link to comment
Share on other sites

So, i found a bunch of posts on different sites with the same problems, and a lot of them had problems because of a second monitor, and suggested launching the game first, then plugging in the monitor. Seeing as I have a laptop I don't think this is my issue, but I replaced screens before, so I took out the screen, launched the game then repluged the cable. No change, Tonight Ill try using my desktop monitor and see if that has any effect.


One youtube video said he solved his issue (with a different game but same symptoms) by installing a previous version of the unity3d software. Ill give that a shot tonight as well when I get to a place with good internet.


This is quite frustrating. :upset:

Link to comment
Share on other sites

Ok, now I'm even more confused. If a second monitor is plugged in the game launches completely normally, if I unplug the second monitor, the game stays fine, but if i try to launch without a monitor plugged in it shows a black screen, I cant carry a monitor with me everywhere. Someone please help, I'm way out of my depth here.

Link to comment
Share on other sites

1. Be absolutely certain the client is excluded from Avast. This is detailed in the Sticky FAQ thread.


2. Disable the "Turn off hard disk after..." options for when you're plugged into power. This setting has caused issues for years.


3. When you updated the video drivers, did you download it from Nvidia and perform a clan install? If not, then that's probably your issue. The Speccy data makes it appear that you updated it via Windows Update.


I'm not finding anything else obvious, but you do have a few extra services for other tools you could try disabling to see if it makes a difference.

Link to comment
Share on other sites

1. 7dtd folder is in exclusions , also tried launching with shields disabled, no dice


2. done, no dice


3. Yeah downloaded from nvidia, uninstalled the drivers, rebooted and ticked clean install. They apparently released another update today, so I updated again just in case. no go on that either.


Let me know if there is anything you think could interfere and ill disable it to try it out.

Link to comment
Share on other sites


At the speccy info the video driver as: Driver version: Which is '390.65' with an approximate date of 12/29/2016. The GForce driver gives version 390.77 with a date of 1/29/2018. I know that 'laptop'/'branded' laptops can have their own drivers... so maybe try Lenovo's drivers?


Info on getting their latest



Their latest is from 7/27/2016...



One good thing is that you can have their website detect your laptops info and show you their latest.


We're all going on the presumption that the video system/card is good. I find it weird that it will work when he hooks up an external monitor, but doesn't when he tries the main display. To me this says something about it - that when 'forced' because it detects an external display it will work properly.

Link to comment
Share on other sites

A few days ago I did the video drivers through lenovo, and it put my version at 359.xx as the current version, no change in the issue. I don't know if i specified earlier, but when the external display is plugged in the game works fine on the laptop screen.

Link to comment
Share on other sites

Hello Bigbuda,


There could be a graphics switch at the front of your laptop - is it on?


2nd Post:


"What i would try is this this is to let Nvidia be assigned on running the game. The switching to the NVIDIA graphics depends on application profiles. If an application has no such profile, you can assign the graphics card manually:


Click Start and then Control Panel. Select Classic View from the left side of the window.

Double-click NVIDIA Control Panel.

Click View and next Add "Run with graphics processor" Option to Context Menu. Close the NVIDIA Control Panel.

Right-click the application title and select Run with graphics processor. Then, click High-performance NVIDIA processor."

Detailed for above:




This should ensure that 7D2D will be 'assigned' to run with the nVidia.


If any of the above isn't set - and you've set them - then try running the game again. If not then... Lets check the drivers:



If they're fine as shown in the link then.... Its probably prudent to run Lenovo's diagnostics. No use in trying other things unless we're certain that you're video is fine. The '2nd' option is to check a specific system. Its up to you but doing the 'first option' might be good and then doing the 2nd option for the graphics might be best. Not sure how long that'll take.

Link to comment
Share on other sites

I have had the same issue pop up once. If I remember correctly that happened when I tried to run on 720p fullscreen when my screen was set to 900p. Lowering my screens resolution to 720p solved the issue.


Anyway, I have recently written a tutorial on dealing with switchable graphics and 7DTD. You can read it here:



Try following these steps and see if the issue gets resolved. I have also tested this right now, and it works with a 2nd monitor attached and without it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...