Jump to content

Problem with some mods [XUi] Error while updating window group 'crafting'

Recommended Posts

Hello all, I'm totally newby in this forus but I have years read some of its topic. 🧐


I'm in love with DF but I'm a f**ing crazy with mods and I like play with than mods that I can... or that the game o the principal mod supported. 


Last two years I was add mods over DF and, as logical, I found problems and incompatibilities, then I started to touch some xml and investigate a litle bit about all of this. Now I usually make work almost every mod as I want, except if I have problems with interfaces (XUi, Mui, etc), models...


Now I have a problem, some weapons pack (over DF base mod) and I dont understand the reason. The weapons mod are ok, I tried it in vanilla, and the game load it is ok too, as long as I know (I checked the player.log, I'm not sure if exist another log more detailed). Even, I can pickup any weapon from creative menu, but when I search it to craft it I obtain this error: "ERR [XUi] Error while updating window group 'crafting'"


I looked up in this forus, in google, reddit, steam... Some people had this problem and achieve to solve it making a clean with the launcher of 7DTD, I tried it too... KO :( 


I was checked the window.xlm, xui.xml, controls.xml files, too. I thought that maybe Kaine made some changes over vanilla ones for DF and these are being affected, but I can find nothing.


I finally decided to post my problem because I have the same problem in another kind of mod just this morning. Last times I didnt have this kind of problems. I know that DF is a complete and complex overhaul of 7DTD and lot of things are different to vanilla, and mods are usually tested in vanilla, but I think that this problem will be relationated with something of my configuration or maybe with something new included in last version DF, v5.0.


Additionally, others similar mods are working with no problems... Even, in the same mods the ammo craft works right... Maybe the 3D model or something like this will be the problem? I'm very confused 😵


I know... too much text, sorry 😋. Behinde, I just paste the whole detailed infomation about all of this and if someone will give me some ligths I will apreciate it soo much. Thousand thanks in advanced!!


7DTD Version: Alpha 21.1 (b16) Compatibility Version: Alpha 21.1, Build: WindowsPlayer 64 Bit
System information:
    OS: Windows 10  (10.0.19045) 64bit
    CPU: AMD Ryzen 7 5800X 8-Core Processor  (cores: 16)
    RAM: 32689 MB
    GPU: NVIDIA GeForce RTX 3070 (8031 MB)
    Graphics API: Direct3D 11.0 [level 11.1] (shader level 5,0)


DF Version: DarknessFallsCore (


Mods with problems:



Devs Auto Miner


Mods without problems (for example):

A19 AlmTurret (Base)



The complete trace error (maybe someone understand something):

2023-09-08T07:59:58 142.520 ERR [XUi] Error while updating window group 'crafting':
2023-09-08T07:59:58 142.520 EXC Object reference not set to an instance of an object
  at RecipeUnlockData.GetName () [0x00015] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiC_UnlockByEntry.GetBindingValue (System.String& value, System.String bindingName) [0x0005d] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at BindingItemStandard.GetValue (System.Boolean _forceAll) [0x00013] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at BindingInfo.RefreshValue (System.Boolean _forceAll) [0x0001a] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiController.RefreshBindings (System.Boolean _forceAll) [0x00010] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiC_UnlockByEntry.Update (System.Single _dt) [0x00008] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiController.Update (System.Single _dt) [0x0004f] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiC_UnlockByList.Update (System.Single _dt) [0x0012a] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiController.Update (System.Single _dt) [0x0004f] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiController.Update (System.Single _dt) [0x0004f] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiController.Update (System.Single _dt) [0x0004f] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiC_InfoWindow.Update (System.Single _dt) [0x00000] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiC_CraftingInfoWindow.Update (System.Single _dt) [0x0000e] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUiController.Update (System.Single _dt) [0x0004f] in <d7dcfa4979674f179c13273f8b30b551>:0 
  at XUi.OnUpdateDeltaTime (System.Single updateDeltaTime) [0x00131] in <d7dcfa4979674f179c13273f8b30b551>:0 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...