Jump to content

ERR Task_CommWriterSteam (ch=0) & EXC Memory stream is not expandable.


Recommended Posts

After the A20.4 update I experienced this error while playing in my friend's world. When this happened I couldn't move a few blocks from my spot as I would just rubber band back.

Our solution then was for her to reload her world so I can rejoin because I couldn't find her in the Friends Tab in the server list.
After joining, my character has reverted back to a certain state. Not back to level 1 but like back a few days of playtime. Before the error I was lvl132 and completed several quests but after I rejoined, it's as though I never completed any quests. It's back to when we last logged out a few days ago but I couldn't remember exactly when. I'm lvl131 again BUT my inventory was saved for some reason.

Days later we played again and even without encountering the error, my character's progress doesn't seem to be getting saved aside from inventory related stuff like selling or harvesting items. We thought nothing of it and decided to do some quests, one of them being a Fetch & Clear, which means me getting a White River Supplies Box. Hours into the game and voila! I get the error again and now I have a permanent White River Supplies in my inventory.

Here's my log: https://pastebin.com/q9uLFmad
Here's my friend's log: https://justpaste.it/3hjel

I asked around in discord and so far their solution for me was to start fresh OR as one told me "try to eliminate duplicate hidden blocks" on certain places as told by the log with errors on them. Though he's not sure if that will solve it.
So far I haven't tried the blocks thing yet.
I'm asking around here too and in the Steam Forum if anyone encountered anything similar or something exactly like this.


Link to comment
Share on other sites

4 hours ago, DannyR said:

I'm asking around here too and in the Steam Forum if anyone encountered anything similar or something exactly like this.

I've seen a lot of issues when a player name has an unusual character in it.

Try asking your friend to change their playername from "Yves~" to "Yves". See if that helps.

Link to comment
Share on other sites

11 hours ago, P3rf3ctVZer0 said:

Try this seems to have some merrit 


Okay, I'll try that. Where's the profile though? From server you mean my profile from my friend's PC?
Also I forgot to add before: How will I know if and when the profile gets fixed? Is there some sort of line from the console I should look out for?

Link to comment
Share on other sites

Okay, I tried that fix where you put the broken profile in your local world and put it back in the world you were playing in and it worked!

However not long after fixing that bug, I encountered a new bug which seems to be the more common one, it's about the drones.
ERR NCSimple_Serializer (ch=0)" & "EXC Memory stream is not expendable

I saw a post about this so I tried to get rid of my drone by placing it in my inventory and leaving it in a storage box. I no longer have a drone but I was able to play after. Although I encountered that error again later on. But I just re-joined and things seem to be okay again. Now I feel like that error will just pop up randomly when I'm playing. Not sure what else to do. Plus we encountered another different bug that's quest related.

When we went to the location of one of our T1 fetch quest, my friend who's the owner of the quest, cannot see the exclamation point BUT she can see the prompt to start it. However when she was pressing 'E' to start it, nothing is happening. We decided to skip it and go to another quest, a T4 fetch & clear. When we started this new one,
my friends' white river supplies chest locations are broken. One of them told me that their white river supplies was 2.6km from where we are and my other friend told me that his white river supplies was at 0.0km and he eventually found it from a loot bag that a zombie in the POI dropped. While doing this quest, this is where I got that NCSimple_Serializer error once again.

My friend whose white river supplies was 2.6km away, figured that the game is pointing at the white river supplies from the previous T1 fetch quest. It might've bugged as we tried to start another different quest. But as she was on her way there, the text guide which is on the top right of the screen, disappeared. Then we thought that it maybe did that because she was too far from the quest area.

That was the last straw (or draw? I forgot the saying) for us. Since it's Day 98 in our world we've decided to just fight our last Blood Moon Horde and leave that world. We'll just come back if and when this crapstorm of progress-impeding bugs have been fixed.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...