Jump to content

Some custom sounds seems to not be working, no idea why...


Recommended Posts

for example, in my mod. My zombieGunner does not load the sound when he is getting hurt or dies. These sounds worked before, but now he is silent. The sounds are in the exact format as the other zombies I have and the other zombies work perfectly. I have tried various things, like adding the sound in unity again and doublecheck so everything is ok before I save. Used a wav instead of a mp3 file, shortened the sound.


Everything in entityclasses.xml and sounds.xml are as they should be.




    <property name="SoundRandom" value="gunnerroam"/>
    <property name="SoundAlert" value="gunneralert"/>
    <property name="SoundSense" value="gunnerattack"/>
    <property name="SoundHurt" value="gunnerpain"/>
    <property name="SoundDeath" value="gunnerdeath"/>
    <property name="SoundAttack" value="gunnerattack"/>    




<SoundDataNode name="gunnerpain"> <AudioSource name="Sounds/AudioSource_Sounds/AudioSource_Pain"/>
    <Noise ID="2" noise="11" time="3" muffled_when_crouched="0.5"/>
    <AudioClip ClipName="#@modfolder:Resources/robelotozombiesounds.unity3d?gunnerpain1"/>
    <AudioClip ClipName="#@modfolder:Resources/robelotozombiesounds.unity3d?gunnerpain2"/>
    <AudioClip ClipName="#@modfolder:Resources/robelotozombiesounds.unity3d?gunnerpain3"/>    
    <Channel name="Mouth"/>
    <Priority name="1"/>
    <maxVoicesPerEntity value="1"/>
    <LowestPitch name="0.95"/>
    <HighestPitch name="1.05"/>
    <LocalCrouchVolumeScale value="1.0"/> <CrouchNoiseScale value="0.5"/> <NoiseScale value="1"/> <MaxVoices value="10"/> <MaxRepeatRate value="1.8"/>


In the console this message will appear every time the game tries to load the sound:


7 days AudioManager LoadAudio failed to load audio source object for Audiosource/AudioSource name="Sounds/AudioSource_Pain

The other sounds for gunners work and they are of the same quality and even the same length, so what gives? :( It's weird...


Edit: I tried switching out the pain and death to attack sounds and then they work. But this is not giving me a clue to why the other sounds is not working. Seems I have to make new sounds for the pain and death sounds or something and pray that they will work. This is giving me a headache, cause now when I made a new zombie and made some new sound for it, the pain and death sounds will not work. But just as with the gunner, the other sounds work fine.

Edited by Robeloto (see edit history)
Link to comment
Share on other sites

OK, this is f*cking weird. Pardon my language. But what the hell is going on with this game?


If I use a sound that I know work and paste a little bit of a sound that don't work in the middle of the working sound and save. Saved as same quality and everything. But that did not work at all. It won't even play the part of the sound that worked before. Seems like it is so random on what sounds work or that some frequencies doesn't work well with the game. Anyway, this is weird and there must be someone that know what the hell this is about?


So furious....so so furious...

Link to comment
Share on other sites

I don't know, but some thoughts in case you haven't tried these:

- Try changing the AudioSource? Maybe to



- Maybe the sounds that don't work are not "centered" on the audio channels, like its full or more "to the left" or " to the right" and that's causing an issue?  Are these stereo or mono sounds?  I'd convert the source to mono.


- I have had some sounds (personal mods) that don't seem to get played in a19 and I have not investigated but I suspect their volume is/was too low.  Maybe there's a cutoff in the game for volume of the source sound?


- Maybe the version of Unity you're using needs updating (for some reason) to be compatible with a20?  It seems weird to me that it would fail to lad an audiosource, unless its a difference in how it was packaged and the Unity/game a20 version doesn't like it.  I would think all sounds would need to be updated if explicitly true, but maybe there is something special about this sound or how its formatted or something in your Unity its not liking or is different than the other packaged sounds. You mention "these sounds have worked before" but have you tried packaging up "sounds that already work today" and see if the "repackaging" of them causes them to stop working?  if so I'd suspect a Unity/game compatibility issue.. or maybe the "export asset bundle" script... I think the "template project" was updated for a20... maybe the export script needed updating and you don't have the most current version?  I haven't tried doing any sound related updates for a20 yet, just thinking.


edit: I have used sounds of varying lengths and have not noticed a "audio too long" problem.  Too short might more of an issue as it might just go "bip"


Edited by doughphunghus (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...