Jump to content

Can't start A19 with MAC


Recommended Posts

Hello guys, 


few minutes ago I installed the new A19 at my MAC about steam. But now when I start the game, the 7DTD icon appears in my Mac navigation bar and disappears after a few seconds – the game will not start anymore.

I already cleared my savedatas.


How can I fix it?


Thanks for help!

Link to comment
Share on other sites

Find in forum:


1. RIGHT-CLICK "7DaysToDie" application in Finder (see previous steps)

2. CLICK "Show Package Contents"

3. CLICK into "Contents" folder

4. CLICK into "MacOS" folder

5. DOUBLE-CLICK "7 Days To Die" executable

6. OBSERVE the game starts and plays. Whoot!


It´s work

Link to comment
Share on other sites



(For Alpha 19)

I've tried exactly that, but there is no executable file in the "MacOS" folder, only a file called "run.sh"


It just opens as a text file.


Even when I downgrade back to A18 (which still works there's still just that same file in there.


(I was going to make a copy of it, then upgrade.. but like I said it's still not there)


Any suggestions?

Link to comment
Share on other sites

Sorry, maybe I did not explain myself well:

- you start the game from steam
- select "show game launcher"
- click "tools"
- click "open game folder"
- right click on the app
- follow the steps I mentioned

It opens a "Terminal" window for me and starts the game

It works for me

If I can help you with something else, tell me

Link to comment
Share on other sites

So I've got a better "fix" for this than downloading the entire game..


* Right click the game in Steam, and click Properties

* Click the "Local Files" tab at the top of the popup

* Click the "Browse Local Files" button, which will open a Finder window (do not close the Steam Properties popup)

* Right-Click the "7DaysToDie.app" file and choose "Show Package Contents"

* Double-Click the "Data" folder

* Right-Click and Move To Trash, the folder named "Config"

* Back in the Steam popup window click the button: "Verify Integrity of Game Files"

* This causes the game to discover the directory you deleted (all 14.3MB worth of files) and re-download them

* Close the Steam pop-up and click Play in Steam as you normally would to run the game.


Hope this helps someone else not have to sit and wait for the entire game to download!

Link to comment
Share on other sites

That is a way better solution than re-installing the game from scratch.

P.S. Same for me with crappy fps on lowest settings possible. It runs fine for a few seconds around 40sh fps, then when you turn it goes down to like 2-5 fps and keeps like this for 3-5 secs Thant it is back to normal for few more seconds or until I turn the camera.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...