Jump to content
Sign in to follow this  
d-luX

Custom models are tiny

Recommended Posts

Posted (edited)

Hello everybody,

I've got a little problem and hope someone can help me.

 

For testing purposes I created a simple fence model in blender with the dimensions : x = 7m , y = 3m , z = 0.10m (R&S applied)

and imported the fbx to unity.

In unity the dimensions for the T_Block and T_Mesh_B are : 100 x 100 x 100 .

When i select my fence ingame the size is correct (Image1) but when i place my fence then it's very tiny (Image2).

 

Image1:

 

nL2xD6s.jpg

 

 

Image2:

 

xWk9EtX.jpg

 

Does anyone know what I did wrong?

 

Unity version : Unity 2019.1.0f2 (64-bit)

ExportAssetBundles:

 

using UnityEngine;
using UnityEditor;

public class ExportAssetBundles
{
[MenuItem("Assets/Build AssetBundle From Selection - Track dependencies")]
static void ExportResource()
{
// Bring up save panel
string path = EditorUtility.SaveFilePanel("Save Resource", "", "New Resource", "unity3d");
if (path.Length != 0)
{
// Build the resource file from the active selection.
Object[] selection = Selection.GetFiltered(typeof(Object), SelectionMode.DeepAssets);
BuildPipeline.BuildAssetBundle(Selection.activeObj ect, selection, path, BuildAssetBundleOptions.CollectDependencies | BuildAssetBundleOptions.CompleteAssets, BuildTarget.StandaloneWindows);
Selection.objects = selection;
}
}
}

 

Thanks in advance.

Regards Chris

Edited by d-luX (see edit history)

Share this post


Link to post
Share on other sites

I usually size it how I want in Blender and apply it. Then when I import it into Unity I uncheck Use File Scale on the right side in the Inspector area for the fbx file.

 

Scaling it in Unity should work though. But make sure you're scaling the child object(the mesh), and not the empty parent object.

  • Like 1

Share this post


Link to post
Share on other sites
Use File Scale on the right side in the Inspector area for the fbx file.

 

Thank you for the hint. It works so far. The placed fence has the correct size now.

But when i just select my fence the size is very huge.

Very confusing.

 

 

Share this post


Link to post
Share on other sites

What's you prefab in Unity look like? Sounds like maybe you got some scaling going on where it shouldn't be.

Share this post


Link to post
Share on other sites
Posted (edited)

I only imported my fbx , unchecked "Convert Units" , created a empty object (nothing changed except the tag and the name) and dropped the mesh into the empty object.

Thats it.

 

EDIT***

 

I don't know exactly what you meant with : "What's your prefab in Unity look like?" .

That's why i've uploaded the unity-file + assets

 

https://drive.google.com/open?id=15JKVp6Ue_jQzOLtISqbmkf_EEeu1HQTV

Edited by d-luX (see edit history)

Share this post


Link to post
Share on other sites

Lol, this is kinda funny and cute at the same time. I could barely see the tiny fence on the second image. :wink-new:

Share this post


Link to post
Share on other sites
Lol, this is kinda funny and cute at the same time. I could barely see the tiny fence on the second image. :wink-new:

 

I also had to laugh first, but it is still a bit annoying :cower:

Share this post


Link to post
Share on other sites

I made small video to show my problem.

There are two parts in this video.

 

[video=youtube_share;e467ZmmmGRs]

 

At 0:42 I havn't unchecked "Convert Units".

 

At 3:27 I unchecked "Convert Units".

 

Maybe i forget something?

Share this post


Link to post
Share on other sites

I got it, finally. :panda:

Instead of converting the model to fbx, I saved and imported the model as a * .blend file. And it works without problems.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...