Jump to content

7DTD - [Steamworks.NET] - Could not initialize GameServer


Recommended Posts


I have an rented server for 7 Days to Die, and since i updated to Alpha 18 it seems that it won't let the players connect and its stuck on initializing.

When i tried to connect it, it had "Server is initializing, please wait" and it was stuck forever, then i looked at my server logs and saw this:

[steamworks.NET] Could not initialize GameServer

Anyone came across this issue? - Looking for help.

Link to comment
Share on other sites

I have the same issue on an ubuntu box running from my home. Have tried a complete reinstall of both 7d2d via steamcmd. Have checked ports and firewalls. Have also tried a couple of different settings in config xml. Nothing seems to get it to connect to steamworks.

Link to comment
Share on other sites

The wiki misses out a core detail. In your firewall, you need to allow Steam's servers to connect to your server. They use three random ports, so you'll need to monitor your network traffic and see the connections your server attempts to make once it's loaded the map. You can find the IP's here: https://bgp.he.net/AS32590#_prefixes


For my Ubuntu server hosted by Hetzner in Germany, the dedicated 7 Days To Die server tries to connect to this steam server: so I allowed it through my firewall. If you have Ubuntu, I outlined what I did in order to find that IP: https://7daystodie.com/forums/showthread.php?127515-Ports-needed-for-Steamworks-NET

Link to comment
Share on other sites

The problem is fixed on my server.


the following line was missing




Look at the 'startserver.sh' script that is accompanied with the install.


For the past version of 7 Days it didn't seem to be necessary, but for the [A18] it does.

Hope it works for you as well.

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

Where do you add the export line? I can't find anything. I shut my server down to try and add some mods to it specifically:


CrosshairGoneWhile Aiming






When I went to start it back up it refused to initialize, when I removed all traces of all of the mods it continues to refuse to initialize. I'll gladly answer any questions you guys have.


I also have absolutely no idea where to put that export thing, I don't have a "startserver.sh"


Solved: For whatever reason when I shut down the dedicated server it didn't shutdown so therefore it was trying to use ports that were already in use. Found out when I opened task manager

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...