Jump to content

Help fixing dedicated after power failure, no sleepers


Recommended Posts

Last week we had some rough storms roll through causing a power outage. I wasn't home and my UPS didn't hold it the entire time so the server got dumped. After we spawned in as many have experienced the day had been reset to day 1. As any good admin would do I ignored my backups and just set the time to where it was when we left. All seemed well we played for a few days building, mining, and such. Last night we decided it was time to venture out for some brass and noticed not a single sleeper was spawning in any building. Sadness overtook us and we wept :sorrow:


I took to the internet, someone must have a solution... But no solution was clear other than erasing all region files and starting fresh. This option isn't going to make anyone happy so if we can't figure out how to fix what we have we'll probably just stop till alpha 17 releases.


Looking for a way to get this back up and going. Here's what I've done so far.


--Reading that the region file is where this info is stored I figured out which region files contained our base and loot. Copied those out of the folder, restored pre-broken backup, then replaced only the region files that contained our main base. My hope was it would fix all the chunks around us without breaking our stuff. But best I can tell it made zero difference, even heading way out I still get no sleepers.


--As a test I deleted all region data and spawned in and sure enough sleepers spawn as they should.


--I also read after you clear the region data and get them spawning again you can copy your old data back in and they will continue to spawn. This didn't work for me.


That brings me to hopefully someone more experienced than I with the dedicated side. Any suggestions for fixing this? :help:

Link to comment
Share on other sites

Yeah, the power failure probably messed up the timer data for respawning entities.


In the testing I did for this a while back, the only sure fix was to completely wipe the affected region files and let the game re-generate them from scratch.


Ultimately I ended up clearing all region files except the one that contained our base. It seems to have fixed it. Positive here is we have fresh loot :D

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...