Jump to content

Mac Crashing/Freezing

The Conquest

Recommended Posts

The main issue that I want to address is an issue causing frequent crashing on Mac High Sierra. All of the following descriptions are of issues surrounding single player worlds that do not have any mods on them. I was playing last around August 2017 with no issues of this sort. I came back from a break back in January 2018 on this OS and have since had issues with crashing of various frequencies (not to imply this is a definitive cause, but this is the biggest difference I can think of). Part of the issue is that it is not a true "crash". Instead it freezes for a second or so, returns to normal for a second, then freezes and never unfreezes, but it does not ever truly crash. It will stay frozen indefinitely if I let it. I can force quit and reopen the game but I have found it places me in locations I was as much as a minute before the "crash". I have not been able to figure out one thing that consistently reproduces the crash and it does not happen on a consistent interval. The only thing I have found in the logs from when the game freezes is that it says "Receiving unhandled NULL exception/Obtained [some number of] stack frames." This is what happened at the end of my logs posted below.


I have tried uninstalling and reinstalling the game, verifying file integrity through Steam, and finally starting a new world, but none of these worked. I tried EAC just in case but it also was not that. I have searched the forums and online and have not yet found anyone talking about the same issue I have.

I don't think I have left anything out, but if so I'll be happy to find it and include it. I have not posted system specs because I have used this system without issue in 2017, but if that turns out to be relevant I'll be happy to post them.

Thanks in advance

Link to comment
Share on other sites

Unfortunately, I don't have a lot of support fo Macs. Not that I don't like them, I just can't support charging 3-4x what the hardware should cost just because of the OS it comes with. I keep saying I'll build one, and then never get around to it.


Here's what I can see in your logs though.


1. You are at Minimum recommended for RAM. It's sad that 8GB has been the "standard" for so long. This game can bottleneck really easy when you have less than 12GB. (Min Req is 6-8GB, Recommended is 12-16GB) When that happens, your RAM gets filled with calculations, and it overloads to Swap/Pagefile/Whatever Apple calls it. When you're writing immense amounts of calculations to your hard drive, instead of to RAM, it will cause the game to really tank the FPS. You'll get an FPS of 2, or even a complete freeze until your system catches up and stops using pagefile/swap.

Lowering graphics options and textures can help alleviate this some. So can running the 32-bit client.


2. You're using the OpenGL GPU. Not sure if that's intended or required for a Mac, but it's another possibility for issues. We recommend only using that when your GPU is older, or doesn't have good driver support.


3. The final error in the log seems to be an issue with the Unity Engine using OpenGL. Most of the info I can find on it though is circa 2015, and it was fixed in Unity 5.3-5.5. I found some stuff since then that points to an issue with programs that aren't able to do static linking, but my C# is too rusty to make sense of it.


My thought is that this may fit into the bug report section, but with the RAM limitations and OpenGL, it's possible that it's not really a bug.


If you could try without using OpenGL, and possibly monitoring RAM usage to see if it is indeed hitting that bottleneck when the issue occurs, that will help a lot in narrowing down the problem.

My gut says it's the OpenGL driver that's the issue, but more data and testing is needed to narrow it down.

Link to comment
Share on other sites

Doubt it's the RAM, especially as you're already running quarter res textures. Unfortunately without an actual trace from a crash or anything like that it's hard to tell what it could be. But indeed try running with the GLCore renderer, that's the only engine side change that might help IMO.

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...