Jump to content

adding extra terrain textures with UABE


Recommended Posts

I'm trying to add more terrain textures in asset TerrainTextures.


All surfaces consist of pairs of textures, in my case called them "undClay.tga" and "undClay_n.tga" (it's underground clay without green grass on ground from A10)


- to designate them the numbername of texture i added line in the text file ta_terrainxml.txt in asset BlockTextureAtlases.

- in asset TerrainTextures I added these textures, and prescribed them in an array of asset.

- in block.xml I use a new number textures for created block.


But when the game is loaded I get in the console:


Exception: TextureAtlasTerrain: couldn't load diffuse texture 'undClay.tga'

at TextureAtlasTerrain.LoadTextureAtlas (Int32 _idx, .MeshDescriptionCollection _tac, Boolean _bLoadTextures) [0x00000] in <filename



at WorldStaticData+Class176.MoveNext () [0x00000] in <filename unknown>:0

at GameManager+Class137.MoveNext () [0x00000] in <filename unknown>:0

at UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) [0x00000] in <filename unknown>:0


looks like I missed something, there is something else - outside of these assets.

maybe Assembly-CSharp.dll not using a more larger array ?


Anyone successfully added terrain textures?




Yes, this method works. I managed to add a one pair of textures in A15exp...but only one pair, because one place was loose relative to the A14.




By substitution, i create one new texture for coalOre, and Sulfur - check it out !:






Some links to thread on the same topic:




please who else can help with information about this?



now UABE support MIPmaps!



Link to comment
Share on other sites

  • 4 weeks later...

I continue to experiment with the substitution of texture bundle TerrainTextures.


I came across this problem:

- after import (load in plugin) a texture in asset it is displayed differently - it seems as if have no mipmapping ...





For the experiment, i exported a pair native textures ("forest_ground.tga and forest_ground_n.tga") and load then is back with no changes - and got the same result.


Settings in plugin i didn't touch - they were the same. I tried to use TGA and PNG....

is it possible that UABE after export does not prescribe texture settings ?

(change and return back the settings of the textures also do not solve the problem)


From the point of view of the bundle nothing was going to change....





UPDATE: but if i export and import RAW(even if from another bundle) - then it works, but in this case I can't redraw the texture and change parameters...

Link to comment
Share on other sites

Oooo... -i'm starting to feel himself an inconsiderate person, when I dug up threads that have already researched similar problems. And usually it so happens that DerPopo already answered these same questions.


hmmm...the search bad on this forum...:uncomfortableness:

Link to comment
Share on other sites

  • 8 months later...

I came across this problem too


I use UABE texture2d plugin to export a png or tga and then load it back with nothing changed, but in the game i see a whole black image instead of the original one.


With this thread help,i made a new picture asset file with unity ide compile,and then load the asset with UABE,and export raw dat and then import raw dat to the asset to be modified, finally successed! so there must be something lost with texture2d plugin!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...