Jump to content

Xpath APPEND Possible bug with skill-unlocked recipes? (SOLVED)

Recommended Posts

EDIT: Found a typo in the code (added an extra >) resolved by the suggestion to check the mod generated configs.

Hi all,


Added a new light recipe to the game using an existing model/icon. 

WITHOUT COMMA: When I use the following append, the skill requirement and tracking pages are borked per image 1

<!-- add electrical recipes to unlock code -->
<append xpath="/progression/crafting_skills/crafting_skill[@name='craftingElectrician']/display_entry[@name_key='electricianT1']/unlock_entry/@item">,HadeslightIndustrialRed></append>
<append xpath="/progression/crafting_skills/crafting_skill[@name='craftingElectrician']/effect_group/passive_effect[@level='25,100']/@tags">,HadeslightIndustrialRed></append>


WITH COMMA: When I add a comma (,) to the value, they appear correctly but there is now a ghost item added to the tracking page per image 2

<!-- add electrical recipes to unlock code -->
<append xpath="/progression/crafting_skills/crafting_skill[@name='craftingElectrician']/display_entry[@name_key='electricianT1']/unlock_entry/@item">,HadeslightIndustrialRed,></append>
<append xpath="/progression/crafting_skills/crafting_skill[@name='craftingElectrician']/effect_group/passive_effect[@level='25,100']/@tags">,HadeslightIndustrialRed,></append>




Edited by JasonX
Solved (see edit history)
Link to comment
Share on other sites

Ah, my bad. One, are there any errors/warnings when loading into a game to test it? Two, check the ConfigDump for the game save you are testing on and look at craftingElectrician in its progression.xml to make sure your changes went where you want them. You can find these in \AppData\Roaming\7DaysToDie\Saves\[MAP NAME]\[GAME NAME]\ConfigsDump

Link to comment
Share on other sites

Checking the generated configs in ConfigDump was a great suggestion - thanks.

It seems that I had added an additional > greater than symbol, as revealed by the generated configs:


        <unlock_entry item="generatorbank,electricwirerelay,switch,tripwirepost,ceilingLight01_player,industrialLight01_player,industrialLight02_player,ceilingLight07_player,HadeslightIndustrialRed,&gt;" unlock_tier="1">


Link to comment
Share on other sites

  • JasonX changed the title to Xpath APPEND Possible bug with skill-unlocked recipes? (SOLVED)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...