Jump to content

Error On Game Load - No Menu Shown


Recommended Posts

Hi Everyone,


Hoping someone can help with an error I'm experiencing.


Just to say, I have also posted onto the 7DTD subreddit as well:





I'm running 7 Days to Die Version Alpha 21.1 (b16).


On getting to the Title Screen, the console appears, states and error, and the main menu does not load. Just sits with the console open.

Here is a snippet from the logs with the reported error:


2023-10-21T14:06:04 10.802 ERR [XUi] Control parameter 'depth' undefined (in: depth="${depth|3}") --- hierarchy: windows -> window (editingTools) -> grid (SMXeditingMenuGrid) -> smx_mainmenubutton_1 (btnRwgPreviewer) -> rect (btnRwgPreviewer)
2023-10-21T14:06:04 10.805 ERR [XUi] Control expression can not be evaluated: pos|0,0 --- hierarchy: windows -> window (editingTools) -> grid (SMXeditingMenuGrid) -> smx_mainmenubutton_1 (btnRwgPreviewer) -> rect (btnRwgPreviewer)
2023-10-21T14:06:04 10.807 EXC missing EndOfFile at ',' at line 1:6
  at NCalc.Expression.Compile (System.String expression, System.Boolean nocache) [0x00099] in <6a1f467c46bd49918ade7b123666cbf1>:0 
  at NCalc.Expression.HasErrors () [0x00015] in <6a1f467c46bd49918ade7b123666cbf1>:0 
Rethrow as EvaluationException: missing EndOfFile at ',' at line 1:6
  at NCalc.Expression.Evaluate () [0x00019] in <6a1f467c46bd49918ade7b123666cbf1>:0 
  at XUiFromXml.parseControlParams (System.Xml.Linq.XElement _node, System.Collections.Generic.Dictionary`2[TKey,TValue] _controlParams) [0x000aa] in <d7dcfa4979674f179c13273f8b30b551>:0 


There are other errors in the log, of a similar "Control"/"UI" nature. I can post these, or the whole log, if need be.


Reading that above, it seems like there is some form of UI/control error that prevents the rest of the UI from loading. I'm not sure how to remedy that.


What I have tried so far:

  • Confirming Windows Firewall has the game allowed
  • Verifying game files
  • Complete game reinstall
  • Cleaning game data
  • Updating graphics drivers (though, not sure it would affect this)
  • Tried all three renderer options
  • Running the .exe as both Administrator and in Compatibility Mode
  • Installed the `lasted_experimental` build (still experience the error; reverted back to `stable`)


I performed another reinstall too, following this process (suggested from my reddit post):

  1. Uninstall the game
  2. Delete this folder "C:\Users\USERNAME\AppData\Roaming\7DaysToDie"
  3. Restart PC
  4. Install the game; then verify integrity of game files
  5. Restart PC again
  6. Run the game


Error still persisted.


Not sure if there is a more thorough uninstall that will remove any other settings that could be affecting the game.


I will say that I have had 7 Days installed for some time, and have just been updating with each new update the game has. I've not played for a few years.



Any help would really be appreciated.


Thanks for your time here.

Link to comment
Share on other sites

4 hours ago, Jugginator said:

The error is throwing on a mod-read, in the xui it looks like. Make sure there are no Mods folders in either appdata or the main game folder, somehow some residual mod code has been missed somewhere.


Hi Jugginator,


Thanks for getting back to me on this.


You are correct; both yourself and a user on Reddit (u/Ezekremiah) hit the nail on the head that it was something relating to a Mod folder.


The error was being caused by the presence of a folder called "Mods" in the install directory.


After this folder was deleted, the game now loads fine and shows the main menu.


I made the assumption that uninstalling would remove all contents from the 7DTD Steam folder. I should have checked rather than assume.



Really appreciate the help.

Thank you!

Link to comment
Share on other sites

Hey, you're welcome! Glad you got that sorted out and you can have some fun now :)


Thanks for responding back with that info, eventually we'll fully move on from using a Mods folder in the main install directory, interesting to know it doesn't get removed from an uninstall.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...