Jump to content

Connectionproblems to MP-Server


Recommended Posts


I have a problem with the multiplayer. In singleplayer I didn´t have this problem!


It doesn't matter which server I join, after a few seconds, or even after a few minutes, I don't hear any more sound, or the sound stays the same. Zombies don't react to me, the distance to other players doesn't change anymore.


Nothing is loaded anymore and as soon as I get into an unloaded area, where e.g. there is no grass on the ground, I fall out of the map.


I reinstalled the game, I tried Alpha20.5 and Alpha20.6, I was not only on my server but also on others AND I tried it on my laptop, same problem everywhere. Other players have no problems on my server.


I therefore assume that there is an error in my network.


I have Windows 11 on the PC and the laptop. Both use the Windows Firewall (on the PC I turned it off yesterday, with the same error pattern, so I don't think it's the Firewall).

The PC is connected via LAN and the laptop via WLAN to a Fritzbox 7530.


Do I have to open any ports?


I only have the problem with 7DTD, other games work fine.


Thanks for any help!

Edited by DocMichi (see edit history)
Link to comment
Share on other sites

Hi Star69,


thank you for your answer.


I forwarded TCP and UDP, and the issue is not fixed.


The logfile:




I discussed the problem with a friend yesterday. We went through a few more things so we turned off EAC on both the PC and the server, which didn't help.


The background is that I can access his server and play there without any problems. My friend doesn't have a game hoster, he rented a root-server where he manages everything himself. EAC was also switched off there.


I just joined my server and had the problem immediately. Only my starting chunk was loaded, the rest wasn't and if I left the chunk I fell off the map again, and I didn´t hear my foodprints.


We tried several servers yesterday, including a server I was on back then. Then the same thing happened there. The only difference is that I have since upgraded to Win 11.

We're really overwhelmed right now why it works on my friend's server, but not on all the others I've tried.

Link to comment
Share on other sites

Looks like your profile is corrupted, which is odd if this was your first time joining. The only thing odd that I see in your setup is that under disabled network protocals, yours is blank. If the server is not behind a nat, then I would put steamnetworking in the disabled protocols which forces it to use litenetlib which is less laggy. If you have forwarded the ports that I mentioned, use a free online port scanner to verify that they are indeed open. Sometimes certain routers can be ‘testy’ when it comes to opening ports and some ISP’s can actually prevent you from opening ports unless you call them. Lastly, if you’re running Windows Defender or another antivirus, you need to create exclusions for your game and saves folders.


Once that is done, you need to delete your profile from server. Go to your Saves->your world->seed name->players and there are 3 files containing your eos number which you can find in the log you posted. I would then bring up the game launcher, select Tools and you want to check the box containg worlds and player profiles then hit clean. ***This will put you at level one on the server and will delete any saved single player saves so if you have one that you want to keep, make a backup. Last item….verify the integrity of your game files at least twice to clear any corrupted files.

Link to comment
Share on other sites

The problem was due to IPv4/IPv6. My ISP made a change. I have seen that the problem has existed for years. Why isn't this fixed?


I now play over a VPN so I have an IPv4 address. It's a bad solution, but better than not playing at all. I was previously able to play on another server without any problems because a tool was installed there to avoid such an error. This is frustrating and I hope that one day you can play without a VPN.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...