Jump to content

A Player can't connect to server - SOLVED (corrupted player files)


Recommended Posts


Hello all,

I have a single player who cannot connect to our server. He claims that he was messing with drones and "notcied his weapon wouldn't switch so he disconnected" and now has gotten this error message in the same place every time.

For the record I have edited the Config xmls on the server, however this doesn't seem to be the issue as he can load up a single-player Navezgane file, and other players can connect to the server. I haven't had the opportunity to delete his player.dat file to try and have him connect but that's a really @%$#ty solution considering absolutely everything resets (kills, deaths, time spent alive, etc) and since this player has put the most time on this server I'd like to restore his progress.

Any ideas on what this can be? Seems to hang up in the dynamic mesh loading sequence every time. I tried changing all my dymesh/dynamic mesh settings while on the server and I couldn't recreate the issue.

Thanks for any help 😁

PREGEN10k map
GPortal server host
Restarts every-day

server.xml file below

<?xml version="1.0"?>
  <property name="ServerName" value="COVIDpunk 2077"/>
  <property name="ServerPort" value="26960"/>
  <property name="ServerVisibility" value="2"/>
  <property name="ServerMaxPlayerCount" value="10"/>
  <property name="ServerReservedSlots" value="0"/>
  <property name="ServerReservedSlotsPermission" value="100"/>
  <property name="ServerAdminSlots" value="0"/>
  <property name="ServerAdminSlotsPermission" value="0"/>
  <property name="ControlPanelEnabled" value="false"/>
  <property name="ControlPanelPort" value="8140"/>
  <property name="ControlPanelPassword" value="CHANGEME"/>
  <property name="TelnetEnabled" value="true"/>
  <property name="TelnetPort" value="8141"/>
  <property name="TelnetFailedLoginLimit" value="10"/>
  <property name="TelnetFailedLoginsBlocktime" value="10"/>
  <property name="TerminalWindowEnabled" value="true"/>
  <property name="AdminFileName" value="serveradmin.xml"/>
  <property name="EACEnabled" value="false"/>
  <property name="HideCommandExecutionLog" value="0"/>
  <property name="MaxUncoveredMapChunksPerPlayer" value="131072"/>
  <property name="PersistentPlayerProfiles" value="false"/>
  <property name="GameWorld" value="PREGEN10k"/>
  <property name="WorldGenSize" value="10240"/>
  <property name="GameName" value="Test1"/>
  <property name="GameMode" value="GameModeSurvival"/>
  <property name="GameDifficulty" value="3"/>
  <property name="BlockDamagePlayer" value="100"/>
  <property name="BlockDamageAI" value="100"/>
  <property name="BlockDamageAIBM" value="100"/>
  <property name="XPMultiplier" value="100"/>
  <property name="PlayerSafeZoneLevel" value="5"/>
  <property name="PlayerSafeZoneHours" value="5"/>
  <property name="BuildCreate" value="false"/>
  <property name="DayNightLength" value="180"/>
  <property name="DayLightLength" value="18"/>
  <property name="DropOnDeath" value="1"/>
  <property name="DropOnQuit" value="0"/>
  <property name="BedrollDeadZoneSize" value="1"/>
  <property name="MaxSpawnedZombies" value="64"/>
  <property name="MaxSpawnedAnimals" value="50"/>
  <property name="EnemySpawnMode" value="true"/>
  <property name="EnemyDifficulty" value="0"/>
  <property name="ZombieFeralSense" value="0"/>
  <property name="ZombieMove" value="0"/>
  <property name="ZombieMoveNight" value="3"/>
  <property name="ZombieFeralMove" value="3"/>
  <property name="ZombieBMMove" value="3"/>
  <property name="BloodMoonFrequency" value="7"/>
  <property name="BloodMoonRange" value="0"/>
  <property name="BloodMoonWarning" value="8"/>
  <property name="BloodMoonEnemyCount" value="8"/>
  <property name="LootAbundance" value="200"/>
  <property name="LootRespawnDays" value="0"/>
  <property name="AirDropFrequency" value="0"/>
  <property name="AirDropMarker" value="false"/>
  <property name="PartySharedKillRange" value="1000"/>
  <property name="PlayerKillingMode" value="3"/>
  <property name="LandClaimCount" value="1"/>
  <property name="LandClaimSize" value="64"/>
  <property name="LandClaimDeadZone" value="5"/>
  <property name="LandClaimExpiryTime" value="0"/>
  <property name="LandClaimDecayMode" value="0"/>
  <property name="LandClaimOnlineDurabilityModifier" value="4"/>
  <property name="LandClaimOfflineDurabilityModifier" value="4"/>
  <property name="LandClaimOfflineDelay" value="0"/>
  <property name="DynamicMeshEnabled" value="true"/>
  <property name="DynamicMeshLandClaimOnly" value="true"/>
  <property name="DynamicMeshLandClaimBuffer" value="3"/>
  <property name="DynamicMeshMaxItemCache" value="3"/>
  <property name="TwitchServerPermission" value="90"/>
  <property name="TwitchBloodMoonAllowed" value="false"/>
  <property name="ServerPassword" value=""/>
  <property name="TelnetPassword" value="CHANGEME"/>
  <property name="SaveGameFolder" value="d:\home\sid_590782\sevenDaysExperimental\saves"/>
  <property name="UserDataFolder" value="d:\home\sid_590782\sevenDaysExperimental\saves"/>


Edited by Baph
Additional info (see edit history)
Link to comment
Share on other sites

Also for the record I get this error when I try to modify a weapon/tool while inside the "vehicle mod" menu :


However, this does not crash my game nor 'prevent me from switching weapons/tools' as the other player has said.


This could also be due to the edits I made in the windows.xml, but all I did was add more slots to things.

Edited by Baph (see edit history)
Link to comment
Share on other sites

I'll try to get him to post the logs, could you tell me specifically what log files would be required?

The server logs have erased since it restarted last night, I can post the server logs once he reconnects?




Here is the current server log, but again the server automatically restarted last night so it doesn't include any logs of the player attempting to log in.

I will ask him to attempt connecting and I'll paste another pastebin with those logs when possible.

Edited by Baph (see edit history)
Link to comment
Share on other sites


This is what his logs are outputting when he attempts joining after resetting the crafting menu.

Also I reset our xml edits and all of our storage crates disappeared... It's almost like a chunk just reset to default... all of our progress is now gone..




This is the output of when he attempted connecting himself last night. It's definitely looking like our region file corrupted and we've lost everything cause I didn't anticipate this happening. Incredibly disappointed right now...

Edited by Baph (see edit history)
Link to comment
Share on other sites

  • Baph changed the title to A Player can't connect to server - SOLVED (corrupted player files)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...