Jump to content

Game Locks up Before Selection Screen


Recommended Posts

Using 17.3 for the world server (rented through a company) I have set up with friends since that was the latest stable release available at the time I set up the server.

Was working fine until Sept 11 2019. That day I got a Windows update that auto installed in my PC (Windows 10)


After it finished installing I noticed a minor issue in game with my window not showing the hotbar for my character. Otherwise game seemed to playing fine.


Figured exiting game and windows entirely and rebooting, assuming this would fix it.

It did NOT.



I booted back into Windows and started the 7 days game. It does the splash screen showing game title and after it closes that it opens a panel that I supposed is meant to be the panel for you to chose to start new game, continue game, join server, etc. But instead of a full sized panel there is a tiny bar https://i.imgur.com/4pvSvUE.png See Screencap. I have tried letting it run for five minutes or so to see if it was just some sort of delayed issue but it remains in that state until I close it out. Also confirmed other players on the server were having no problems booting into the game and joining the server.




Attempted fixes:

Re installing 7 days game

Verified integrity.

Switched from 17.3 to 17.4

Also un-installed the most recent updates to Windows 10

Then re-installing the updates. After each step, I re tested my game and kept getting same error.


All fail to change this error.


Here are the bug reports files for the day this issue started https://pastebin.com/gCATDe1J. The following day https://pastebin.com/MWQKHgdA.

and the most recent file https://pastebin.com/NVCJkyCV for comparison.



I have successfully played other PC games on this system in the meantime. So it does not seem to interfere with other games that are played through Steam.

Link to comment
Share on other sites

Also un-installed the most recent updates to Windows 10

Whenever you do this, you have to update your GPU driver because Windows places their own driver in that doesn't support Direct3D Acceleration.


It probably doesn't help that your GPU barely meets the min spec.

Oh, and from the most recent file,

"Forcing GfxDevice: Vulkan"

Vulcan isn't supported yet.


SO for starters, go here.


Download the driver.


Run it as administrator. (From the right-click menu)

Choose to not install GE Force Experience. (Because it's just bloat, and you have zero overhead for bloat with your hardware.)

Choose advanced settings. Ensure that the only boxes checked are as follows...


  • GPU Driver
  • Phys-X driver
  • Perform a clean installation.


Once it's all finished, reboot your PC.




Also, moving this to the support section since it's not a bug.

Link to comment
Share on other sites

Drivers Re-Installed


Thank you for the quick response on this. I hadn't considered this might be a driver issue. The Vultan detail was because I was experimenting with settings after the error presented itself to see if I could find a workaround. Since then went back to default settings.


I did as instructed and did a clean custom install using the details you recommended.

After rebooting it, it is still having the same issues.

So I still have the same issue with the weird bar thing presenting itself instead of a proper control panel to enter the game.

I do plan to upgrade my PC hardware when I have the chance but it seems unlikely that this was hardware alone doing this. I suspect there is some setting I still have missed or something I need to re install.


Any other suggestions would be appreciated.

Link to comment
Share on other sites

Still Broken New Info


On the day I was attempting to re-install the driver as instructed I noticed after the fact that a new Windows update auto installed on the 15th and also the 16th. This is odd cause I told the settings to temporary pause the updates to reduce any more complications to fixing the game but Windows auto installed anyway. I am unable to uninstall these updates. Each attempt fails with no specified reason given. I went ahead and did the driver install again in the hopes it would help but still no correction. The things I am thinking for a fix will be a total re-install of Windows (will have to do backups so would do this as last result) and / or updating my current Anti Virus package.

Link to comment
Share on other sites

Fixed it. Details Below.


I had to do a full format on the Windows partition where my game was stored and re-install Windows 10. I suspect I will have to change settings to disallow updates to prevent this from happening again cause it was time consuming with the additional backups of projects I had to do to do the re-install.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...