Jump to content

Getting "nullreferenceexception" on SP vanilla save. Can't log in.


Recommended Posts

Hoping someone out there can help...

I'm unable to log into my save file. Getting the nullreferenceexception error spam in infinity on log in screen for the save.

This is a current build save. No mods. Pure Vanilla.

I had played it earlier yesterday and came back in the evening and got this message.

I checked steam files. Deleted the entire game from my system and reinstalled. Turned off anti-cheat. Can't think of anything else to do.

Here is the link to the log file that last worked: https://pastebin.com/XXYVTEFM


Here is the link to the error log... Seems the 1.5mb is too big to upload so I've shortened it... https://pastebin.com/uzyXh5n7


Any help would be appreciated.



Link to comment
Share on other sites

This is just a guesstimate. but questions first.

When you started over did you also delete of keep same profile?


Prior did you have modded build on pc, SMX/ValMod for alpha 15?


asked because of your log


2018-07-15T01:28:09 6.556 INF Starting UserProfileManager...

2018-07-15T01:28:09 6.574 INF Texture quality is set to 0

2018-07-15T01:28:09 6.646 INF [MODS] Start loading

2018-07-15T01:28:09 6.649 INF [MODS] Trying to load from SMX ***************************

2018-07-15T01:28:09 6.681 INF [MODS] Loaded Mod: SMX (15b104er08) ***************************

2018-07-15T01:28:09 6.681 INF [MODS] Trying to load from ValmodIcons ***************************

2018-07-15T01:28:09 6.683 INF [MODS] Loaded Mod: Valmod Icons (5)

2018-07-15T01:28:09 6.683 INF [MODS] Loading done



at ItemStack.CanStackWith (.ItemStack _other) [0x00000] in <filename unknown>:0

at Bag.CanStack (.ItemStack _itemStack) [0x00000] in <filename unknown>:0

at XUiM_PlayerInventory.AddItemNoPartial (.ItemStack _itemStack, Boolean playCollectSound) [0x00000] in <filename unknown>:0

at XUiC_RecipeStack.GTG () [0x00000] in <filename unknown>:0

at XUiC_RecipeStack.Update (Single _dt) [0x00000] in <filename unknown>:0


It looks like a conflict of a custom item mod left over or in present user profile.

go to your userprofile\appdata\roaming\7dtdfolder

zip it

delete folder

start game

create a new chracter in profle editor

see if you get same error.


When you are about to start game hit F1 key to bring up console

now start.

If you see any Yellow lines appear read them, they may mean a leftover folder under your documents.

If you can log on then profile was corrupt or had leftover mod item pointers in it.

If you have a copy of a true Vanillia config folder, use Notepad++ and compare with yours to make sure

one of the files isnt a holdover from a modded play.


Best i can do to help trouble shoot,

Hope it helps.

Link to comment
Share on other sites

Yes, I had played several MODs previously. Looks like some residual from those. Darn. That sucks. I wish there was a way to make them all play nice.

Thanks for the suggestions. As I won't be able to play the same character with the method above, if it does work, I will just wipe my profile and start a new game. I'm doing speed challenge runs so it hurts, as this was a good one, but it isn't life ending...

THanks again for digging in there and helping out!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...