Jump to content

PC Can't place waypoints


Recommended Posts

ISSUE: Right clicking the map does nothing. Left clicking makes a noise but does nothing. the "Quick or Save Waypoint" option does not show up at all.


Hi. Not sure this is a bug as the other 3 people who downloaded the game at the same time as me in our house don't have this problem. I have uninstalled the game, restarted my computer & reinstalled it and still I can't place waypoints. In MP, I can see others waypoints and they can share them with me, but I can't create any in that mode either. I have searched the threads, but can only find a reference to this issue for Console. Apologies if there is a thread that has a fix for this already.



Not running any mods

Purchased & downloaded via steam July 2018 - version 16.4 (68)

Windows 10 Pro x64 bit

Processor: Intel® Core i7-6700 CPU @ 3.40GHz, 3408 Mhz, 4 Core(s), 8 Logical Processor(s)



Game runs fine and everything else appears to work. I just can't create waypoints - extremely frustrating. Thanks

Link to comment
Share on other sites

I suggest checking windows updates, Java and your GFX drivers.

Generally speaking, when I run into issues like this, the previous will fix.

Also, if you dig into your 7d2d folder via steam->Rightclick 7d2d, properties, browse local files,common there should be a "redistributable' file. Run that as admin and run the 'repair' option.

Also, holding alt, pressing tab, leaving 7d2d screen and alt-tabbing back in can help and so can window'd mode.

Link to comment
Share on other sites

Hi Pichii

Thanks for the reply, but I've worked it out thanks to a suggestion about altering control keys... I had changed the secondary action (right mouse button) to "P" as I like to use the right mouse button to interact with items which by default is "E". I've just reset the default controls and the waypoint options show up when right clicking the map. THANKS SO MUCH for your reply though. Greatly appreciate the potential fix :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...