Jump to content

Web Map - Problems signing in through Steam


Recommended Posts

I am running a locally hosted game on the latest Ubuntu server image. I've been using web maps successfully for quite some time but I took a break from playing for a few months. Now when I browse to the web map, it loads fine, but when I log in through steam, it returns a screen which states:


Login failed, click to return to main page.


I am sure that I am entering in my correct steam credentials and I have tried logging in using both my local IP as well as my public IP, which I have correctly forwarded to the web map IP & port on my router. I've tried using multiple game instances (ones that worked correctly previously as well as new seeds). I have triple checked web permissions and they seem fine. When I look at my output log, I am seeing the following errors:


2018-05-14T11:05:27 2961.622 WRN Steam OpenID login result did not give a valid SteamID

2018-05-14T11:05:27 2961.623 INF Steam OpenID login failed from XXX.XXX.XXX.XXX:53012


(XXX.XXX.XXX.XXX is in place of my local IP address)


When I log in using the internal IP, that IP is referenced in the error. When I log in using my external IP, the gateway (router) IP is referenced.


Any ideas? I'm wracking my brain here.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...